Stupid Steam!

By TimeParadoX ยท 12 replies
Apr 18, 2007
  1. Recently I tried to play a game on Steam ( Half-life 2 ) then after I double clicked to launch it I got a HL2.exe has incountered a error

    So I restarted and now I cant play any games on my steam

    I deleted Xfire because it kept crashing my games, Could anyone help me with this problem?


    Also my other games do not work, the ones that are not on Steam like Company of Heros
  2. Condor

    Condor TS Maniac Posts: 388

    you should alway restart your PC when a game crash to prevent further damage.

    my suggestion would be, try diskscan/check and see if it help =]
  3. TimeParadoX

    TimeParadoX TS Rookie Topic Starter Posts: 2,273

    I did restart my computer ;)

    Also how do I do Diskscan? Usually after a crash my PC auto run it on boot but how do I run it manually?
  4. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    This may be stupid, but make sure you have the correct DirectX installed...I had this happen to me after a format one :haha: !
  5. TimeParadoX

    TimeParadoX TS Rookie Topic Starter Posts: 2,273

    I do think this is a more technical issue Cfit :D


    I just tried to reload Steam and got this error


    Do you think this could have been caused by the recent Overheating I had?

    My videocard went crazy yesterday and went all the way up to 150f from the usualy 80 or 90f tempature

    My computer went very weird and the monitor started to go out of frequency then when I rebooted I had one of those "Caution triangle" things in my toolbar saying that Xfire.ini and Steam.ini were corrupted
  6. Condor

    Condor TS Maniac Posts: 388

    My computer > right click on your hard disk either C or D than go to properties > Tools and check the first one, let pc restart and it will check.

    not sure if that works for you, but when you said auto run, i assumed you're still running on window 98? =]

    and screw Xfire lolx, it crash my game sometime. I just wanna register my game on xfire, turn that thing off .
  7. TimeParadoX

    TimeParadoX TS Rookie Topic Starter Posts: 2,273

    I have XP, it ran it while the computer was still running and didnt have to restart

    I'll restart and see if steam works now, I'll be back in like 5 minutes


    I still get the runtime error, Does anyone know a way to fix this?
  8. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    I think you solved your problem :D ! Is that why your xfire connection went awry yesterday :suspiciou ?
  9. TimeParadoX

    TimeParadoX TS Rookie Topic Starter Posts: 2,273

    Yeah because it all messed up, That link you gave me about those templates for our new forum crashed me and caused me to over heat like crazy

    Also I did fix my .ini problems but it still gets runtime errors

    Do you think it's a problem with steam client or my computer?

    Because most of the time problems like this get fixed by patches like that one thing I had with Garry's mod about LUA files getting corrupted
  10. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    Steam is going through some problems and all....they are under ransom right now by some hacker.
  11. TimeParadoX

    TimeParadoX TS Rookie Topic Starter Posts: 2,273

    Are you super serial? :D

    I'll get manbearpig to go scare him

    If you're not serious then i'll just try and reinstall steam or something
  12. Grafficks

    Grafficks TS Rookie Posts: 302

    Haha, I remember that South Park episode. :D

    Above, you posted a screenshot of the error message you get when trying to run Steam. Do you get that exact same error message pop up when running non-steam games (like your Company of Heroes)?

    You could also re-install your Half Life 2 or Steam, and see if that works.

    Maybe you should also confirm that your HJT log is clean, to eliminate the possibility of this being a malware-induced problem.

    If all else fails, do a System Restore to the day before your HL2.exe crashed. That should do the trick.

    Good luck. :)
  13. TimeParadoX

    TimeParadoX TS Rookie Topic Starter Posts: 2,273

    I just uninstalled - reinstalled Steam and it had the same exact problem, do you think I could reformat my Hard drive?

    All my other games like Company of Heros does the same exact C++ error

    Also if I reformat do I lose everything and have to reinstall Windows or what?

    Or if I do system restore how do I restore it to 3 days ago?

    Because last time I restored my system on my other computer it completely trashed it and I had to get a new hard drive


    I do believe I have found the problem and fixed it, I do not want to jinx it so im just going to install a game like Lost coast ( since it's a small file size ) and test it, if it works then I fixed it and if it still doesnt work then im going to Valve's office and kick them in the balls! :haha:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...