Symantec Internet Security 2005 Internet Access Configuration Problem

By wlknaack · 45 replies
Feb 28, 2005
  1. I recently upgraded NIS 2004 to 2005 and no matter how I configure the Internet access for the program "Microsoft Printer Spooler Service," NIS 2005 randomly notifies me, via the pop-up in the lower right corner of the display, that "Rules are automatically configured for the program: Microsoft Printer Spooler Service." In addition, this pop-up notification continues to pop up and down for at least a half a dozen times before it goes away. No error messages are involved, and no other program is affected.

    It would appear to me that NIS 2005 does not recognize when the Microsoft Printer Spooler Program has firewall Internet access rules established. Thus, since it is a "safe" program, NIS 2005, automatically sets the rules, notifies me, does not recognize that the rules are set, so it sets them again, and the cycle is continued, over and over again until the Spooler program stops asking for Internet access. I guess that the apparent random nature of the occurrence of this cycle is correlated to the Spooler program requesting Internet access.

    I have been communicating with Symantec India, but it is like wading through a lake of alligators in order to get at that kernel of truth. Any ideas? I'll even consider the elimination of the notification function provided it does not affect the error & risk notification functions.
  2. ChgoBob

    ChgoBob TS Rookie

    Did you ever get a fix for this problem? I'm getting it too. Thanks,
  3. guru101

    guru101 TS Rookie

    thank god I found this thread.....

    Im suffering from the same problem.
  4. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    I have not yet found a solution. Surprisingly, the problem is occurring less frequently, but will not go away. I am living with it for now because the only help I have received from Symantec is to un-install/(safe)re-install NIS, which I prefer not to do at this time, and will do only as a last resort. I will post any solution I find.
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Did you completely switch off the XP firewall?
  6. guru101

    guru101 TS Rookie

    I have the problem, and XPs firewall is disabled. The problem occurs no matter what setting you set for the spooler (and I mean any).
  7. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    I echo guru101: The XP Firewall is off; no matter what program setting you have for the Microsoft Printer Spooler Program, NIS 2005 does not recognize the setting and, thus, continues to establish automatic access every time the program attempts to access the Internet, resulting in the incessant pop-up notifications. No other program is affected.
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Found this, maybe helpful:
  9. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Reply to realblackstuff

    Thanks for the input.

    I have two printers, Lexmark (default) and HP LaserJet. I was able to change from "spooling" to "print direct" for the HP LaserJet; I was not able to change for the Lexmark.

    When attempting to change the Lexmark, a notice appeared: "Printer Properties: Printer settings could not be saved. Operation could not be completed." Also, every time I tried to make the change with the Lexmark, the same annoying notice from NIS regarding the printer spooler program access rules kept appearing.

    I have switched the "default" to the HP LaserJet (which is now in "print direct"), and I will monitor events to see if this has any effect on canceling the NIS notice regarding the printer spooler program. I will post any changes I find.
  10. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Get rid of that Norton/Symantec crap.
    If you want a package, check out Trend-Micro.
    If you are happy with freeware, AVG7 from and Personal Firewall from or the free version of Outpost from
  11. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Follow-up to realblackstuff's input

    The Printer Spooler Program pop-up returned, so I removed the Lexmark and continued with only the HP LaserJet, which was in "print direct" mode, and the NIS pop-up regarding the Printer Spooler Program continued to appear. So it looks like switching from "spooling" to "print direct" does not mask the "glitch" in NIS.

    I have ZoneAlarm Firewall installed and running for some time now, and I have downloaded AVG for installation and evaluation, as I move to become less reliant on Symantec. Until then, I will continue to try to eliminate this annoyance.
  12. garracrema

    garracrema TS Rookie

    Symantec Internet Security is not the bad guy here probably

    I have been using Symantec Internet Security 2005 for 5 months and I have not had any problems until I installed a Lexmark All-in-One driver and software few days ago. After installation of the Lexmark Driver, I noticed the same pop up messages that you had. Since it was something new related with printers, I finally got the conclussion that it could be the Lexmark drivers and software. I also noticed that the Lexmark printer became my default printer. To test it, I just decided to make my other HP printer the deault. The problem was gone right away. I would suggest to verify if you removed completely any software or driver related to the Lexmark printer you had. Also, since the problem was with an All in one or multifunction machine, check if your HP printer is one of that type.
  13. guru101

    guru101 TS Rookie

    lol, I too have the Lexmark All-in-One driver and software..obviously related, maybe searching for an updated driver off Lexmark could solve the prob.

    I will say this, there was an update for NIS today, and Ive not had a pop-up since...could be wishful thinking tho ;)
  14. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    For Garracrema: To my knowledge, I do not have an all-in-one driver. The printers on my PC are single function, Lexmark Z65 and HP LaserJet Series II, each with their own driver. However, considering the possibility that Lexmark may be a contributor to the problem, I uninstalled the Z65, and reinstalled the latest software/driver. During installation the pop-up appeared, but I have not seen it since.

    For realblackstuff: Even after installing the latest Lexmark driver, I still am not able to switch from "spooling" to "print direct" for the Lexmark Z65.

    For guru101: I also installed the latest NIS update today and I, also, shall wait to see if the pop-up's days are over.

    I appreciate everyone's input.
  15. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Last ditch checkup: does the spoolsv.exe program have/want internet access in your firewall? Try giving it and/or try removing it from the firewall.
  16. guru101

    guru101 TS Rookie

    if you read thru the previous suggestions you'd have seen that this has already been done.

    for the record, the latest update didnt solve my issue. going to uninstall NIS and try AVG/Zonealarm.

    thx a bunch Symantec :unch:
  17. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Reply to realblackstuff

    First, the pop-up has returned with a vengeance.

    Second, I have sent an e-mail to Lexmark regarding the inability to change from "spooling" to "print direct," and I will post whatever results I get.

    Third, the NIS firewall has an automatic access procedure for programs it considers safe to allow them access to the Internet. You can also manually configure these "safe" programs to automatic access, deny, permit or remove. In the case of the Microsoft Printer Spooler Program, no matter what you set manually, the automatic access procedure either does not recognize the setting, or ignores the setting, and sets access to automatic. It then ignores or does not recognize that it, itself, has established the setting, resets it, and continually alerts you, via pop-up, of what it is doing. I have set the MPSP to every conceivable setting, to no avail.

    However, in reviewing the firewall configuration program in NIS 2005 in order to reply to your request, I got an idea which may work. You can turn off the "automatic program control," which then requires you to manually configure any program which wants access to the Internet. Well, once you have operated for a reasonable period of time with the automatic program control on, your most commonly used "safe" programs will have requested and gained access to the Internet automatically. For programs not in the NIS safe list, but used frequently, you will have been notified by NIS when the program wanted access and you would have manually and permanently set the rules for Internet access. Consequently, since I installed NIS 2005 on 2/21/05, in the intervening 6+ weeks, I most likely have established access rules for most, if not all, of my programs which require access.

    Consequently, I have 1) turned off the Automatic Program Control and 2) changed the Microsoft Printer Spooler Program access to "permit all" from "automatic." If this works, the only downside is that I will be notified by NIS when a program which does not have Internet access wants access, and I'll have to manually set the rules. As a last resort, with the Automatic Program Control off, I could remove the MPSP. But I do not want to do that until I learn more about the Lexmark situation (above). Whatever happens I'll post the results.
  18. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  19. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Update to previous post

    The experiment involving disabling the Automatic Program Control did not work. It reminded me of one definition of euphoria: "The period between the moment you had, and implemented an idea, and the moment you find out that your idea wasn't worth crap." What happened is that the MPSP popped-up and asked for manual configuration, which I provided, and then proceeded to pop-up over and over again, requiring me to take action with each pop-up, which is a worse situation than the automatic pop-up notification.

    I finally found out how to remove the Lexmark from "spool" to "print direct," and I now have both the HP and the Lexmark in the "print direct" mode.

    For now, I shall conduct business as usual with both printers in the "print direct" mode, the NIS 2005 Automatic Program Control enabled, and the MPSP set at "automatic." If and when the MPSP pop-up reappears, I will disable Automatic Program Control and remove MPSP from the Internet access list.

    I will keep you posted. If this doesn't work, all I can think of is to uninstall and safe re-install NIS 2005. In any event, I have ZoneAlarm and AVG up and running as an alternative to NIS 2005, should I give up on Symantec.
  20. guru101

    guru101 TS Rookie

    I'll keep watching with interest m8 ;)

    keep us updated, I'd like to see where this one goes....
  21. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Follow-up from previous post

    Both printers were in "print direct" mode, the NIS 2005 Automatic Program Control "enabled" and the MPSP set at "automatically configured." Within 24 hours the "MPSP automatically configured" pop-up reappeared.

    Continued with both printers in "print direct" mode, reset the NIS 2005 Automatic Program Control to "disabled". and reset the MPSP to
    "block all." Things looked good for a day or so, and then the "MPSP needs to be configured" pop-up, which requires action on the user's part, appeared (over and over again).

    Continued with both printers in "print direct" mode, the NIS 2005 Automatic Program Control "disabled" and MPSP removed from the program Internet access list. The "MPSP needs to be configured" pop-up reappeared (over and over again).

    So now I am back to where I started: The printers are in "spooling" mode, the NIS 2005 Automatic Program Control "enabled," the MPSP set at "automatically configured" and the "automatically configured" pop-up comes up whenever feels like.

    Unless someone has another idea, the only options remaining are live with the problem, uninstall/reinstall NIS 2005 to see if it eliminates the problem or, the one which is rapidly becoming my favorite, uninstall NIS 2005.
  22. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I repeat my 4-4-2005 post to you.
  23. guru101

    guru101 TS Rookie

    looks the way to go... puke: symantec :knock:
  24. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Follow-up to previous post

    I took the last shot: I uninstalled/re-installed NIS 2005. The MPSP pop-up reappeared after a day, popped-up several times on two occasions, and then went away. I assumed it was back and would randomly appear, but it has not been back for several days. Maybe the problem has been solved, but I'll wait awhile before making that final judgment.

    Something new has appeared, a window alerting me that my browser is seeking Internet access, and asking whether I want to grant it access. This has happen several times and, strangely, even when I am on the Internet, conclusively proving that the browser has already been granted Internet access. This is similar to the MPSP problem in that it appears that NIS 2005 does not acknowledge that Internet access has already been granted for a specific program. I set Automatic Program Control to give the browser automatic access, so we will see if it happens anymore. I hope I have not traded one problem for another.

    Reply to realblackstuff: I have installed and have been running AVG and I am very happy with it; I have had ZoneAlarm running for a long time, and I am also happy with it. I am also checking out Kerio and Outpost. As you can see, I am ready to transfer from NIS to these programs at a moments notice should the NIS problems continue. Question: You did not include ZoneAlarm in your recommendation, is there something about it you do not like?

    I will post a final follow-up once I determine whether the NIS 2005 problem(s) disappeared, or are back.
  25. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I don't like the Vector Engine in ZA, it is a resource-hogger. It also causes shutdown problems on some PCs.

    My favourite is Outpost, but is not for the faint-hearted, with its myriad controls.
    But both Kerio and Sygate do a good job with their free versions, better than ZA.

    On my PC I run Agnitum Outpost Pro (paid version). Nothing has ever passed it, IN nor OUT, without my personal consent. I am not paranoid, but I'd rather pay the mere Euro 23.- and have absolute piece of mind.
    It's a small price to pay.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...