1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

'Tampered' with msconfig and now I lost connection with my wireless router

By Kua ¬∑ 16 replies
Feb 18, 2008
  1. Hi

    I used msconfig to only disable those things which were'nt necessary: quicktime player, skype etc.

    When I rebooted I think I must have done something wrong. Msconfig opened up again and perhaps I made the wrong selection.

    Now I have lost the local area connection thing in the bottom right. Sorry to be so untechnical.

    Some other minor (I think) easily rectifiable things have happened. But I need the internet to solve most of them :p.

    I've tried to use the network setup wizard to set up a connection again but it says I son't have the necessary hardware. That said it wasnt me who connected that PC to the 'network'.

    I've just discovered system restore so hopefully in the future I'll be able quickly solve such problems. Although there is probably something I don't know about that.

    And by the way I did try reverting msconfig back to 'normal' but with no resolution. Skype and quicktime come back, but the things I need (and did not disable in the first place!) do not.

    What could I do?

  2. k.jacko

    k.jacko TS Rookie Posts: 483

    Well, why not try system restore? Go back to yesterday's config.
    Off-hand i can't think of anything that would halt your network connection. Unless of course you were messing around with any tab other than the STARTUP tab.
  3. Kua

    Kua TS Rookie Topic Starter Posts: 58

    Because system restore was turned off (seemingly thats the default!) until about 20 minutes ago (this happened yesterday).

    And no I didn't mess with any other tab - that's why I'm perplexed. BUT I might have made the wrong selection under the general tab. When I first unchecked the appropriate start-up applications and rebooted I was initially met by that tab. I remember being unsure of what to do and unfortunately I can't recall which selection I made (of normal, diagnostic and selective). I have a feeling it was something other than normal because this seemed to be a prompting to confirm my changes - so probably I went for selective, it seems logical to me.

    I also can't recall whether these problems occured before or after I made that choice - probably after. However reverting back to normal and rebooting did not provide a solution.

    Like I say I've lost zero config in the system tray - which is what I used to establish a link with my adapter and the wireless router (if that makes sense). But it also seemed to uninstall or in some way mess up my sound driver and I'm prompted to re-install that when I boot up (of course thats no problem if I have access to the internet and can find the latest driver).

    I just attempted installing the latest driver for my network adapter. This hasn't helped. That's very vague, sorry. I will try to explain further when my mind is feeling a little more 'serene'. (edit: but like I say, I have been using zero config - and intend to use it again - so should keeping my drivers updated matter at all, seen as I don't use the application that came with the adapter).
  4. jobeard

    jobeard TS Ambassador Posts: 12,494   +1,431

    first things first
    1- use the Dev Mgr to verify there are no red/yellow flags on the Network adapter.
    2- describe your ISP connection {dial-up, cable, dsl} and ALL the hardware from the modem to your system (brand name/models please)
    3- use run->cmd /k ipconfig /all to see what your TCP config looks like
  5. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Or run

    cmd /c ipconfig /all >Desktop\Ipconfig.txt

    And attach the ipconfig file created on your Desktop to here
    Sorry jobeard just wanted to throw that in. :)
  6. jobeard

    jobeard TS Ambassador Posts: 12,494   +1,431

    the dependencies are
    network connections
    Remote Procedure Call
    Windows Management Call​
  7. Matthew

    Matthew TechSpot Staff Posts: 5,270   +103

    If you simply disabled things in the Startup tab and didn't delete them, why not just go in and re-enable everything. Then, run a search on each individual item listed to be sure it isn't going to influence your system in a way you don't want it to.
  8. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,545   +429

    I believe he said (in the first post of the thread) that he already renabled those things and still has the problem
  9. Matthew

    Matthew TechSpot Staff Posts: 5,270   +103

    Touché ;).

    Sleep depravation for the loss :(.
  10. Kua

    Kua TS Rookie Topic Starter Posts: 58

    I've had a friend of mine give me some help with this. It seems that I had (and I can't imagine how) inadvertently set both zero config and plug and play to not run automatically. Having those back running has solved most of my issues apart from the main one: my internet connection.

    Now when I run the network setup wizard it acknowledges my Belkin Wireless Network Adapter, but absurdly it says it is 'disconnected'! To my mind that doesn't make sense.

    In order to have zero config and plug and play run automatically again, my friend directed me to 'services.msc' and I wonder if there are other applications (not sure I'm using the correct terminology) which need to be kick started again, for example Universal Plug and Play (I wonder if that will help network setup wizard detect my adapter correctly). I feel sure I didn't mess with the services tab in msconfig, but seemingly it had been affected.


    1. I have two instances of Microsoft GSM 6.1 Audio Codec. One has a yellow flag, the other does not. There are no other flags in the device manager. I think I need an internet connection to download a new driver. Although perhaps I could download it to this PC, put it on a pen-drive and install in there.
    2. I have a broadband internet connection. The computer I am posting from is connected directly to the Belkin 4-port wireless-G router (F5D5231-4, I think). My computer has a Belkin N Wireless USB Adapter (F5D8053).
    3. This just opened up a dos-style window (what's the correct term for this!?) 'Windows IP Configuration' which gave me no information.


    I ran 'cmd /c ipconfig /all >Desktop\Ipconfig.txt' but didn't attach the resultant file because it was empty(!)

    Thanks for your help on this one!
  11. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Start -Run: cmd /c ipconfig /all >Desktop\Ipconfig.txt

    Should give a Ipconfig.txt file on Desktop (please delete the old one first)

    Please test for me. I really want to know
  12. Kua

    Kua TS Rookie Topic Starter Posts: 58

    Yep it does give a ipconfig.txt file on the desktop - but its totally empty.
  13. Kua

    Kua TS Rookie Topic Starter Posts: 58

    Its my suspicion that there are other things in services.msc which I need to kick start (well set to automatic) and that that this explains the lack of content in the ipconfig file.

    For example until I set 'plug and play' to automatic my device manager was empty too!!
  14. Kua

    Kua TS Rookie Topic Starter Posts: 58

    I tell a lie: the ipconfig.txt file says 'Windows IP configuration'.

    Sorry to spam - I'll stop now. I just didnt want kimsland to miss anything :)
  15. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Thanks Kua I must step out, about I'll check out why this is happening later, unless others reply.
    As a quick thought, pretty sure it's in services.msc
  16. Kua

    Kua TS Rookie Topic Starter Posts: 58

    Yep me too. If anyone has the time to look through them, these are photos of the full list of apps (?) in services.msc. Perhaps someone could indicate which apps I need to set to automatic.




    I set Universal Plug and Play to automatic. But when I tried to start it, it came up with a 1068 error. But I will try a reboot now. Having said that I'm wary of messing with services.msc without advice.

    Oh and I'd like to take this opportunity to rant at the fact that System Restore isn't on as default in XP (at least it wasn't for me)!
  17. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    These are my recommendations.
    And don't post one of those horrible screen dumps again
    Next time write it all out. (like I have below - or would you like a photo instead)
    Oh and the Services have already been fully modified by someone

    These are my specific recommendations
    Do them all, restart, try again

    ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## OK
    Bonjour Core for Windows (Info Here http://developer.apple.com/networking/bonjour/index.html)

    Automatic Updates set to Automatic (personal choice)

    Fast User Switching set to Disabled if only one user

    Help and Support set to Manual no restart

    Logical Disk Management set to Automatic

    Logical Disk Management Admin Service set to Automatic

    MS Software Shadow Copy Provider set to Manual

    Netmeeting Remote Desktop Sharing set to Disabled

    Print Spooler set to Automatic if you have a printer

    Removable Storage set to Automatic

    Shell hardware detection set to Automatic

    Volume shadow copy set to Manual

    Window Imag Aquisition set to Automatic if you have a camera

    Windows Management Instrumentation set to Automatic (and start it)

    Windows Time set to Automatic (personal choice)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...