Task Manager Gone!!!!!!

By m.d.c skamonkey ยท 10 replies
Jun 6, 2002
  1. Seriously you guys my computer has fully gone off on one... pressing CTRL-ALT-DEL has NO effect any more!! i don't think i've changed any relevant settings... and going to help and support to get a link to taskmanager brings up an error that "this windows component is not installed"... SH*T!!! I also tried putting the required files from the XP Pro CD back into the system32 folder, but a) they were already there and b) running them manually had no effect... i've reinstalled windows to no avail, and i really wanna avoid a format, as i only did one last month and i'm still installing software from that one!! someone, anyone help!!


  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Try runing System File Checker (You'll need the CD). It will do kind of what you did, but on a more thorough scale.

    Start / Run / SFC

    If that does not work, then perhaps your registry is corrupted or has been tampered with. Open regedit (Start / Run / regedit) and check this setting first:

    [HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ System\DisableTaskMgr]

    Make sure it is not set to 1. If it is set to 1, set it to 0.

    Another idea is.. Do you have permission to use it? Since XP has many advanced user policies and services, it is possible that something has been muddled. If you login as administator or an account with equal power, can you still not use it? It might be kind of farfetched, but I'm sure it is possible to disable the taskmanager via the policy manager for lesser-users such as "guests" and "users".

    Keeping an open mind, this could also be a virus. So run a virus scanner if you have one (preferable updated as recently as possible).
  3. m.d.c skamonkey

    m.d.c skamonkey TS Rookie Topic Starter


    Thanks for your post man...

    Right here's what happened when i tried those things...
    SFC - Dos window opened then closed, investigating further...
    Regedit - That key (system) was not present, so i inserted it and the relevant value, to no effect.... doh.

    Virus checking now, update on that and SFC soon.

    Thanks a lot for your help so far.

  4. Tedman

    Tedman TS Rookie Posts: 39

    Bah, It would be easier if you just opened a comand prompt, so if you put in the wrong command it wouldn't just close. Try 'SFC /SCANNOW'

    Make sure you got the cd with you.
  5. m.d.c skamonkey

    m.d.c skamonkey TS Rookie Topic Starter

    thanks for everyone's help so far...

    got SFC working, no luck there,

    virus checked, didnt find anything...

    anyone got any other ideas *sniff*


  6. Justin

    Justin TS Rookie Posts: 942

    Hmm... that's very odd.

    Reminds me of a problem I had in win2k a while back, mysteriously I could no longer open any property page, but hours later I would get spawns of MFC or whatever (the thing that controls pages like that) that crashed. It happened right after I had disabled a bunch of services.

    Does it do this in safe mode? (i.e. are you able to open task manager in safe mode)
  7. m.d.c skamonkey

    m.d.c skamonkey TS Rookie Topic Starter

    hmmm - i did disable a load of services recently, but i thought that might be hte problem so i re-enabled them all...

  8. SuperCheetah

    SuperCheetah TS Rookie Posts: 709

    I had a problem similar to this recently also except when I disabled alot of the services I kept getting random blue screens. I ended up reformatting only because I'm too lazy to restart the services and I needed to reformat anyways. Now everything is fine.

    I would make sure and have a good understanding of the services and what each one does before I go disabling alot of them.
  9. m.d.c skamonkey

    m.d.c skamonkey TS Rookie Topic Starter

    yeah - i used a tweak guide - damn mofos killed my computer (yes i know everything i do is @ my own risk)... so you reckon i'm gonna have to reformat?

  10. SuperCheetah

    SuperCheetah TS Rookie Posts: 709

    You probably won't have to reformat as long as you figure out which services are screwing up your system. I would reenable the services one by one until you get your Task Manager back. Then you'll know which one is causing you problems. Look here for Techspot's great guide on services.


    It gives a detailed description of each services and what its functions are. I highly recommend it.
  11. tenbears

    tenbears TS Rookie

    I had a similar problem with task manager gone and no access to registry. I was going to formatt and went into bios to change boot sequence from HD to CD rom. When I restarted the computer I forgot to place the xp disc into the cdrom and the computer booted up in the normal sequence. Just for kicks I tried control alt delete and my task manager was back. I was also able to enter my registry. This simple mishap prevented a 3 hour ordeal to get my machine back running and I don't have a clue why the boot sequence would make my task manager and registry become inaccessalble. Hope this will help anyone with a similar problem. I'm running XP on EIDE 0 with 2- 100 maxtor ATA on RAID 0 Striped for mass storage
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...