1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Toshiba Gigabeat F10 - Not working, PLEASE HELP!

By Arlaun
May 31, 2006
  1. Hey, I am having trouble with my just brand new Gigabeat and was wondering if anyone could help me.

    I had the cradle plugged into the computer via USB cord and plugged into the power supply. My Gigabeat was on and I inserted the Gigabeat into the cradle. After a moment my PC regonized the outside device but acted strangely and had a message saying "Detected New Hardware" "Hardware could not be installed" and I was confused because I've been using the Gigabeat for a few minutes transfering music onto it and had taken it out of the cradle to listen to the new music placed on it to make sure it worked. Anyways, I took the gigabeat out of the cradle still on (I've done this a few times and nothing ever happened) but this time it said "System Error". I tried turning off and back on the battery and restarting up but it kept saying it. I tried a few more times but then it progressed to saying "No System Found on HDD"

    Please help. I've no idea at what to do with this and need much help.

    Thank you.
  2. IH8PunkRok

    IH8PunkRok TS Rookie Posts: 113

    ok ive been doing a little research on ur mp3 player (very nice by the way) and i cant come up with a solution for it however visit this address (i dont know how to make links sorry)...
    it allows u to find a certified servicer for ur mp3 player. they should be able to help. however im sure it will cost a little bit of money.

    good luck man
  3. Arlaun

    Arlaun TS Rookie Topic Starter

    What I ended up doing was just sending it back to the manufacturer and got a firmware upgrade and reinstall on the gigabeat. I believe what the problem was was I got a gigabeat at a electronics convention down in Vegas and between then and now the gigabeat creators made a newer firmware and gigabeat room software. So I got the new software and updated firmware and it's been working great ever since. Thanks for the tips--

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...