Toshiba Notebook and wireless network

By EdwardH ยท 6 replies
Mar 19, 2004
  1. I am running Windows XP Home edition on my desktop. I have installed a D-Link 604+ DSL/router., connected by Ethernet to the desktop. All works fine and Internet access is good. When I try to connect my Tosh via wireless I have the following problem (which D-Link themselves cannot solve):

    The IP address of the D-Link is

    If I set the Tosh to automatically pick up an IP address it picks one up one starting 169, and no connection can be made.

    I can force the Tosh to connect by giving an address of This allows me to connect to the desktop, share files etc. BUT I cannot access the internet from the Tosh, but I can ping external sites successfully from the Tosh.

    Something sems to be not translating web adresses into IP adresses. I have tried to tell the Tosh to use some DNS servers but still won't work. Have downloaded latest drivers for DLink and my Tosh wireless software is current.

    There was something similar to this earlier this year, but I have tried everything suggested to no avail. Could I have a corrupt version of Interent Explorer?
  2. me(who else?)

    me(who else?) TS Rookie Posts: 387

    I had the same problem with my turned out my cable modem wasn't plugged into my router might want to check that. Sometimes my modem spontaneusly turns itself off.

    You also might want to try Net Stumbler...there might be more than one WLAN network in your area. If there is, double click on the WLAN icon on your taskbar (when the connection is closed) and it will come up with a mist of available networks, but since you can connect to your desktop, this doesn't appear to be the problem.
  3. EdwardH

    EdwardH TS Rookie Topic Starter


    The router works OK for the desktop so connection to phone line should be OK.

    I can only see my network when I search for available networks so no confusion there I guess.

    It seems to be something to do with the notebook not being able to translate web adresses into IP addresses, or the router not allowing to do so. Spent 45 minutes on the phone with DLink's techsupport last night to no avail!!
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Make sure you enable NAT in your Router.
    In it's WAN-part, you set up your IP-address and DNS-IP-addresses from your ISP.
    In it's LAN-part set the router to fixed IP-addresses, ranging from to if that can be entered, else leave as is. Set the subnet-mask to

    Your PC's should be set to (and .3 and .4 etc.) each with subnet-mask
    The PC's default-gateway and the first DNS-server should both be set to (which is your router). You can leave the second DNS blank.
  5. EdwardH

    EdwardH TS Rookie Topic Starter

    tried that already, but still won't work
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    What OS is on the Tosh? W98 or ME?

    Try to set the Tosh DNS-configuration to:
    Enable DNS
    Host: the PC-name of the Tosh
    DNS-server: add
  7. EdwardH

    EdwardH TS Rookie Topic Starter

    Fixed it!!!

    I connected my laptop to the Internet via my old USB DSL modem. The connection was fine, but Explorere couldn't find any pages.

    Rolled back using system resore (XP) to January and tried again.

    All now works, including DHCP. Not sure if was IE or what.

    Thanks for help everyone.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...