1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Toshiba Software Modem Mystery

By halfasianmafia · 32 replies
Mar 17, 2005
  1. Hi everyone,
    I have a problem that is driving me insane. I'm using a Toshiba Satellite M35-S395 laptop and trying to connect to the internet via the Toshiba Software Modem manufactured by Agere. I should note that I am in Ukraine. I can use wireless networking and my network card fine to connect to the internet. I was also successful in using the software modem to dial up for a couple months, until it completely stopped working.

    The modem would not connect, then it would give me sporatic responses when queried, so I left it alone for a few months (didn't really need to use it). Now I'm in a situation where I have to get it functioning again.

    Here's the latest - When I set up a dialup connection and try to connect, I get DNS error 633: The modem is already in use or not configured properly. When I go to hardware manager and open up the modem properties, it says it is working properly. When I go to the diagnostic tab and query the modem, it says the port cannot be opened, which may be a result of a hardware conflict. In device manager, no other devices seem to be conflicting, however when I check the "show hidden devices" option in the "view" menu, one device is listed with the yellow exclaimation mark: "Serial" which says "This device is not present, not working properly, or does not have all its drivers installed". I don't know if that's related. Back to the modem. Here's a list of possibly relevant info:

    -Location: PCI bus 0, device 31, function 6
    -When queried, the log ends with "Opening the modem device failed with error 000005aa"
    -The resources are as follows - I/O Range 2400-24FF, I/O 2000-207F, IRQ 11
    -I notice that if i start in safe mode, IRQ is 04 (I don't know if this matters, maybe it's just because of ACPI, but there are several devices with IRQ 11)
    -Under Ports (COM & LPT) a printer port is listed, but no COM port
    -I can change COM port for the software modem under "advanced port settings" from COM 01 - COM 256 but regardless of which one I select, I get the message that the port has been opened by another application.

    I know this is a jumble of information, but I hope someone out there can make some sense of it and help me. This is pretty important to my work, and I don't have the money to hire someone over here to help out (I'm a Peace Corps volunteer, plus its an American computer so hard to find support in Ukraine). Thanks and let me know if anyone needs more information or has possible solutions!
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    COM1 uses IRQ4 at address 03f8h
    COM2 uses IRQ3 at address 02f8h
    You may have disabled these ports in the BIOS and/or in the Device Manager.
    Modems try to find COM1 and IRQ4 or COM3 and IRQ4, in most cases.
    You can disable COM2 or leave it if already disabled.
    Older modems have an IRQ and/or COM jumper on them, but I assume yours is probably a newer type.
    Perhaps give us the make/model-number if you can.
    Try and remove the PC-card from the PC and uninstall the modem. In Device Manager, tick the option Show Hidden Devices. That modem may be there in a few occurrences.
    Reboot without the modem. Then switch off, re-insert the modem. Windows should find new hardware and reinstall it.
    The modem could also show more than once in your network settings.
    Another place to check would be in IE/Tools/Internet Options/Connections tab.
    If that is not set to use Dialup you can't get through.
    Don't use proxies if you don't have to.
    Try these things out, hopefully they get you going.
  3. halfasianmafia

    halfasianmafia TS Rookie Topic Starter

    Well, i've tried a few things with no luck:

    -I tried going into msconfig and disabling all startup programs and processes except for what was essential to be able to query the modem in diagnostics. This was in hopes that some other program was occupying the port, and blocking access to the modem. I got it down to 3 startup services and 1 startup command, but I still got the message that the port was already in use when I tried to query the modem.

    -I've uninstalled the modem drivers in both normal and safe mode, being sure to catch anything outside of the device manager list (I found I had to uninstall the modem in device manager and also remove the drivers in the add/remove software window). I reinstalled the drivers both from my original toshiba disc and from a file downloaded from the toshiba website, but the problem was the same once I reinstalled the drivers.

    -When there were no drivers installed and I restarted the computer, it would detect a PCI modem

    -realblackstuff, thanks for the advice but I'm a bit unclear on removing the "pc-card" since I'm using a laptop. I've gone into bios and there are no com ports to disable or enable - same with the device manager. From what I understand, a pci/software modem creates com port 3 specifically for its own use. As far as using a jumper to change com/IRQ - I can't do this in xp with what I have. I can change the com port to anything from 1-256, in "advanced port settings" but regardless of what I select, it says it is being used by another program or cannot be open. I can't change IRQ or I/O range.

    -To reiterate, I'm using a Toshiba M35-S359 Satellite laptop with a "Toshiba Software Modem" manufactured by Agere.

    -Maybe since I was using it in a small town in Ukraine, the phoneline somehow screwed up the modem? I'm at my wits end and close to just buying a USB modem or something. Any additional help would be appreciated. I also found someone else with what sounds like the exact same problem at:


    -Opening up the guts of my computer I found an Askey Computer Corp modem, model 1456VQL4A

    Thanks for any help
  4. Triton

    Triton TS Enthusiast Posts: 82

    This problem sometimes happens after installing SP2 for Windows XP.

    Download the Toshiba driver for this modem.
    Toshiba Software Modem Driver for Windows XP/2000
    Posted: 10/21/03
    Released Date: 10/03/03
    Version v2.1.22

    The driver file "sm30mdmx.exe" self extracts to folder "Modem.temp" and the driver setup program starts automatically. Click CANCEL when the driver asks if you want to install it.

    "I notice that if i start in safe mode, IRQ is 04 "
    Enter the laptop BIOS and see if there is a setting for "Modem uses IRQ" Set the IRQ to N/A

    Boot into Windows.

    "yellow exclaimation mark: "Serial" which says "This device is not present"
    Delete this device from Device Manager.

    Reclaim the "in use" COM port or ports.

    This is a AC97 modem and the driver installs a virtual com port. It will not be listed in Device Manager under COM & LPT. The port it uses will only be listed in the Modem Properties. Using the modem driver from Toshiba the modem driver can not be installed properly using "Windows Found New Hardware Wizard". The modem driver must be installed using the setup.exe program in the Toshiba driver package.

    Browse to the "Modem.temp" folder and run the "agrsmdel.exe" program. This will uninstall the modem and the driver. Check Device Manager to be sure.

    "Windows XP Driver Signing"
    Make sure Windows is not set to BLOCK unsigned driver.

    Normally I would recommend to reboot and when Windows finds new hardware click cancel. Then run the setup.exe program from the "Modem.temp" folder.

    This may or may not work. Windows may install a * default driver before you can cancel the Found New Hardware.

    After running the "agrsmdel.exe" program and before rebooting run the setup.exe program. This may work. if not you will need to track down the INF file Windows is using to install the default driver to force the Hardware Wizard to work.

    * Windows default drivers install using a INF file (Driver Information File) and do not run the setup.exe program.

    This driver also installs the LT MOH (Modem On Hold) software.
  5. jobeard

    jobeard TS Ambassador Posts: 12,273   +1,367

    Toshiba Software modem cfg

  6. ctarchila

    ctarchila TS Rookie

    same problem

    halfasianmafia, did you solve the problem.
    This problem also is driving me insane ... :(

    Many thanks!
  7. halfasianmafia

    halfasianmafia TS Rookie Topic Starter

    Still not fixed

    Hi all,
    I'm sorry to say I was never able to find a fix for this modem problem. Since I only use dial up at home, I decided taking years off my life stressing about this problem wasn't worth it, and neither was sending my computer off to be serviced. So perhaps I took the coward's way out and just bought a $25 USB external modem which works perfectly. Yeah, it's a bit of a pain to have an extra USB peripheral to attach when I want to dial up, but at least I can connect to the internet now. I think something was seriously screwed up with the internal OEM software modem...something that would have taken more than just changing some settings to fix. Hope y'all with the same problem have better luck, or else just buy an external modem!

  8. sillyxone

    sillyxone TS Rookie


    My niece's is Toshiba A15-S129, having the exact same problem but sometimes I managed to make it work (by changing driver, settings ...) so I didn't think it is a hardware problem.

    I spent 3 days to isolate the problem, just to find out applying the same things won't yield the same result. Too tired, I google a little more, find this:


    And follow the posted solution, I open the base of the laptop, saw the modem (a small PCB with a big label attached to it (PTA Approved label, ICASA approved label ...). Unplug it, plug it back, work like a champ. Probably I was shaking it while working, made it worked sometimes.

    Thanks a lot to Allan_Shiels from the other forum. Hopefully this will apply to most of us who having this trouble.

    Note: when I plug it back in, the connector socket seem to be loose as I have to apply pressure with my fingers in order for it to work. Before I put the cover back in, I put in a small foam to press the card down. So please try to apply pressure on the card if it still doesn't work. And probably you don't have to open the whole laptop's bottom, it's is the smallest door (the others are RAM, wireless, and CPU access doors)
  9. rcaf

    rcaf TS Rookie

    I experience the same problem in my Toshiba A70 and resolve it as follows: Shut down/disconnect power cord/remove battery momentarily. Then reconnect battery and power cord and restart. It's not a permanent fix but a quick one that works until the problem recurrs.
  10. redvisa

    redvisa TS Rookie

    Hi guys,

    I own Toshiba notebook and I've had the same mystery problem with Toshiba modem. I tried everything - I had two sleepless nights..… scanned, changed ports, used various software and addressed this issue to specialists, but NONE new what was the matter.

    Thank God I had guarantee with Toshiba service center, I went there and they said it's quite common with notebooks to have such a problem – the matter was with hardware - modem itself–modem off-sealed from the circuit board. Electric soldering iron a and a clever specialist worked wonders.

    By the way, don't pay attention to this phenomena: when you check the "show hidden devices" option in the "view" menu, one device is listed with the yellow exclamation mark: "Serial" which says "This device is not present, not working properly, or does not have all its drivers installed" – it's OK in notebooks – the system seeks additional COM ports which do not exist.

    Overall: Go to service and check you modem physically – it may be off-sealed from board.

  11. redvisa

    redvisa TS Rookie

    halfasianmafia, ee below.
  12. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    my suggestion would be to uninstall the modem and then reinstall the modem drivers.... perhaps your drivers are corrupt.
  13. redvisa

    redvisa TS Rookie

    Tedster - this won't help. I've tried this million times. This is not a software problem - it's a hardware problem. But those who face this problem should try all the software means before taking the PC to be serviced.
  14. CoRrUpTeD

    CoRrUpTeD TS Rookie

    :grinthumb I believe your modem has "connection" issues, it seems these modems are crap... find the modem on the underside of the laptop unscrew/ reseat the modem, test, if it works great, if it doesn't try inserting foam, or paper between the modem and the "black case"... if you cant find the modem locate the manual for the laptop.

    The issue I had with this modem was resolved by, inserting paper between the modem and the "black case"... Don't be surprized when it takes a crap and you have to keep repeting those steps...

    I don't have much time and just registered to give you guys this info...

  15. KOLS

    KOLS TS Rookie

    Toshiba Modem!!


    Right on target!! I've been playing with this one for awhile...and...after read your fix tried it and, I be darned it worked like a charm. Surprizingly there was a folded piece of paper attached to the back of the modem (do you think they knew about it to start with?) any way I unscrewed it, fold a piece of paper to about an 1/8" thickness, seal it up, rebooted and away it went without a hitch.....THANK YOU!

  16. CoRrUpTeD

    CoRrUpTeD TS Rookie

    NP! glad it works! 1/8? heck Mines up to about 1 inch.. Inside laptop, and out...
    As I said above don't be surprized when it comes undone etc... This modem is a real piece of work. @ the paper comment, no I think it's there for FCC standards.

    somtimes ya just need to slow down before trying everything! ;)

  17. MrJonesInPortla

    MrJonesInPortla TS Rookie

    Same Issue

    These modems are just hopeless. Just been through the same whole issue with a Toshiba A10. After uninstall,re-install drivers, going back to previous restore points, it was the piece of paper stuck between the case and the modem that fixed it. Whoever designed that connection should be shot. Toshiba need to send out a customer bulletin on this.
  18. sbrose

    sbrose TS Rookie

    Toshiba Laptops (including Satellite) Modem Error 633, 000000005

    Thanks so much for this thread. This problem and solution appear to be for any/all Toshiba Laptops. It's certainly worth a try. My wife, my co-worker and I have all had this problem. Some for months! :hotbounce THE ANSWER IS (as answered by folks in this thread), take out the hardware (the modem - smallest panel on a P25-S477) give it a stern talking to, and then press the living %$#! on top of it on the connector side back into the compartment.

    I had to fold (like a paper fan) almost 3/4" of paper on top of the modem, just at the end where the white (useless) connector is. On this laptop it just so happens to be on the screw side of the panel cover so the pressure pushes down on the connector, not the entire modem. Obviously don't put so much paper spacer so you can't get the screws back in, but in my case, it took that extra 1/8" to cause enough force on the modem connecter to keep the connection once I turned the laptop back over.

    I feel bad for the peace-cops fellow who tried all of the software solutions he could. THAT IS NOT THE ANSWER.

    His solution of spending $25 for a USB modem appears to be a cheap answer if your not comfortable having a roll of TP in the back of your laptop!

    Thanks Again.
  19. ihsan555

    ihsan555 TS Rookie

    toshiba modem

    Hi every body
    i have the same problem with my toshiba laptop but with a little difference
    my toshiba software modem provided by Agere is working but suddenly the system freez so i have to disconnect the ac power and remove the battery
    to restart it . i worked rof three month to isolate the problem its the MODEM
    but i donot know if its a hardware or software problem
    can anybody help with my problem
  20. Amused

    Amused TS Rookie

    I spent a full night trying to solve this issue. I have the EXACT SAME PROBLEM with my Toshiba Satellite P25-s5093. I tried everything but as everyone else explained i faced the same problems, i mean there was no solution no matter what i tried.

    In addition to the modem problem my lan card was not connecting to the netwrok if it was set on 'auto assign ip' but it worked if i manully gave it an ip and dns etc. I think the modem has something to do with it.......not sure though.

    Anyways I was searching every where and could not find any solution and my laptop's warranty also expired. I called toshiba support they asked me for $35 to help coz my warranty had expired. Imagine that.....and i can get a usb modem for cheaper than $25 here in Pakistan.

    Finally i came accros this thread when i google my problem with 'error 000005aa' lol

    I have not tried any of the solutions that people have suggested....but i am glad i know wat the problem is and that this is very common with toshiba crap modems. I will try putting pressure or something else and let you people know if it works for me.

    Thanks a lot for saving me loads of time people.....now i atleast know what the problem is......

    We should all SUE TOSHIBA!

  21. Matter82

    Matter82 TS Rookie


    Beating this topic to death once more, the hardware removal and remounting solution worked. I spent a good amount of time trying various other techniques including uninstalling and reinstalling drivers and trying the trick to release the ports. So, yay. Thank you to the individuals who posted on this board. You saved me much time.
  22. Amused

    Amused TS Rookie


    I got my modem working again! Thanks to all of you who posted and shared their Toshiba modem experience. I would have never figured out what was actually wrong with my modem if it wasn't for this thread and people who posted.

    As many suggested applying pressure on the modem to make it sit properly and firmly in its place was what worked for me. Some how the modem was a bit lose and stoped working and wasted my time with those 633 error messages. To fix the modem I folded a paper sheet and placed it on top of the modem and screwed the modem cover back on. Now the paper sheet keeps the modem pressed down and the modem works fine.

    If someone still has this same problem, this solution is worth a try before you go buying a new modem in case the warranty expired.

  23. Barbara

    Barbara TS Rookie

    Thanks, it worked. Modem connection was just a little loose. Tightened it, put in a piece of paper about 1/8" thick, took out battery and put back, then re-started the computer. Bingo!! It showed a new modem and it's working fine. Thanks very much. Barbara
  24. qiytooy1

    qiytooy1 TS Rookie

    toshiba modem problem

    I had a similar problem with a Toshiba Satellite laptop. Wasted about 2 days troubleshooting.

    Just by chance I stumbled on this forum, to learn that so many people were experiencing the same thing.
    Learned a lot from you guys and galls. Thanks.

    Then I took a look at my laptop and wondered if or how I would open it up, to twinkle with that darn modem. I unscrewed about 4 screws, but could still not open it.
    I realized then that I wasn't sure on how to open up the laptop to get to the modem, without a manual.

    I took the easy way out, bought an external USB modem for $25, and am using that now. It works fine.

    Thanks to all who helped.
  25. sehfeld

    sehfeld TS Rookie


    even though this is an older threat - it still helped to solve my problem. Fortunatly I only spend about three hours on experimenting with software solutions until I read the info here - put lots of paper under my Toshiba Z 22's hood and - voila it worked.

    Really I was laughing out loud when I first read about the suggestion to use paper to apply pressure - I really couldn't believe this was even vaguely possible!

    I am however even more amazed by Toshibas ignorance in dealing with this matter. The Z22 model might be a low end Notebook, but other people here were having the same problem with substantially more expensive builds. It's a real disgrace that Toshiba didn't have the guts to replace an obviously faulty modem connection or issue a warning.

    To illustrate how the fix works have a look at the pics here - unbelievable but true - I just hope a Toshiba representative or a competitor will see this one day :D



    It works!!!

    Thanks again for your help everyone!!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...