TouchEd Error?

By me(who else?) ยท 11 replies
Feb 22, 2004
  1. i have a toshiba laptop, not even a year old. A few weeks ago, I was editing my boot-up with msconfig. I don't know what I did, but now when I boot up my computer a pop-up comes up that says there is a Touch-Ed error. I know that Touch-Ed has to do with the touchpad, but I don't know how to fix it. Thanks in advance.
  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    It sounds like you just need to reinstall the drivers for your touchpad. I would imagine that they load something on startup and when you played with msconfig you could have unchecked them.
  3. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 387

    Thanks... it works
  4. Aquilino71

    Aquilino71 TS Rookie

    TouchEd Error

    I have a same problem, but I couldn't fix it yet. Can you give me a little help?
    Tx, Aquilino

    Dear Sir,

    Whenever my computer loads up, I always receive a:

    TouchED Error

    Retrieval of "THotkey" failed.

    Error code - 0x00031402, 0x00000002

    What can I do to fix it?

    Thanks so much.

    I have a Toshiba too.

  5. SBriggs

    SBriggs TS Rookie

    Same problem here. All the forums found via Google lack a solution. I am posting it to this forum b/c this forum comes up first in the Google search. Hopefully other Toshiba sufferers can use this fix.

    Stop trying to remove this error with AdAware, AVG Antivirus, Spybot, HijackThis and so on.


    This is a Toshiba touchpad utility.

    Navigate to C:\Windows\system32

    DELETE 000StTHK.exe and 00THotkey.exe.manifest

    COPY 00THotkey.exe

    Navigate to C:\Documents and Settings\All Users\Start Menu\Programs\Startup

    PASTE 00THotkey.exe into the Startup directory.

    Creating a shortcut may work just as well, I can't really say because this is how I solved the problem and I am happy with it.
  6. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Thank you very much SBriggs for that information. Hopefully it will help someone in the future.

    :wave:Welcome to TechSpot:wave:

    Hope to see you stick around :)
  7. mack10

    mack10 TS Rookie


    thanks sbriggs it worked perfectly.
  8. yongfeng

    yongfeng TS Rookie


    Hi there,

    I accidentally deleted the 00thotkey.exe file from my computer. Could anyone upload a copy for me? I am not sure whether all the Toshiba models use the same version of 00thotkey file. My Toshiba model is Portege A100.

  9. wizardg

    wizardg TS Rookie

    I finally got that bothersome THotkey error box off the computer I was working on. I don't know what caused it. I was very busy upgrading and putting virus protection into a laptop that had been neglected to the point of a black screen and pointer.

    After I corrected the black screen problem with an easy F8 to last good config move I went about the deed of trying to make sure it didn't happen again by renewing the protections and ugrading all windows XP updates etc.

    It was then that, that nasty little THotkey error showed up..Whew thanks to this forum I found out that the common files download from Toshiba worked for this A55-1064 Satellite.
  10. RWSieg

    RWSieg TS Rookie

    This still works, Thank you for the assist. and documentiaton.

    be well.
  11. Sidnex

    Sidnex TS Rookie

    I had the same problem for the last few weeks after trying to disable it within the startup executables. That failing, I tried to uninstall it, clean the registry, and finally reinstall every Toshiba utility they offered. Nothing worked except for the above fix.
    Even after uninstalling from the Add/Remove Programs utility, both the 000StTHK.exe 00THotkey.exe files remained in the system32 folder. Did not see a 00THotkey.exe.manifest file in there, but regardless following the instructions from SBriggs did do the trick.
    One bit of useful but simple info: It doesn't work to copy the 00THotkey.exe file into any other startup folder (e.g. under default user, named user, owner, etc.); it looks like it has to be the All Users\Start Menu\Programs\Startup folder as indicated above.
    In my case that folder was hidden so be sure to make all folders visible first if you can't find it.
    Thanks for the postings.
  12. GerardS

    GerardS TS Rookie

    Hi all, this troubled me for a while as I was de-virusing my daughter's school laptop.
    In my case it was my own fault: I deleted the relevant registry key in an attempt to
    disable/isolate malware.

    The error message is cryptic and unhelpful to say the least! (Toshiba, take note!)

    TouchED.exe (C:\Program Files\Toshiba\TouchED\TouchED.exe) needs
    thotkey.exe to be running. Unfortunately thotkey.exe is not actually called that -
    it's found at C:\WINDOWS\System32\00THotkey.exe. If thotkey.exe is not running,
    the TouchED error dialog pops up and TouchED dies.

    THotkey presumably also requires the files 000StTHK.exe and 00THotkey.exe.manifest
    present in system32 (although I haven't broken up the set to find out!)

    It should not be necessary to move files into or create shortcuts in the startup folder,
    instead, the situation can be remedied by creating the following key in the registry
    (the usual disclaimers apply to modifications to the registry!) :

    key: THotkey (actually not critical)
    value type: REG_SZ
    value: C:\WINDOWS\System32\00THotkey.exe

    If you don't know how to edit the registry, ....

    Of course, if you've deleted the relevant files or they're corrupt, this
    won't help, you'll need to get them from somewhere.

    Hope this is of value!

    Many thanks to Mark Russinovich of Sysinternals/Microsoft, for tools that made
    working this out possible!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...