Tech Stocking Stuffers: 18 awesome gifts under $50

Trouble with 160GB SATA Drive

By saik0pod ยท 43 replies
Jan 8, 2008
  1. Okay, so today I got a brand spanking new 160GB 7200 Sata Seagate Hard Drive. Put the cable into Sata port 2 installed the sata power supply, bios detected it. (NOTE: I have a 80GB sATA where WinXP Pro is loaded.) So I boot to windows, I didnt see the sATA drive in My Computer.

    I opened Partition Magic 8.0, partitioned my new 160GB drive. Next I booted noticing that the 160GB is not being detected in the bios. Partition magic says : ERROR Batch file cannot be executed, because drive not detected in startup. SO I restarted my pc again and the brand new sata drive WILL NOT SHOW UP IN BIOS.

    I tried EVERYTHING! Nothing can detect my new 160GB drive! Can anyone tell me how to reformat the drive manually? I really need help!
  2. saik0pod

    saik0pod TS Rookie Topic Starter

    Not sure if this info will help

    My motherboard is

    MSI- NEO2-P (2 Sata ports) Intel ICH(Something) Controller

    The malfunctioning Hard Drive is

    SeaGate Barracuda10 ST3160815AS 160GB SATA 7.2K RPM

    Bios is

    American Mega Trends Award Bios
  3. mailpup

    mailpup TS Special Forces Posts: 7,160   +460

    Just in case, make sure the cable connections are tight both on the motherboard and to the hard drive. Those SATA data cables can come loose fairly easily sometimes.
  4. saik0pod

    saik0pod TS Rookie Topic Starter

    Yes I know its not the cable. It's all secure I even changed the SATA cables with brand new ones. Even the SATA power supply which I tested which works 100% Reviewing a last post I've read, my PSU is a 850 WATT monster, It's only 2 weeks old and Im sure its not malfunctioning.
  5. tastegw

    tastegw TS Enthusiast Posts: 188

    idont know if this will help or not, im still fairly new to this myself, but are there jumpers on your HD"s and if so, are they both set to what they are?

    primary and slave?

    if so, then i tried ;)
  6. saik0pod

    saik0pod TS Rookie Topic Starter

    It's a Sata hard drive no jumpers are required. Thanks for your help though
  7. saik0pod

    saik0pod TS Rookie Topic Starter

    Let me add in detail what happened.

    1) I plug the Sata Drive into the computer.
    2) I see Bios Detects it
    3) Playing around with Partition Magic to create a Partition on the Unformatted Drive.
    4) Partition magic requires me to reboot the machine in order to create the partition.
    5) I reboot seeing the Sata drive not being detected in bios.
    6) I get an error from partition magic saying it cannot complete, due the drive not being visible.
    7) I checked the drive it works 100% (As in it spins the latters and its getting power)
    8) I notice the bios startup takes longer

    e.g Sec Master .... Press <ESC> To cancel (Cancel Detection)

    Bios is trying to detect the drive which is there, however it fails to detect it after 6 mins.

    9) I spend hours on google trying to find a solution
    10) I end up here
  8. saik0pod

    saik0pod TS Rookie Topic Starter

    Cmon guys, I know someone out there has a solution
  9. captaincranky

    captaincranky TechSpot Addict Posts: 12,759   +2,431


    Unless you have a Sata RAID driver installed the BIOS must be set to run as IDE or all it will do is continue to hunt for the drive. Without RAID, It must be set to "run as IDE" in all XP variants anyway. In Vista, the HDD may be run as "ACHI" (native SATA non-raid mode).
    There is a jumper involved on a Seagate SATA HDD, but, it's there to hold the drive in SATA 150....,, remove the jumper and it will run as SATA 2 (300Gbs). As you pointed out, there is no master or slave.
  10. saik0pod

    saik0pod TS Rookie Topic Starter

    Hi, I dont think thats the problem, as my other SATA drive can be detected and Im able to boot from. There is no jumpers on the 160GB drive however there is a set of 4 pins in the back
  11. saik0pod

    saik0pod TS Rookie Topic Starter

    Anyone have any suggestions?
  12. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Do you hear the drive produce noise when you power on the system ? At worst, it could simply be that your hard drive has failed & need to be replaced.
  13. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    You need to make sure your SATA II drive is operating at 150MB/s or SATA I speeds. Your motherboard is to old to have a SATA II controller card. Most SATA II drives have to be jumpered to run at SATA I speeds.
  14. captaincranky

    captaincranky TechSpot Addict Posts: 12,759   +2,431

    Going Visiting.....

    Seagate 80GB "Barracuda" SATA 2 certainly did have a jumper on it as shipped. When I polled the system, it showed up as running at 150GBS, this on a SATA 300Gbs board. Pull the jumper and, Viola! Seagate's web site should have the final word on,"to jumper, or not to jumper, that is the question". I say that with great apologies to Shakespear.
  15. saik0pod

    saik0pod TS Rookie Topic Starter

    im pretty sure my motherboard supports SATA 2, My 80GB Sata drive is SATA2 and its currently working 100%. The new 160GB works, it spins up and such its just that bios cannot detect it. This happened after I partitioned the 160GB drive.
  16. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    None of the MSI Neo 2 P are SATA II capable. not this version or this version. If your 80GB hard is actually a SATA II device then it's jumpered.
  17. captaincranky

    captaincranky TechSpot Addict Posts: 12,759   +2,431

    When in the course of human events......

    If the partitioning is actually at the root of your problem.. I would wipe the drive and start over. See, if this makes any sense to you. If you try this, DISCONNECT ALL the other drives in you system, then boot from the CD. The CD you're going as an image file. It's an .iso, burn it as as image file, very important.
  18. captaincranky

    captaincranky TechSpot Addict Posts: 12,759   +2,431

    I'm the little guy...

    To get things back on track, I'm the guy with the 80GB Seagate. He's the 160GB person. The issue is the same about the jumpers though.
  19. crawdoogie

    crawdoogie TS Rookie

    As pointed out earlier your board does not support SATA II.

    The ST3160815AS HDD has a 4 pin jumper block next to the SATA interface connector. To set for SATA I you need to put a jumper across the two outermost pins.

    Another possibility could be that your mobo currently doesn't support 48 bit addressing and cannot handle anything over 137 GB. A BIOS update for your board includes support for HDD's over 136.9GB by enabling 48 bit addressing. If updating be aware that there are several versions of your motherboard and the BIOS updates are not interchangeable. You could also create two or more partitions that are smaller than 137 GB using partition management software.

    BIOS from MSI here:
  20. saik0pod

    saik0pod TS Rookie Topic Starter

    Ah I see, is there any SATA 2 Adapter? Also my bios is updated and can read beyond 137GB. I bought SATA II cables for my 80GB and 160GB. Thanks for all your help! This really is a helpful site
  21. saik0pod

    saik0pod TS Rookie Topic Starter

    Anyone know how i will be able to jump this sata II drive?
  22. crawdoogie

    crawdoogie TS Rookie

  23. saik0pod

    saik0pod TS Rookie Topic Starter

  24. saik0pod

    saik0pod TS Rookie Topic Starter

  25. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    if the bios does not see it anymore on that channel
    download diskwizard bootable utility from seagate
    it's software from acronis free
    put the (bad )drive on the other channel and boot from the disc you made
    if acronis (seagate)does not find it check bios again maybe something got disabled
    I'm guessing the drive just went and die'd
    or the motherboard has something wrong with it
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...