1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

trying to understand usb and creative Zen touch

By hit3mup ยท 10 replies
Jun 3, 2005
  1. Dear All,

    Am the disgruntled owner of a brand new Creative Zen touch 20gb mp3 player which apparently works with usb 2.0. After installing the software which came on the cd (file transfer software i think and maybe nomad explorer) the Zen appears to get recognised by the pc with no problems when i connect via the usb cable. The Zen also displays 'docked' which is all very well. However if i select say 10 tracks to download to the player the xp progress bar seems to halt at around 60-70% and eventually the program (nomad) complains that the operation cannot be completed. I noticed that the small hard drive in the player feels as though it is 'spinning down' around a similar time to the message being displayed. If at this stage i refresh the players view in nomad explorer it can be found with no problem....its just i cant write to it until i unplug the usb from the zen and reconnect. I spoke to creative who told me that because my pc (in system devices) reports that my usb is an 'open host' adapter...this means it cannot supply adequate power to the player....but surely USB2.0 is USB2.0 and if something claims to be USB2.0 compliant that would be the end of the story?? The usb card im using is a belkin usb 2.0 pci card and is also pretty new. Any help/ideas would be greatly appreciated. Thank you.

    Mark J.
  2. kritonas

    kritonas TS Rookie Posts: 49

    What if you plug it in a USB 1 port? Can it transfer files (even if that's slower)? I'm not really an expert but i've got a zen too and maybe i can help.
  3. hit3mup

    hit3mup TS Rookie Topic Starter

    I have tried the USB 1.0 port which seems to give similar results....the Zen stops responding after about 10 tracks have been downloaded to it.
  4. kritonas

    kritonas TS Rookie Posts: 49

    What cable are you using? Did you try connecting the zen to another pc?
  5. irharg

    irharg TS Rookie

    Hi, I have just received a Zen touch and had exactly the same problem. I too am therefore disgruntled. I have tried various usb ports, usb1 and2 conections ( I have both), various cables and combinations and the same happens. I have also tried win xp and win98, and other disks I have with the same result. I have managed to transfer 120 os so mp3s (a small proportion of those I have been trying to transfer) but never the contents of a full folder. After a proportion of the files are transferred then Zen touch becomes 'busy' or 'not connected'.
    Is is a USB power problem? Should a powered usb hub cure it?
    But is this surely is Creative's problem. It is obviously a known issue but what are they doing about it? :mad:
  6. kritonas

    kritonas TS Rookie Posts: 49

    try updating the firmware if you havent already
  7. boborfrank

    boborfrank TS Rookie


    My first post
    New member tried to start new tread nearest I could get was to this tread
    My request to start is

    How do I know if I have a usb 2 ?

    When I plug my Creative Zen Touch into usb I am receiving a message

    This device will work better in a usb2 port

    Sorry if I have gone about asking for help the wrong way.

    Regards Bob
  8. kritonas

    kritonas TS Rookie Posts: 49

    Hello and welcome:)

    I wasnt sure about this, but i searched a bit on google and found this:

    How do I know if my PC has USB 2.0?
    You can identify whether your PC has Hi-Speed or not relatively easy. Open Device Manager and expand the Universal Serial Bus section. There should be an "Enhanced" USB host controller present.

    If you need any more info try this site
  9. boborfrank

    boborfrank TS Rookie

    Thanks for your reply
    further info in case you can help

    1. Do other USB devices work on the system?
    Yes key board usb 1
    printer usb1

    2. Is USB enabled in BIOS setup?
    sorry cant see how to check this in the bios

    3. Is the BIOS up-to-date?
    As far as I am aware
    4. Have updated device drivers been tried?

    5. Are any USB hubs being used?
    Yes powered and I get the same message when i plug the hub in ie this would work better in usb2

    6. Is the PC in question a portable (laptop/notebook)?

    I have tried unpluging ALL usb devices and only pluging in one at a time direct into the computer not the hub

    IRQ 0 System timer OK
    IRQ 4 Communications Port (COM1) OK
    IRQ 6 Standard floppy disk controller OK
    IRQ 8 System CMOS/real time clock OK
    IRQ 9 Microsoft ACPI-Compliant System OK
    IRQ 10 MPU-401 Compatible MIDI Device OK
    IRQ 13 Numeric data processor OK
    IRQ 14 Primary IDE Channel OK
    IRQ 15 Secondary IDE Channel OK
    IRQ 16 NVIDIA GeForce4 Ti 4200 with AGP8X OK
    IRQ 17 OHCI Compliant IEEE 1394 Host Controller OK
    IRQ 17 Creatix V.9X DSP Data Fax Modem OK
    IRQ 18 Realtek AC'97 Audio OK
    IRQ 19 SiS 900-Based PCI Fast Ethernet Adapter OK
    IRQ 19 MEDION (7134) WDM Video Capture OK
    IRQ 20 SiS 7001 PCI to USB Open Host Controller OK
    IRQ 21 SiS 7001 PCI to USB Open Host Controller OK
    IRQ 22 SiS 7001 PCI to USB Open Host Controller OK
    IRQ 23 SiS PCI to USB Enhanced Host Controller OK

    Thanks in advance
  10. animated_wolf

    animated_wolf TS Rookie

    I dont understand what happened

    I had my Zen for 2 days now and it just started to mess up. I disconnect it and it plays music and everything but when I try and download more songs onto it, it says the USB is not plugged in. I dont know what to do. I did everything I was supposed to. Is there something I am missing?
  11. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    USB can power SOME devices directly via the USB cable -- notice some!

    Any device with HD or that pulls more that 500ma, needs external power source,
    and NOT just a powered USB hub.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...