TSPIP.sys crash when accessing VPN (remote desktop)

By PrettyMao ยท 5 replies
Feb 20, 2006
  1. I have been trying to login into my office workstation from home. To do that I have to go through a vpn network, which uses XP's remote desktop (I believe this is correct, as it needs to access port 3389, which I have allowed in my router, a DLink DI-524).

    Every time the computer attempts to connect it suddenly gives me the BSOD. The BSOD always occurs when it is trying to connect to the office IP through port 3389.

    To access the system needs to go through a port forwarder, this is done by clicking a link and a small java applet opens up, the applet starts the connection process, another small window pops up that says "Connecting to 129.X.XX.X:3389" that lasts for less than a second before the BSOD appears.

    My system is old and it could be likely that some of the older drivers are conflicting, but I am unable to determine which device it is. I have tried two different network cards (both are DLinks), installed the latest drivers for each and that did not seem to work for either card.

    I have attached some of my minidumps, all from the same type of crash. If anyone can give me some insight as to what is causing this error, it would be greatly appreciated. I would like to be able to work from if possible.

    AMD 1050MHz Thunderbird
    ASUS A7V-133 motherboard
    OS is on a Western Digital 80gb HD, 7200rpm
    video card: Voodoo5 5500
    Creative Labs Soundblaster sound card
    DLink DFE-530TX PCI fast ethernet adapter (Rev A)

    if there is any other other information needed, please let me know and I will be happy to supply it.

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    All your minidumps crash at TDI.SYS. This your Windows TDI Wrapper driver. They all have a bugcheck of D1.

    (Click to consult the online Win XP Resource Kit article.)
    The system attempted to access pageable memory using a kernel process IRQL that was too high. The most typical cause is a bad device driver (one that uses improper addresses). It can also be caused by caused by faulty or mismatched RAM, or a damaged pagefile.

    Update your system to the latest Windows service pack.

    Also, go HERE and follow the instructions for testing your ram/hdd/page file.

    Regards Howard :wave: :wave:
  3. PrettyMao

    PrettyMao TS Rookie Topic Starter

    Hi Howard

    Sorry for replying to you a little late. I am still trying out different drivers, I tried clearing my pagefiles and nothing happened there.

    I have some other sticks of RAM I will try... gonna keep at this and hopefully something will work. Is there a chance that this may never work?

    I will keep you updated.


  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Deffinitely try other sticks of ram.

    If that doesn`t help. It is possible that part of your OS has become corrupted.

    Maybe try doing a Windows repair as per this thread HERE it may help.

    Regards Howard :)
  5. PrettyMao

    PrettyMao TS Rookie Topic Starter

    Hi Howard

    Well, wouldn't you know it, I had two sticks of RAM in there and the first one I pulled out turned out to be the culprit.

    I added two other sticks in there, so 3x256megs and I can still login into my workstation at work. So everything is fine now after weeks of trying various things.

    Thanks a bunch!!


  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    That`s good news.

    I`m glad your problem is solved.

    Thanks for letting us know.

    Regards Howard :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...