Two DVD drives will not read anything.

By gavy ยท 5 replies
Jan 10, 2008
  1. Okay. This has been one of the most frustrating experiences ever, so hopefully someone can help me here.

    A few months ago, I attempted to replace my ancient Acer 636A Internal CD-ROM drive with a Sony DRU-810A DVD RW drive. This attempt failed rather miserably. I am positive everything was plugged in correctly. The computer recognized the DVD drive as the Master, and opened/closed just fine. However, it flat out refuses to read CDs or DVDs. In My Computer, it shows up as DVD-RW Drive E, but never shows a CD/DVD as being present. If I double click on the drive from there, it makes a strange clicking sound as though it's trying to turn the CD/DVD, but it can't seem to.

    So, I called up Sony and dealt with their tech support for a couple of hours. In the end, it was concluded that the drive was faulty and I was supposed to mail it back to them to have it fixed, or replace it in the store (got it from a computer show so it wasn't that simple).

    I would have mailed it to them but something else happened. I took an older DVD-RW drive (Pioneer DVD-RW DVR-104) from a spare system I had. It WAS working in the other computer. When I put it into this one, I again had the same problem I had with the other drive. It was recognized as the Master, comes up at DVD-RW Drive E, but doesn't read anything, or even acknowledge there's a disk in the drive. This one doesn't click, but makes more of a whirring sound indicating that it's attempting to spin the CD/DVD. But, like the other DVD drive, it can't.

    My old Acer CD-ROM still worked when I put it back in. I later replaced the grey cable (whatever it's called) with the one that connected the Pioneer drive in the other computer, and tried both DVD drives again. Still failed.

    Can ANYONE think of anything that would cause this problem? I thought it was the Sony drive, at first, but why would both the Sony and Pioneer drive do the same thing?
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Perhaps it is the controller that they were both connected to that is the problem. In the Device Manager check under IDE ATA/ATAPI controllers to see if the controller the optical drives were/are connected to have reverted to the slow PIO mode instead of the faster DMA or UDMA transfer mode.
  3. gavy

    gavy TS Rookie Topic Starter

    No, they're all UDMA.

    The CD-ROM drive still worked last I checked, just not the DVD drives. I'm only plugging in one drive at a time, to eliminate any conflicts in that manner.
  4. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    And just to touch this base, the jumpers on the optical drives are set to the proper setting?
  5. gavy

    gavy TS Rookie Topic Starter

    Not sure what you mean. I went and looked in the IDE ATA/ATAPI controllers and everything says "DMA if available" and shows up as either "Not applicable" or "Ultra DMA Mode 5."
  6. gavy

    gavy TS Rookie Topic Starter

    Oh, I'm a *****. Yes, it's set to master.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...