1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Two HDD Problems in One

By jwgjr ยท 6 replies
Jun 9, 2006
  1. Ok, here we go... about a week ago, on reboot, got a disc error message. ("Disc read error, press C-A-D to restart" or something like that). Bios (on a KV8-MAX3) saw both drives (2- 250GB IDE Maxtors) although, interestingly, MaxBlast did not see them. Figured it was a corrupted MBR or something so I figured I'd try a repair. Problem was, when I dropped in the SP2 disc to do the repair and pressed a key to boot from CD, the drive spun up, started to read, the screen went black and the computer hung. It wouldn't read the disc or start the install. "CD drive problem," you may ask? Nay. I dropped in my knoppix live CD and it booted up fine, saw both HDDs, allowed me to read the info on the CDs, the boot.ini file looked fine, etc.. Problem seemed to involve the windows CD or something with the drive access, or some weird IDE error that knoppix wasn't hitting.

    SO... I ordered a new Plextor DVD drive (just in case... good excuse eh?) and a new HDD-- a WD 250GB SATA drive. I disconnected the IDE ribbon entirely and dropped in the SATA drive. The Bios recognized it and I used the RAID utility to view the drive. So far so good. I booted from CD and the windows install program came up. Excellent! I hit F6 and inserted the SATA driver disk that came with the MOBO and tried each of the different SATA drivers and on every one of them (Sii, VIA and Intel) after the loadup, it said no harddisc detected... press F3, etc.. I looked on WDs site, and the SATA driver they have for that drive is on the disc provided by the mfg.

    Bottom line, I have no idea what caused the initial problem, and my tardly self can't get the SATA drive to be recognized by the XP install program with any of the SATA/RAID drivers I have. (I am an SATA n00b... this is my first non-IDE drive.) Anyone have any idea how to fix either foulup?

  2. jwgjr

    jwgjr TS Rookie Topic Starter

    UPDATE: WD FAQ said that RAID settings may be an issue. Checked and didn't see anything that could be causing a problem, but like I said I am an SATA/RAID n00b. Any ideas?
  3. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    have you tried to reset the bios to optimum defaults
    try mounting the 1 drive for now
    check the type of sata channels you have
    some use 2 just for raid and the other 2 for basic boot
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    If you were using SATA along with IDE, that's a no-no. Windows sometimes gets hung up and confused as to which is the default drive. Use one or the other.
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I use sata with ide and have had no issues
  6. jwgjr

    jwgjr TS Rookie Topic Starter

    Well, problem manifested in a new way. Now windows sees the drive and partitions it, but when it goes to copy the drivers to the disc I get an error that the files could not be copied. Tried 3 different floppies all with similar results. Grr....
  7. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    some setups use dos to install drive
    if you partitioned for ntfs it may not like that did you get prompt to install from active OS
    are you trying to make this a boot OS drive are storeage
    just for the heck set your bios boot for raid if you are trying to boot from sata
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...