1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

UltraATA 133 Controller PCI, cant see my drives

By vidkid1 ยท 6 replies
Jun 13, 2006
  1. ok, if it's not one thing, it's another. After a slew of problems that were conquered, (thanks to TECHSPOT help) there is one problem that I just cant nix. My SIIG UltraATA 133 PCI controller card doesnt want to see my drives that are hooked up to it. I swear I've tried every single which way and nada. At first it was a driver issue because I didnt even see it on the hardware manager list. No I do, but For the life of me, I cant get the drives to mount.

    Here are my specs:
    INTEL MOBO, P4 631, 2GB RAM
    My ATAPI chain has an 80 GB drive, (system) and the ZIP 250. (I had to disconnect the CD-ROM drive. The board only comes with a single on board IDE connection. My old ASUS board had two on boards. Thats why I NEED the ULTRA PCI host card. I cant connect the system drive to the controller because it doesnt recognize anything hooked into it.

    I have 1 SATA HD that is clean on board via SATA connector on MOBO. My only hang up is that the Host Controller does not see the additional drives. GEEK SQUAD is coming over to my office, but if anyone can help me out here, I can call and cancel and save me some cash.

    I recently changed the MOBO and CPU from an AMD (not 64) to the new MOBO and the Pentium 4 due to change in my video editing software. That was another nightmare, but Im passed that. Now struggling with the IDE controller card. Any help would be great.
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    it may be an issue of incompaitability between your mobo and your PCI card. that has always been and problem with PCI IDE controller cards.
  3. vidkid1

    vidkid1 TS Rookie Topic Starter

    Im checking the SIIG site for that, but the darn card works sometimes. This afternoon I saw one of the two drives hooked up. I needed more time to swap things around and do a process of elimination, but I didnt have the time. Any other ideas?
  4. vidkid1

    vidkid1 TS Rookie Topic Starter

    problem solved

    Okay, so, if anyone out there had the same problem as I did. Here iis what I did wrong:

    Main board IDE/ATAPI had ZIP drive and Main IDE Drive with System

    Controller card had 2 IDE hard drives.

    The reason it wasnt working, although the driver of the controller card was loaded and present, was I shouldnt have had the 2 different IDE channels with IDE drives on board. Once I placed the system drive away from the ATAPI hardware, they all showed up on boot up.

    Let that be a lesson to me.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    ide 1: CD master, Zip slave

    ide 2: HD 1 master, HD 2 slave

    you mentioned your motherboard is AMD. What type and model and CPU do you have?
    You should be able to run straight off the motherboard if it's an Athlon XP series.
    Also ensure your cable is 80 pin not 40.
  6. mailpup

    mailpup TS Special Forces Posts: 7,102   +419

    Minor correction. There will still be 40 pins, just 80 versus 40 wires within the cable.
  7. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    yeah. wasn't thinking..... 80 wires - 40 pins
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...