Unable to file/printer share on one computer

By rdlaub ยท 10 replies
Feb 3, 2006
  1. I have a home network using windows xp professional with 3 computers on the network. Up until the other day I have been able to share files and printers across all 3 computers.

    Suddenly I am no longer able to access files on the shared printer on one of the computers. I am able to access the other 2 computers from that computer and that computer can still access the internet on the network as well. But I can no longer access anything on that computer form the network.

    I have tried everything I can think of to figure this. There is no active firewall, sharing is turned on, etc.

    If anyone can help I would greatly appreciate it.
  2. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    on the failing computer, delete the remote printer, reboot, and then redefine it
  3. rdlaub

    rdlaub TS Rookie Topic Starter

    Why would that impact my ability to access the "failing" computer.

    By the way, I am getting the following message when I try to access the computer in My Network Places.

    "computer name" is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions.

    Logon failure: the user has not been granted the requested logon type at this computer.​

    Again, I have been having no problems on this network previously. Just happened out of the blue.
  4. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    yea, but it now has the problem. WHY may never be determined. The WHAT
    to fix can be at least addressed.

    Major piece of information here. You say that system can still access the web and email,
    yet fails print sharing, and this msg is part of the symptom.
    hum ... a malconfigured NIC would be suspected, but the system has web access.

    "computer name" is not accessible implicates the firewall which you insist is not active
    (which system?) ALL systems need to have a firewall and I would never run w/o one --
    but it's your decision. Anyway, you should enable print/file sharing on ALL those systems.

    If you had a non-MS default FW, ports 139,445, TCP+UDP need to be opened
    for your LAN ip address range.
  5. rdlaub

    rdlaub TS Rookie Topic Starter

    I have a router which handles firewall needs.

    Print/file share is enabled on all systems.
  6. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    then everything must be ok .....

    suggest you reverify very carefully
  7. rdlaub

    rdlaub TS Rookie Topic Starter

    I just noticed that on the computer with the problem, windows firewall buttons are dimmed out. It says off but I can't change it. Could this be corrupt somehow and if so, what do I do about it.
  8. rdlaub

    rdlaub TS Rookie Topic Starter

    Anyone else able to help me here. This file sharing thing is a real problem. I've tried everything I can find. I even tried system restore to try to go back a week to before the problem came up. But system restore gives me a message that it was unable to restore and no changes were made.

    I also unshared files on the computer in question, renamed it and renamed the workgroup on all 3 computers. Still no luck.
  9. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    Try this...

    How are you sharing it from:

    TCP/IP Port?

    PC - is acting as a print server?

    1. Remove the drivers for the NIC (PCI) or onboard.
    2. Shutdown PC remove PCI (NIC) if you're using one, the re-seat it.
    3. Make sure that the onboard NIC is enabled if you're using one.
    4. If you're not using the onboard NIC make sure that disabled
    5. See if XP is seeing New Hardware.

    Still doesn't work

    Remove all Printers from the PC including drivers and software
    Reboot the PC
    For each Printer re-add and install software, then share out that Printer
    Test the printer per PC and see if it's being seen
    Also ping the Printer on your workgroup and directly on the same PC

    No Go

    Remove the OS and Re-installed it
  10. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    if dimmed out it means you have lost permission to access this system
    are you admin did your sister change admin's on you
    you will need to log in as admin
    best way is create new admin privledges
    and log in with those
    need to go to group policies mmc and reset all permissions
    more at microsoft more heremmc
  11. rdlaub

    rdlaub TS Rookie Topic Starter

    I know I am using TCP/IP.

    After that you lost me. Sorry I am technical enought to set up file sharing, but as technical as your instructions seem to require. I'm afraid I'll screw up everything.

    By the way, it's not just the printer, it is accessing the computer completely as well.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...