Unable to Read USB Flash Drive

By Comtrade · 31 replies
Jun 17, 2005
  1. I have a 512MB PNY Attaché USB flash drive. Have been using it without any problems until recently. I am running WinXP Pro which recognizes the drive as H: but when I try to open the drive I get " Please insert a disk into drive H:".
    Have I lost everything? Is the drive no longer functional? I am not sure how it got this way we had some power failures recently while it was plugged in and running. Obviously I can't insert a disk.
    Any help would be appreciated.

    Comtrade :confused:
  2. johnny52

    johnny52 TS Rookie Posts: 16

    Same with my Lexar jumpdrive...

    Same thing happened with my Lexar jumpdrive. My computer says it's not formatted.

    Just came back from plane trip. Could security equipment at airport wipe out jumpdrive? J2
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  4. KIKO

    KIKO TS Rookie

    I have a 512MB CRUZER MICRO USB flash drive. I can,t open and look dobles
  5. Coronas

    Coronas TS Rookie Posts: 25

    Just an idea...but have you tried putting it into other usb slots in your computer? I remember when I had a Sandisk usb, It would not read @ the front of my bay, but only @ the back.
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Check out the thread Tedster linked.
  7. halo71

    halo71 TS Rookie Posts: 1,090

    I have seen that same exact thing before myself. With the 256 Cruzer Mini on several POS Dell's at work.
  8. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    x-rays do not affect thumb drives.
  9. Isaac Aiko

    Isaac Aiko TS Rookie

    I have a 1GB SONY Micro Value USB flash drive. I used it for few days every thing was ok. My systems is a WinXP Home Edition which recognizes the drive as E: When I try to open the flash I get a message " Please insert a disk into drive E:".

    Please how can I make this flash to work again so as to recover my data?

    Please help
    Isaac Aiko
  10. halo71

    halo71 TS Rookie Posts: 1,090

    Isaac...........Welcome to Techspot!!!

    Have you read the link that Tedster posted above??
  11. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    So you're saying it's a FAT32 problem since XP is using NTFS it might not open the these USB drives after sometime of use. Still if you can't solve the problem a lot of these USB drives comes with 3 years free replacements or just buy a newer one. I know I almost drop the bomb when my PNY fell into well lets say bowl of water sounds better :). It just floated so I was sure luckly my data it go down the drain..
  12. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  13. doopt94

    doopt94 TS Rookie


    well, i have a 128mb memory stick(manutan international-printed on stick) and it has worked fine untill a few weeks ago. my friend thinks he may have done something to it.
    Anyway, it reads it in my computer, but when i try to open it, it says
    Please insert a disk into drive e.
    it always says this. when i right click on it and select format, nothing happens. but, i have opened my computer management from my computer and now i dont have a clue what to do.
    Please can someone explain what i need to do, or any other ways of getting it sorted.I do need this memory stick.

  14. johnny52

    johnny52 TS Rookie Posts: 16

    My computer crashed and burned the day after I

    posted my question, so I had nothing but an old cd backup.

    Still don't know what caused my stick information to crumble.

    Was able to reformat my lexar but now back up everything TWICE.

    They say 3.5" floppies aren't reliable but I never had trouble with any of them all the years I used them. J
  15. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    again I state:

  16. izabela

    izabela TS Rookie

    I read it.I wanted to know about the part where the usb flash drive is not detected in any way by the computer.Your wrote :
    "if the drive doesn't appear there may still be hope (details later)."
    This is my case! Can you suggest any kind of material like that where
    those details are explained.I would be grateful if you could help me on this.
    Lots of respect.
  17. Stacey

    Stacey TS Rookie Posts: 146

    Good Morning,
    As Tedster suggested reading this, will help to answer your questions.
  18. legs

    legs TS Rookie

    izabela, this is exactly the same problem as i have. Tedster gave great instructions but like you i have run out of ideas as to what to do next.
  19. nasa_syed

    nasa_syed TS Rookie

    izabela and legs, this is exactly the same problem also i have. Tedster gave great instructions but like you two i have run out of ideas as to what to do next.
  20. nasa_syed

    nasa_syed TS Rookie

    "if the drive doesn't appear there may still be hope (details later)."
    please help us Tedster
  21. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    try assigning a letter to the flash drive in disc management.

    You may be able to recover use of the drive in another system.
    If not, consider the drive dead.
  22. nasa_syed

    nasa_syed TS Rookie

    thanx for the response tedster
  23. WelshWizard

    WelshWizard TS Rookie

    please insert disk into drive e: usb problem

    Try this. I had a problem with a 2Gig Kingston DataTraveler USB stick which worked perfectly in my laptop (running Windows XP) until I plugged in a friends Corsair USB stick to copy some data. After which I got a message 'Please insert disk into drive e:' whenever I treid to access the encrypted partition of the Kingston stick. It still worked fine on my other laptop and other desktop PC's so I knew it was down to the software of the laptop. To remedy I did the following and it worked.

    With the PenDrive in the USB port
    1. Go into device mananger (right click on Computer, hit properties, then hit device manager).
    2. Navigate to Universal Serial Bus controllers at the bottom and uninstall "USB Mass Storage Device" ( Once you reconnect a USB drive after rebooting, windows should reinstall these drivers)
    3. Reboot your computer

    Hey presto No more 'please insert disk into drive e:' message.
    Hope this helps others with a similar problem.
  24. Avela

    Avela TS Rookie

    USB Flash Drive Unrecognizable in all Computers

    I purchased a USB Flash Drive the 2GB Forum Eddie Wall Model (part# FORUM-EW/2GB). I purchased it in April ‘07 and I am already having issues with it, I can no longer retrieve anything from the drive, because no system recognizes the flash drive when plugged into to USB port. I know it’s not my laptop since I can use other devices such as cameras, mouse, and other flash drives.
    I used it since I purchased it and last week at work on June 22 was the last time remember using the flash drive. I notice the LED on the flash drive does not turn on, as before once the drive was plugged into the USB port. No computer will recognize the flash drive, uugggh.

    I have saved work on the drive for school and my job. Does anyone know what can be done to get the flash drive to initialize when it’s plugged into the system? It doesn’t work on any system I have plugged it into, 10 different systems in fact including our servers.

    I think Tedster you mentioned, "if the drive doesn't appear there may still be hope (details later)." In your post ( https://www.techspot.com/vb/topic45834.html )
    are there details for this situation? Please say yes or am I SOL.
  25. izabela

    izabela TS Rookie

    thanks guys!

    I'm not having luck with usb flash drives. Now I have 2 'dead' usb in one year.I was really careful when inserting or removing them but in my case this was not enough.I thank you all for your advices but none of my usb's began to work.One of them still unaccessible 'Insert unit into drive F' and the other still undetectable but the LED IS ON.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...