Unable to renew ip address - limited connectivity

Not open for further replies.
hi i'm fairly new to this community so i'll try not to break any rules. I'm having trouble with my wireless connection. I have windows xp home, on a compaq presario laptop, and formerly had no problems connecting wirelessly to anything. Unfortunately, and i think i created this problem myself, i enabled the spyware on my pc-cillen antivirus and probably inadvertently deleted some files from the registry i need for my wireless connection. My problems arose soon after i enabled this function. Back to Ad-aware for me! Being kinda computer ignorant in this regard, i tried to fix it with winsox but no go. No matter what i try i still get a limited or no connectivity message. I tried restore point, but no go also. I get kinda panicky about fiddling with the registry so i need some knowledgeable advice, kinda like fix-your-internet-connection-for-dummies. Anyone?


Posts: 3,874   +3
Well if you think you got rid of something you need, then I'd suggest removing it from the device manager, restarting windows and letting it reinstall the wireless card. Just keep your manufacturer CD close, in case you need to manually install the drivers for it.

:wave:Welcome to TechSpot:wave:
well thank you for that, i tried it, no difference. i can't access any wireless stuff at all, just keeps coming up with limited or no connectivity and when i try repair - nothing. Then i get the message about unable to renew ip address. i'm totally lost here. i wish to hell i knew for sure what i did, but the only thing changed is the spyware.


Posts: 1,634   +0
How close are you to the wireless router? Limited or no connectivity could mean it is just getting bad signal. It won't get an IP either if the signal isn't strong enough to connect to the router.
Quick solution is to move close to the router and see if it changes anything.

Next you want to go into your wireless configuration utility. Don't listen to Windows, use the utility to check your settings and search for a network to connect to.

Check Device Manager and make sure it lists the card as a-ok.

Obviously, turn off the anti-spyware in PC Cillin. If it has a history or undo then check what it removed, if anything, and undo the changes.

Check that the router is up and running right. Try just unplugging power and wait a minute and plug back in. Then try the wireless utility again.

Check the properties of the wireless network connection for anything weird. Static IP, stuck info of any kind, bad gateway IP or anything else.
Check the properties by going into Control Panel and Network Connections. Then right-click the wireless and select Properties.

Check the Windows error logs for entries relating to wireless. Right-click My Computer, select Manage.

Anything seem out of place?
i've tried most of your suggestions, not sure what to look for in error messages and the spyware has no way to undo. I'm within 10 feet of the router and i usually connect automatically but it just tells me that it's acquiring network address and then the limited connectivity message and the message that the network didn't assign a network address?? not had that before. The router is working fine as my hubby's laptop is fine. But everything else seems to check out. not sure hot to check for a bad gateway. Thanks for your help so far, i appreciate it. doz
i'm lousy with program names, that's actually the one i have. But i downloaded it again and ran it twice, with no luck. i've tried restore point twice, but that didn't do anything. doti


Posts: 1,634   +0
Can you plug the laptop directly into the router with a patch cable? Does that work, can you get online?
If so, then Internet (aka winsock), is fine. If not, the networking subsystem is corrupt in some way.
Does your router OR wireless card utility have a signal boost that you can tweak? Try that.

Guess we'll go from there.
someone gave me the suggestion to try ipconfig/refresh ipconfig/renew and that seemed to get it working intermittently. it still won't always automatically connect but at least it's working, most of the time. is it possible for some other device to interrupt the signal and screw around with it? it just happened so suddenly, and i couldn't work out why. thanks to everyone who gave suggestions, you guys rock! and rest assured the next problem i have i'll be heading straight back here!


Posts: 1,634   +0
If, at the right moment, the signal has just enough strength, a release/renew will get your IP.
But once you have a proper IP, it usually stays the same even if you drop and come back, because the DHCP server isn't giving out any other IPs. So that makes sense.

I suppose in a weird coincidence, your antenna, either router or card, has gone bad. You'd have to test and get a whole new card to see.

good luck
Same problem

I'm new to this site, but I am having the same problem.
I have recently purchased a Dell laptop and I have also gotten norten internet security which I installed. But I can't seem to be able to get on any network...I have dried my wireless network at work, and plugging the line directly into the laptop at work and at home but it always comes up with the same problem (says limited or no conectivity)
And as well, when i try to repair the conection i get the error message that it was unable to renew the IP address.
I was unable to try the solution of "ipconfig/refresh ipconfig/renew" as I am not too sure on how to do it correctly...can some one give me a step by step? I think that i have to do it in the start->run...but not sure on the initial prompt.
Thanks for everyones help
got the same prob...

I've searched around and noticed a lot of people having problems with intel's 2200BG wireless. The problems range considerably but none so synonymous with my problem as the one in this thread.

My girlfriends laptop wireless works fine everywhere but at my house (e.g. school, her home, friends house, hot spots, etc.). It's not that the connection didn't work before it just suddenly doesn't work now. I updated the drivers, turned off the security, changed the router, ip renewed (which is done by [start]->[run] then type [cmd]; at the prompt just type [ipconfig /release] then [ipconfig /renew] all without the square brackets).

Everyone else at my house can use the wireless just fine (e.g. my brother, my sister, myself). Connecting directly with a wire is fine as well. This has definitely become an intriguing problem that I would definitely like to be rid of. I'll post back if I find any fix but I would also like to know if others have the same problem and how/if they fixed it.

I guess its possible that a spyware fix created the problem but I assumed if it was a spyware related network issue then why just my network at home and not other places. It also could be a mac cloning but if that were the case then could a person hide their comp name from my router because it doesn't show any id as connected on the router; the mac address doesn't have an assigned IP address from the router and I cleared any logs, left if for a few days and then checked while still trying to establish a connection.

There was a problem similiar to this that may help others though. All I did was change the wireless channel on the router from 11 to 9 and it fixed the problem at her house but not mine. Conflicts for wireless space with her neighbour was definitely the problem for just that case.

try estting the ip address manually, make sure no other one on the network is using the exact one, match up the full ip except the last bit. there is a possibility that her card isnt compatible with your router, maybe you use wireless g and she uses wireless a. something like that maybe. thats all i can think of.
Ok i have tried and tested this for all forms of networking with Limited or no connectivity.

1. Click Start, click Run, type "ncpa.cpl" (without the quotation marks) and press Enter.

2. Right-click the connection with an overlaid yellow symbol and click Properties.

3. Click on the "General" tab, highlight "Internet Protocol (TCP/IP)", and click Properties.

4. Click on the "Alternative Configuration" tab, select the "User configured" radio box.

5. Type in the "IP Address" field.

6. Type in the "Subnet mask" field.

7. Click OK twice.

This has happened to me twice. Very frustrating until you find a fix. You may have a corrupt winsock. (or winsock2). There is an easy fix at Microsoft. They have a winsock reset command. Go to support . microsoft . com (remove the spaces) and then search for "How to determine and recover from Winsock2 corruption". Here's what they say: "To repair Winsock if you have Windows XP Service Pack 2 (SP2) installed, type netsh winsock reset at the command prompt [I typed it in the start --> run box, which worked], and then press enter." There's more info at the MS site. My IP address renewed itself ok after that and I'm back online.

The problem for me may have had something to do with uninstalling Content Watch Internet filter and their dll file called "cwhook."

Good luck!
HI. I had the same problem that you,( limited or no connectivity). I tryed to run ipconfig/renew, and i had an eror that say's that my DHCp server is not responding. The thing is that i have 2 laptops at home, one of them is working exelent, and the second one, ust don't wants to connectthe internet by wilrelless(but the cable internet is workin) I just don't know what to do..
Not open for further replies.