1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Upgraded BIOS added an LPT1.4 port , Printing wrecked

By nbthor ยท 4 replies
Nov 7, 2005
  1. I recently upgraded my BIOS, with much back and forth with esupport, and the flash went smoothly with no apparent problems. Some of my previous problems seem to have reduced. Fantastic :) .

    I kept getting a found new hardware pop=up for my already installed Canon Multipass C755, I am running Windows XP SP2. The printer worked fine. I checked the hardware and found an LPT1.4 port. My lpt1 port was still there.
    The found new hardware wizard was just annoying. So, finally today I thought I would remove the printer and reinstall, hoping that that would place it in the correct spot.

    Well, now I can't reinstall the printer. The current disk is not compatible with XP, but I have an update and a patch for xp2. When I try to start the printer installer it does nothing. The hourglass icon flashes for a few minutes and then nothing happens. I've checked the event logs and nothing seems to be pinpointing the issue.

    I've tried totally removing all the bits of the old software right down to removing the registry entries, without any luck.

    I've tried plugging and unplugging the printer from both the computer and the power.

    I am at my whit's end.

    The printer is connected via a parrallel port, just not a LPT1.4 port.

    I removed the key for the LPT1.4 port from the registry, but when I turned the computer back on, it was back.

    I would appreciate any suggestions. Thank you.
  2. Triton

    Triton TS Enthusiast Posts: 82

    Many motherboard BIOS default setting for printer port is SPP (Standard Printer Port) not bi-directional.
    When you flashed the BIOS it was probable reset to the default SPP.

    Delete both printer ports in Windows and then boot into the motherboard BIOS.
    Enter the BIOS and set the printer port to ECP/EPP.
    Boot back into Windows and let it detect the printer port.
  3. nbthor

    nbthor TS Rookie Topic Starter Posts: 35

    Thanks, I couldn't remember which setting that port was supposed to have, unfortunately, changing it didn't help. The LPT1.4 port did disappear though.

    I used msconfig to shut down a bunch of non-microsoft services, predominately symantec and spysweeper on a subsequent boot. I was able to get the installation software to run, but, the install didn't finish due to "Failed to register mpservic.exe to windows Nt as devices or services."
    I then thought, well why not do a system restore to return it to a previous working state and then do the msconfig thing to reinstall the software. System Restore has come back with unable to protect system error message. In event viewer, the specific error is "error #5: access denied".
    My system is weird, I can't reliably access Safe Mode. Mostly, I just can't. Sitting on F8 at startup doesn't do it????
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You should tap F8 lots of times before the PX loading screen comes up. Sitting on it or holding it down is not a reliable method indeed.
  5. nbthor

    nbthor TS Rookie Topic Starter Posts: 35


    I finally got it all to work. I had to turn off, manually, all the services associated with Norton Internet Security in order to allow the Multipass software to install. Even then it hit a certain point and gave a "Failed to register file with Windows NT as devices or services." error message and quit. This did however partially install the printer, which then showed up in the control panel. I was then able to use the add additional drivers option to add the Windows NT drivers out of the installation program.
    When I next ran the Multipass software to install the printer, without uninstalling anything, Voila :) the install proceeded as per standard and the printer works exactly like it's supposed to.

    Thank you for your help.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...