Upgraded CPU, but PC not having it.

By Everlong18
Nov 17, 2007
  1. Tried upgrading my CPU from a 3800+ AM2 CPU to a 5200+ AM2. Reset the CMOS, becasue of previous overclocking, and put the new processor in and fired the beast up.

    At first it just hung at the screen before POST. Sometimes it would get to the POST and tell me my checksum wasn't correct and default had been loaded (For BIOS, I presume). I couldn't do anything as the USB keyboard hadn't been loaded, so I tried a spare PS/2 keyboard and could get into BIOS. I saved and exited and got back to POST where it said the same thing again (checksum blah blah) so I tried pressing F1 to continue, but it just hung at a black screen.

    Anyone know what could be up with it?

    Rest of my specs can be seen from drop down.
  2. edsanit

    edsanit TS Rookie

  3. Everlong18

    Everlong18 TS Rookie Topic Starter Posts: 36

    I've checked all that. On the CPU support page, the BIOS version for the 5200 just links to the BIOS version I have now.

    Also, in the BIOS when I have the 5200 in, it shows 3GB RAM, but only 2GB usable, but with my 3800 it shows the full 3GB usable.

    The graphics card I have (Geforce 7600) has no power connector on it, so it gets all its power straight from the mobo, so maybe I could need a better PSU?
  4. edsanit

    edsanit TS Rookie

    Maybe, any luck?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...