upgrading to Firefox 2.0 in Fedora Core 5

By VicRic ยท 5 replies
Apr 11, 2007
  1. Hi.

    I learned that running

    yum -y --enablerepo=development update firefox

    is the easiest way to upgrade to Firefox in Fedora Core 6; it worked perfectly for me in 2 machines running FC6.

    Now, I have another machine running Fedora Core 5, and I can't run the risk of messing it up -

    Would the same command line work fine in FC5 ?

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The development repo represents the future FC7. Yes, trying FC7 packages on FC5 may be risky.

    You can tell yum to only show you what would be done and not actually change anything on the system.
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I install Firefox in most systems by extracting the .tar.gz package to home directory and running it from there. No harm done to any system files and it's just as easy.
  4. VicRic

    VicRic TS Rookie Topic Starter Posts: 44

    Thanks Nodsu, thanks Mictlantecuhtli.

    In the end I decided to perform an upgrade of the whole system, from FC5 to FC6; then I applied the tested and true "yum..." command.

    I had a bit of a snag when at the end of the 'yum' command I got a message stating

    Running Transaction Test
    Finished Transaction Test
    Transaction Check Error: file /etc/gre.d/gre.conf from install of firefox- conflicts with file from package seamonkey-1.0.8-0.5.1.fc5

    I uninstalled SeaMonkey and run the command again, which ended successfully then.

    Now, excuse my inexpertise, but I have a problem that I hope you can help me solve.

    When I run Firefox 2.0 as 'root' I can see all sites which require the latest Shockwave Plugin, but when I run as 'user' the browser asks me to 'download plugin'.

    If I review the "about: plugins" as root I get the following:

    If I review the "about: plugins" as user I get the following:


    Could you give me some direction ?

  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The plugin was installed for only the root user most likely..

    You should have a flash-plugin or some similar package that you can install.
  6. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    In Firefox's about:config page, you could change plugin.expose_full_path to true to see where the Flash plugin went. You can also copy it to user's profile directory.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...