USB device not recognised

By Erwin0265 ยท 9 replies
May 2, 2007
  1. Hi,
    I am a high school teacher from Australia. I teach maths and science to 11 - 16 year-olds [you know, the kids that want to learn - hahahaha].
    Anyway, I recently purchased a "new" computer on Ebay:
    It's a Dell Optiplex GX60.
    I do a lot of airbrush artwork [yes, even though I teach maths and science] and computer manipulation using Photoshop. My previous computer simply couldn't cope so I thought I'd get a faster/"better" one.
    Believe it or not, but the PSU is only 180 watts - but I have been told that Dell PSU are unique and that I can't upgrade.
    I have yet to manage to get through to Dell as they only appear interested in customers who have a warranty.
    My problem is this, with almost evey device a connect via USB, I get "USB device not recognised".
    In other forums, I had suggested that I get a powered hub as this should solve the problem. However, my old Belkin USB 1.1 hub appears to work fine, albeit slow; I purchased a USB 2 hub and the coputer installls it and then again comes up with, "USB device not recognised" - it doesn't matter which port I use [although the 2 front ones appear to have less power than the back ones] - the 2 front ports support only card readers - no even memory sticks are recognised [except through the old USB 1.1 hub].
    I have spent the better part of 2 weeks on this issue and am just about ready to chuck this computer in the corner and start hunting for another computer on Ebay [But NOT a Dell - which I was lead to believe was a good quality brand].
    Dell's own forums are full of this same issue with many solution - none of which work.
    So, I thought I'd try another forum.
    BTW - the new USB 2 hub is not the problem as it runs fine on the old computer - with all 7 ports filled - no problem.
    Any suggestions???
  2. tweakboy

    tweakboy TS Guru Posts: 467

    You must install the motherboard drivers for that PC ,,, It will then install proper USB drivers and your good to go.

    You must first find out the model of the pc or motherboard, then try and find latest mobo drivers,,,,

    On any PC, usb just doesnt work by itself,, u need proper usb filter driver or mobo driver,, gl,
  3. Erwin0265

    Erwin0265 TS Rookie Topic Starter

    Hi Tweakboy,
    I have USB drivers - Microsoft simply can't find a driver for this hub [it's generic, from HK - no brand - no instructions - no back up].
    Another forum entry suggested I disconnect the PC from the mains for an hour or so,. to drain residual "something" - I forgot what - that seemed to help a few problems as I had difficulty with the PC recognising USB devices - except via a USB 1.1 hub.
    Now, I know this PC is a Dell Optiplex GX60 - don't know what mobo - I have updated everything under the Sun from Microsoft [except for IE 7 and MP 11 - don't like 'em] - what else can I do?
  4. DellCA

    DellCA TS Rookie Posts: 16

    Erwin0265, Checking the system specs, it has six (6) USB 2.0 ports, so I'm not sure why you are having the problems.

    If you haven't already done so, try (re)installing the Dell Desktop System software, and the Intel Chipset software (both available from You might also try resetting (or even updating) the BIOS, and then checking what the USB port settings are. If you are using a powered USB hub and/or a USB device with its own power source it should work just fine.

    You might try running the Dell diagnostics to see if it finds any problems with the system. That is available from the support site (Dell 32 bit Diagnostics) or, if you have the disks the system shipped with, you can run them by booting from the Dell Resource (aka Drivers & Utilities) CD.

    Hopefully this will help. If you have other questions on the system I'll be happy to answer them.

    Dell Customer Advocate
  5. CCT

    CCT TS Evangelist Posts: 2,653   +6

    I would also suggest you look up how to get into the Bios and ensure USB 2.0 is enabled - many past Bios had usb enable, then a separate setting for USB 2.0 enable and THEN a setting for USB 2.0 of either full speed (12 mb/s) or high speed (480 MB/s).
  6. DellCA

    DellCA TS Rookie Posts: 16

    My apologies for leaving that out of my previous post. You can access the BIOS (aka System Setup) by pressing the F2 key while on the Dell splash screen just after powering on the computer (this works for any Dell computer).

    In the BIOS, in the Integrated Devices section are two USB settings: USB Emulation (should be ON to enable USB keyboard/mouse support during system startup) and USB Controllers (should be on to enable USB ports). Other than 'on/off' there are no other USB settings in the BIOS.

    If you wanted to reset the BIOS back to the Factory Defaults, go to the BIOS screen then press ALT+E (clears stored settings) then ALT+F (resets to factory defaults) then ALT+B to save the changes and restart the computer. There is also an ALT+D option to reset the currently selected BIOS option to its factory default setting.

    Dell Customer Advocate
  7. CCT

    CCT TS Evangelist Posts: 2,653   +6

  8. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    you can upgrade the PSU, but it must be dell compatible.
  9. disciple

    disciple TS Rookie Posts: 30

    This might be nothing, but i was get the same "usb device not recognised " after i installed my new motherboard. The back ones worked fine but the front ones off the case gave me the above. It was down to that i had connected the usb wires to the motherboard wrongly; when i corrected this they worked straight away. So check the usb wires to your motherboard; the setup should be in the manual of the motherboard.
  10. DellCA

    DellCA TS Rookie Posts: 16

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...