Usb drive problem, help

Not open for further replies.
Hi, I've just been given a dane-elec 4gb usb pen drive when i plug it into my computer it recognises it, but when i click on it, it says insert disc into drive, now my laptop is running vista I've gone into disc management to reformat it but it doesn't let me, I've looked in device manager and it say device working properly. Any ideas???? anyone. Thanks in advance. ok just noticed the pen drive is in a file format called master boot record???


Posts: 13,806   +3
Warning: The tools in 2. and 3. (below) will format (ie remove all data from) your flash drive, but as a last resort it is worth it.

Check for a tiny switch on the flash drive, some have this
Confirm it is not in the Write protect position

HP USB Disk Storage Format Utility

This will format most USB flash drives
It can be known to recover Flash drives that are un-responsive too.

If that doesn't work try this one:

Hard Disk Low Level Format Tool (USB Flash drive "format" that is ;) )

The following entails editing the Registry
warning: If you are not comfortable in doing this, or inexperienced with the registry, then don't do it ! Incorrectly modifying the registry can have drastic effects on your system.

Start->Run-> Regedit
Expand: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
(Note: if this key doesn't exist, then disregard this option, and close Regedit)
Double click on the string ‘WriteProtect’ and change the ‘Value Data’ box to ‘0’
Close Regedit, and Restart

Please reply if any of these options helped you :)
Hi, thanks for your help but none of your suggestions worked (all though i don't under stand the writeprotect change value) could u explain this a little better. Thanks


Posts: 13,806   +3
Thanks for your reply
The above was basically a copy and paste of one of my text files, that was relevant to USB flash (pen) drive formatting.

The little switch on the side of some (not many) small flash drives can obviously stop any format of the drive. These switches are quite tiny, and again not on all flash drives.

Regarding your unresolved issue, I wonder if you have tried plugging in your flash drive to another computer (to eliminate your computer as the possible issue)
It is possible that you may be missing some updated drivers; or possibly have Windows corruption. Or even a faulty USB connection on your computer.
Therefore it would be best to confirm trying another computer first


Posts: 2,653   +0
In My Computer do you have a mapped network drive to another computer and since this is a Laptop the actual computer that it is mapped to does not have to be available from this location.

If you do have a mapped drive to a network share then rt click and Disconnect.

Reboot to Safe Mode if or not you have this share. Do nothing but reboot back to normal from SafeMode desktop

Let me know!



Posts: 13,806   +3
I'd say faulty pen drive
You will need to return it to the place of purchase to service\replace it
Here are some contacts for -> Dane-Elec you may wish to email them and ask if there are any downloads (formatting tools or software driver) for your pen drive
Hi, I have this problem for a while with my USB flash drive and went through a lot of suggestions that were posted by different people, and unfortunately none of them worked, except I couldn't tried the Windows Registry since I don't have "Storge Device Policies" field - perhaps I am using XP SP2.

I have the same problem with another XP PC. I strongly believe there could be a problem with Windows XP rather than my USB drive. I wonder if some one could come up with any suggestions that could solve my USB write-protection problem?

Not open for further replies.