usb external harddrive issues

By amazon_sephy ยท 7 replies
Mar 23, 2005
  1. Hi,

    I just bought a Neo mobile storage harddrive case and cant seem to get it to install. When i hook it up it says its installing the drivers for a mass storage device on the usb port. When it finishes install it says problems have occured that may prevent the device from being used. When i look in the device manager, its not even listed! Im running winxp pro- sp2, and have an aopen ax4b pro 533 mobo. I have also tried this on my laptop running xp pro sp1, and on an old win 2k machine and none of them have gotten it to work. Any help on this issue would be greatly appreciated, thanks.
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    looks like you're either doing something wrong or the hardware itself is defective. Did the part some with any software and/or drivers?
  3. amazon_sephy

    amazon_sephy TS Rookie Topic Starter Posts: 83

    no, it says that windows xp will auto install the drivers for you. i dont see how i can be doing anything wrong. i plug in the enclosure to the hd, and then plug the power in, and plug the usb into the pc. It detects it for a second, and then just doesnt install drivers for it. Also, i read somewhere to check for hidden devices in the device manager, sure enough it shows up as hidden. I have no idea what that means tho....
  4. patio

    patio TS Guru Posts: 482

    Has the drive itself been prepared for the system i.e. partitioned and formatted ?

    Or have you tried another drive in the enclosure?

    patio. :cool:
  5. amazon_sephy

    amazon_sephy TS Rookie Topic Starter Posts: 83

    i tried a harddrive that ive used for data already. its an 80gb wd that has a windows 2000 installation on it, and data just thrown on there when it was used as a secondary drive in my system, its formatted as ntfs. I have also tried an old 2.0gb wd which has windows 98 installed, thus it uses fat32. Neither drive works with it. Maybe i have to put a freshly formatted drive in? Maybe the old drive simply cant work in the thing, and i have to use the newer 80gb freshly formatted with fat32? Once i get the data backed up on my 200gb seagate which im having problems with mentioned in the thread above this one, ill try that drive in this thing. I cant format the 80gb at this time.
  6. zephead

    zephead TechSpot Paladin Posts: 1,569

    reformatting the drive won't fix anything. your problem is with the drive controller. see if you can return it or exchange it for another one.
  7. patio

    patio TS Guru Posts: 482

    I agree with zephead.

    patio. :cool:
  8. virent

    virent TS Rookie

    I am having the same issues with this enclosure. Anyone have any solutions, other than returning the unit?

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...