1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB failure

By PFJ ยท 19 replies
Oct 14, 2005
  1. Fellow Techspotters,

    Having recently restored my Dell Dimension 8300 WINXP HE OS to full health & SP2 with a re-install and an onslaught with AV software against virus/malware/spyware everything was rosey in the garden until my son & his buddies (who were the cause of my last crash) struck again.
    I was informed that the USB ports are not working.
    I looked in the Hardware Manager and it states that all devices are working correctly and no conflicts under the USB HUB/ROOT. But still I disable then hoping that on startup the OS would reinstall whatever was missing. It did - but the USB ports still did not function. So I thought that perhaps it ws harware related and that they had damaged the 5V rail but I check this with the DMM and it's working fine.
    I ran AV checks and did find several TROJANS, cleaned these and used the HJT in safe mode to do more cleansing. Still no joy. Another clue might be that it does not shut down properly and most times requires a hard shutdown.

    The drivers that came with the PC are no longer useful because I've upgraded to SP2.

    Any ideas?


  2. iss

    iss TechSpot Chancellor Posts: 1,994

    What I would do is make a XP disk from your dell recovery disk you can find out how here.


    Then use Nlite http://www.nliteos.com/ to slipstream SP2 into it and you will have a XP with SP2 disk you can use for installs and repairs.

    once you make the disk or borrow a disk of XP SP2 put the disk in the drive and run System file checker by opening a command prompt and type sfc /scannow this will scan the system files for any corruption or missing files and repair or replace any that need it.

    other than that did you try system restore? and going back to a point right after the fresh install?

    Oh yeah, one more thing BAN THE KIDS FROM THE COMPUTER! :haha:
  3. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Windows LUA tip

    I highly recommend this windows LUA article as a means to control systems with multiple users -- kids or others that have little real knowledge of systems administration.

    There's lots to consider, but the benefits are just wonderful. To avoid changing the
    subject of this thread, I'll create another thread and post back a reference here.
  4. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    Thank you jobeard and iss for your replies. But things have gone down hill since I last posted. The darn thing is freezing now. I had just enough time to add chkdsk /f in the run box before it locked me out. When I rebooted the check disk came up but halted at 91 percent. The next time it past stage 1 of 3 but stoped at 17%. Now it doesn't want to boot into safe mode (it also froze) as I had hoped to post a HJT log.

    The USB problem was not life threatening until I wanted to print but I could live with that for a while but now THIS!

    My son :evil: (whom I will soon disown & place on eBay) has informed me that while downloading a game something about a virus appeared. :(

    Any ideas or suggestions for another weekend to be spent resolving computer related problems.


  5. iss

    iss TechSpot Chancellor Posts: 1,994

    Frankly, I wouls say using the recovery disk for a format and reinstall is your best option.
  6. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    while working on the problem(s) and if you have broadband, disconnect from the internet until you get control.

    when you get control, change your password and then add an account for
    junior and make it a limited type of account. This will make it difficult for
    him and the virus-trojans to control the system again.
  7. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    Eventually got it to the point where it reboots normally and apparently doesn't freeze. I came home from work and my daughter must have switched it on/off so many times that the virus gave up!
    I was then able to run a virus check in safemode using Kaspersky which took over 5hours. I put this down to the fact that it was being thourough. It found several Trojans and one Worm.
    Then my son and his friends were playing a game the requires the internet and next morning I had lost my internet connection. Now NO INTERNET and NO USB!
    I can see that the IP address is different to that which I had before but I've done everything within the WINXP OS to change it but to no avail. The icon tells me that 'I have limited access or it must be diconnected'
    I know my cable & broadband modem are operating correctly.
    Could there be another virus or worm writting its IP? Can I alter the IP using DOS Prompt?

    P.S. I tried the System Restore and though it took almost an hour it informed me that it could not restore to the check point that I had selected. Instead it just doubled my shortcuts and did away with my restore points in September!

    Also, tried doing the XPsp2 disk by slipstreaming but this it would not complete the slipstreaming and gave me an error message so I gave up on that around 1.45am :zzz:

  8. Wolfleader

    Wolfleader TS Rookie Posts: 50

    what virus scan are you using? if it is an older ver. it might not be able to find all the viruses you have. try upgrading youre antivirus at the first chance you get. that might help out a bit.
  9. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    Hi Wolfleader, I used Kaspersky that really took time to scan and found the virus. But you are correct - it did state that it was 54 days since it was updated.
    At the momemt I'm going with ISS suggestion to format and re-install. But I know that I am going to make a hash of this. I cannot find a difinitive explaination of the formating sequence on any website. They all expect the reader to have a good knowledge of whats involved.
    I got a right going over by the missus because I'm spending more time repairing this PC than I spend with her...
    If I knew how or if it is possible I would like to have four partitions...one for each account. So if my son messed up his drivers and registry files that it would not affect mine. Then he could repair it himself (like that will happen!) or do without.

    on company Laptop.
  10. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    OK. The saga so far. I successfully re-formatted and reinstalled WINXP and the SP2 + updates. Drivers installed etc...but still no USB. The are no conflicts attached to the USB Hub in Device Manager. What I do noticed is that if I plug USB compatable equipment into the front ports the pointer freezes.
    The rear ports do not freeze the mouse/keyboard but are also not functioning.

    Do I have a hardware problem?


  11. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    there are TWO types of USB connectors; type 1 and type 2 (both look alike too )
    The front-panel is 'usually' USB 1.0 and for camera attachments.
    If you buy ONLY USB 2.0 cables, they can be used anywhere, but they have
    two styles; A-B and the A-A. The A-end always goes to the system, and a B-end goes to the device - - it's almost square with two rounded corners.

    If the devices is strickly 2.0, then only use the REAR system connections and
    I would doubt a hardware problem exists.
  12. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    Thanks for the info jobeard. I did wonder why they put two on the front and two on the back but I concluded that it was purely for accessibility.

    There are indeed many sites mentioning similar problems with USB failure in XP and I've tried all the suggestions - even the sledgehammer solution as suggested by Dell of re-formatting!

    I have tried my USB flash device as a test jig and on insertion the PC freezes. My son confessed that a friend had a USB flash on a bunch of keys and inserted it into the front USB socket - now I'm thinking that one of the keys may have inadvertently been inserted into the adjacent front USB socket. This may account for the reason why the front USB ports cause the PC to freeze and not the ones at the rear.

    But why are there 8 USB root hubs listed in the Device Manager when I only have 4 sockets? :confused: Heeem!

    If it turns out to be the MOBO, do you think that a USB via PCI card would work?


  13. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    The continueing saga..
    Still have not resolved this issue. Searched umpteen sites & threads related to USB issues but to no avail.

    I have a question relating to the compatability of firewire/USB with which I was going to start another thread but I'll asked it here for the moment:

    I see that I have a 2 X firewire ports on a PCI - Is it possible to use this with my USB printer and flash?


  14. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Firewire cables are not only different and will not plugin with USB, but even more expensive than USB. Few devices offer both types of connectivity. I've seen several USB-to-$something-else converter, but don't recall USB-Firewire being available.
  15. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    This saga has turned into an epic...Still have no USB connectivity. When I insert an USB device the PC freezes - not just the keyboard & mouse.
    I have scanned, tried drivers, uninstall for PnP to no avail. So I have this problem in work where I've lost one of my serial ports so I thought I'd look at conflicts. Then I thought that perhaps here is where my USB troubles reside. So I've captured the IRQ settings and would some kind Techspotter have a glance at these to see if I'm barking up the wrong tree and do further untold damage!

    Best Regards

  16. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  17. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    thanks RBS but I've tried all of that.

    I've uninstalled the any driver associated with the USB ports and allowed winxpsp2 to reinstall the drivers again.

    I thought that the answer to my dilema was an IRQ conflict although no exclamation marks within yellow triangles appear to indicate a conflict.

    I could purchase an USB PCI card but I see that this didn't work for someone else with a similar problem.

  18. Carldalynx

    Carldalynx TS Rookie

    Similar USB 2.0 problem

    Not a solution, but a possible narrowing down of the problem.

    I have an ASUS P4S800D-E Deluxe motherboard that has been giving me similar problems. When I plug in my, known working, SanDisk Cruzer drive to any front or rear USB port, the computer locks up tight, requiring a cold boot. There are no errors in Device Manager. I tried uninstalling all the USB controllers and letting XP SP2 find and reinstall. The problem continued. Disabling Legacy USB did not help, nor did installing the SIS patch.

    Interestlingly, I found an old USB 1.0 card reader and plugged that in. It worked fine in any USB port. I went into the BIOS and disabled USB 2.0. When I plugged the Cruzer in, the PC continued to work and the Cruzer showed up as a valid drive. Of course, things transfer really slow, but I have now narrowed the problem down a bit.

    You might try disabling USB 2.0 and see if this helps.

    If anyone knows what my next steps should be, based on the above, I would appreciate the info.
  19. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    thanks for your input Carldalynx. I'll give it another go tonight. Failing that I might uninstall WINXPSP2 as it appears that the problem arouse around the time I formatted and re-installed WINXP and upgraded.
    I see others have had similar problems when they upgraded.


  20. PFJ

    PFJ TS Enthusiast Topic Starter Posts: 112

    To conclude:
    thanks everyone for your input - in the end I installed a PCI-USB card and disabled the USB in the BIOS. Now, evrything is back to normal - well kinda!


Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...