USB Flash Drive Problem Windows Server 2003 (similar to XP probs)

By Dolemite ยท 12 replies
Dec 26, 2004
  1. Hi all,
    I've spent the past six hours trying to work out a USB Flash Drive mapping (and mount/dismount) problem in Windows 2003 (standard). I have been browsing around and found problems with conflicting mapped network drives, conflicting smart card readers etc... but my problem seems to be a bit different.

    To be clear on what I've tried here's a list:
    1. Close and re-open Windows Explorer
    2. Uninstall and re-install all USB controller devices out of the device manager.
    3. Re-assigned the drive letter for the removable device via disk manager (i.e. made the device drive Z)
    4. updated bios to latest revision (from MAR 2002) I'm using a relatively older system 700MHz - AMD Duron system on a Gigabyte board.

    Things I've checked
    BIOS Settings: OK - USB support enabled
    Drive mapping: NO Network drives are mapped
    Just 1 HD (C) and a CDROM (D) and burner (E)


    1. When the flash drive is plugged in while the computer is booting
    2. When the disk manager is open - must be the active window within the computer management console. (I can mount and dismount the drive time after time without any problems). As soon as I close the disk manager (and computer management console), that's when re-mounting the flash drive fails.

    1. After Windows is loaded, then unplugging the flash drive... Dismount is fine. Once re-inserting the flash drive, the mount fails at some point and the drive doesn't get mapped. NOTE: If I manually type in F:\ in the location bar, I can read and write to the drive, however it is never acknowledged by win explorer... It shows up as a blank with no name or description. Once unplugged, the drive fails to dismount and Windows gets hung up when trying to shut down/restart.

    There is nothing wrong with this flash drive, as it works in other computers I've tried it on. In fact, I have no problem with this drive on my laptop which also has Win 2003 Standard installed (this laptop is also older @ 700MHz - Cyrix system). I checked all the settings in the "disk manager" and "Removable storage" and everything is the same...

    I've done exausted all my steam!
    Any ideas? Please let me know if I'm not clear with my problem.

  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Could it be a faulty USB-connection?
    Surf to and D/L their test-version of SourceUSB.
    It should tell you what sort of USB-connection/s (if any) you have
  3. Dolemite

    Dolemite TS Rookie Topic Starter

    Realblackstuff: Yep, USB connections are all good. That is a nice utility you pointed me to though.

    I'm tending to lead to some sort of glitch in the OS. Again, if the disk manager is open, the flash drive works perfect. As soon as I close the disk manager, the flash drive doesn't mount. (yet is accessable by manually typing in it's drive letter).

    Thanks much!
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Install the MS Tweakui for XP. In there is a setting under "My Computer" to lock/open the rest of your drive-letters. They may be "locked" now.
  5. warringtonrule

    warringtonrule TS Rookie

    Udick 2.0


    hi i got a udisk 2.0 flash usb drive and i got a problem with it,
    when i put it in the usb socket (2.0) it automatically adds media songs to the flash drive, what could i do to solve this or another help is how to delete the flash drive from the computer and re installing it

    PLEASE HELP asap :(
  6. mcarlclapp

    mcarlclapp TS Rookie

    I am a newcomer to TechSpot. I came her looking to a solution to a problem with my zip drive similar to the one that you addressed here. Tweakui was the answer to my problem. Thank You for your help.

    Marvin Clapp
  7. Blakhart

    Blakhart TS Rookie Posts: 353

    My guess is a service such as Plug and Play (not the UPNP plug and play) and/or Removable Storage may be disabled or not starting as they should. Tyr them set to auto and see if that helps any.
  8. mcarlclapp

    mcarlclapp TS Rookie


    Thank You for your suggestion. I have just discovered that the problem was solvable by unlocking my G drive with tweakui. Nevertheless I appreciate your suggestion. As a newcomer to this forum, it is great to find people who are able to offer their assistance to computer problems.

    Marvin Clapp
  9. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    are you STOPPING the drive before unplugging it? Hotswapping is dangerous to the media.
  10. mcarlclapp

    mcarlclapp TS Rookie

    zip drive

    I always stop it first although I notice when I look at its properties that it is set so that I don't have to stop it first.

    I found out that this time, the problem was in Windows. The drive (G) was turned off. I used tweakui to turn it back on. It is working fine now. Thanks for the input.

    Marvin Clapp
  11. SMichaelReeves

    SMichaelReeves TS Rookie

    External USBHard Drives Not Being Seen by Server

    If you are running Windows Server 2003 and you are wondering why your USB Hard Drive is not seen by the Operating System after you plug it in, here is the answer to this common problem.
    Windows Server has a tendency of attempting to assign a drive letter to the USB hard drive that is already in use. If you have plugged in a USB hard drive and checked in Device Manager to see if it is working correctly, and it is, the next step you need to take is to open DISK MANAGEMENT and look at the current disks. You will see that there is your standard C drive, your cd / dvd drive and then you may see your USB Drive but there is not a letter assigned to it. Go to that device that does not have a letter assigned to it, right click on it, and then click on CHANGE DRIVE LETTERS AND PATH. You will then see a place to change the drive letter. Simply change it to a letter that is not being used already (example C or D) and then CLICK OK. You problems are not resolved. The operating System will assign the letter of your choosing and from then on, you will have total and complete access to your External Hard Drive. Also, the operating system will indeed remember the letter that you assigned to it and when you unplug the hard drive and plug it back in, the system will assign it the same letter again.
  12. scuderi

    scuderi TS Rookie


    None of this works for me, because the external USB drive does NOT show up in Disk Manager. Ever. The drive is detected fine in XP Pro SP2, however, so I know the drive and cable are good.

    Windows Server 2003 Standard SP2. Device manager shows 5 "USB Root Hub"s, 4 "VIA Rev 5 or later USB Universal Host Controller"'s, and 1 "VIA USB Enhanced Host Controller" all of which are automatically re-installed by the OS if I remove them.

    I haven't tried a BIOS update yet.
  13. scuderi

    scuderi TS Rookie

    They don't include a serial no. with their trial, so you can dl it, but you can't install it... as of Oct 30, 2008 anyway...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...