USB Flash Drive Problem with Windows XP

By RCman · 34 replies
Sep 7, 2003
  1. I am having a few problems with my new TCI USB 64MB Flash Drive (USB Mass Storage Device). I am running Windows XP Professional on both systems described below.

    I know that the device is working, because it works with no problems on my older AcerPower 400mhz (Please see System Specs #2 in my profile) I can read/write to it, no problems occur. TCI Inculded software, I didn't install it and Xp just went alone with no problems, intalled the USB Mass storage, and it works.

    I do however have problems with it when I connect it to my Gateway Performance 800mhz, (Please see systems specs #1 in my profile). I tried as I did with me AcerPower, not installing the drivers, but for some reason, XP told my it had errors installing the driver, and the device was not working properly. So I tried installing the TCI inculded software, as instructed, and it nstalls with no problems what so ever, but when i connect the device one of two things happens at random; 1) The device is detected for a short while (5-10 sec, then disappers, so i am not able to use it, and scanning for new hardware does not help. or, 2) The device shows and says it is working fine and appers like it should, but i am unable to read/write to it and the device manager for it says "Satus: Unreadable". I have also tried pluggin it into different USB ports.

    I know it is a working USB Flash Drive, because I have NO problems with my AcerPower SE, and its a much much older computer. Windows XP Professional is installed on both.

    Any help would be greatly appreicated.

    Thank you,
    Bill :)
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Firsthand, i would recommend installing the original chipset drivers from Intel/Gateway. Delete the USB stuff in the Device Manager first, reboot and let XP install new drivers.

    There may be some options in BIOS for USB too, like allocating an IRQ that may help.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    As above, remove your USB controller & hub from Device Manager and physically remove your USB device.

    Reboot and allow your USB controll & hub to reinstall fully. Then insert your pen drive and make sure you are very still. ;) If you let it do its thing for about 20-30 seconds, it should detect the drive properly.

    If this still does not work, I would recommend updating your chipset / USB drivers and repeating the process.

    If you still have trouble, attempt to manually install the drivers provided with your USB pen drive WITHOUT the device plugged in. This is a common problem with USB devices under Windows in general, although I haven't seen it so much with USB storage devices.

    And if it STILL doesn't work, kick it a few times for the Rickster.. Then update your XP either through Windows Update ( ) or install the latest service pack.. It's kind of like hitting it with a hammer - A more broad and general solution to your problem.

    You may also want to try different USB ports, remove other USB devices etc... Don't think something is silly until you actually try it and it doesn't work. ;)

    And if it does not work after that.. Hopefully someone will have better ideas. :)
  4. RCman

    RCman TS Rookie Topic Starter Posts: 22

    Thank you for your sugestions, unfortunatly its still not working, after trying everyones' sugestions, my guess is it is the chipset/USB hub drivers on the motherboard... I was hoping to get a new computer soon anyway... I really appreicate the help.

    Thank you,
    Bill :)
  5. bsbavishi

    bsbavishi TS Rookie

    Problem in detecting USB Flash Drive

    I have a very serious and distinct problem, I had 2 USB Flash drive of BENQ. Both of them are of 512 MB. I was using both of this from last 7 to 8 months and it was working perfectly and it had never created a problem. suddenly yesterday one of them had stopped working. it is detected by the Windows XP but saying that it is unknown device and when I am putting the other one it had detected and it is still working perfectly. I am doing my Masters in IT so i had tried almost everything but it is still not working so anyone can suggest me what to do?

    Thanking you.
  6. RCman

    RCman TS Rookie Topic Starter Posts: 22

    Wow, this thread is almost two years old, just got an email notification about it...
    Anyway have you thought of the possiblilty that the USB Flash Drive stopped working? Try it out on a different computer. They do have a life span and won't work forever. Good Luck.
  7. bsbavishi

    bsbavishi TS Rookie

    tried but not working

    I had tried in 3 other computers and all of them had given me the same message. Is there anything else which i can try. It is very important to me because my important data and backup files are in it.

    Thank you for replying me
  8. Gaz

    Gaz TS Rookie

    USB Flash Drive

    I have the same problem with a 256 MB USB Flash Drive. It was working fine but then without warning it has stopped working. Windows XP detects the device but in Device Manager all I am getting is unknown device. The USB Flash Drive does not light up and no drive letter is being shown. I have tried removing all USB devices and reinstalling, I have also tried this in safe mode. I have also used other USB devices (camera, Flash drive) these work fine. I have tried the non working USB Flash Drive on other computers all so with no success.

    Thanks for you time.
  9. booboo

    booboo TS Rookie

    Flash Drive Problems

    My PNY Attache flash drive was working really well when I bought it. But today it just stopped working. I took it into school and it would not open. It didn't work at home or on my neighbor's computer either. When I tried to open it a message came up saying that the drive has to be formatted but when i pressed the format option it said that the drive cannot be formatted.
  10. jarredcinman

    jarredcinman TS Rookie

    Another thing to try...

    This thread is real old, but I found it when searching for a similar problem so here's the solution I eventually came up with.

    I had mapped a network drive to E:, which my USB drive had previously installed at, while it was unplugged. When plugging it back in, it didn't show up anymore. I disconnected the network drive, and hey presto, my USB drive is back.

    So the moral of the story is, map network drives with the USB plugged in, so that they don't steal it's assigned drive letter.

    This may not solve everyone's problem, but it's worth a try.
  11. lady of the rin

    lady of the rin TS Rookie

    Help Me!

    I am having the exact same problem (and I have the same brand, too, a PNY). I am desperate to get it working again, otherwise I'll lose a good 10 years worth of work! I keep getting a message that says the drive isn't formatted, or it's formatted for a Mac. I've tried one file recovery progamsuggested in this thread already, and nothing comes up. I've even emailed the PNY Technologies tech support, and it sounds like there is little they can do. I am bordering on a nervous breakdown, here, and I need help! Please!!!!
  12. hsikkema

    hsikkema TS Rookie

    I had all the symptoms previously described....

    Try physically unplugging all wires from the computer and waiting 30 minutes or so and then rebooting - this worked for me and I was able to access the USB Flash drive again.
  13. Stephen (Aust)

    Stephen (Aust) TS Rookie

    Physically unplugging the computer worked for me as well.

    I had a memory stick that had been recognized for weeks but suddenly stopped working on XP (although was OK on another computer). Phyically switching off the XP computer solved the problem completely.
  14. ghdreamz

    ghdreamz TS Rookie

    USB Memory stick recognized but dosn't open in Explorer

    I copied some files from my XP pro machine to my Kingston USB (512MB), when i plugged it in one Dell Desktop (front USB) it did not detect and gave a message that "Drive is not formatted, do you format it now?"

    Since then i am not able to use my USB memory stick, though my system assigns a drive letter to it every time i plug it in the usb slot. It even shows
    Kingston data traveler in the hardware list, but it never opens the file
    explorer for USB memory stick. I guess the file system is corrupted and i
    tried to format the drive but that also never worked.

    I tried using different machines to plug this usb stick, tried differnt OS
    (windows 2000 and XP), tried front and back usb slots, tried un-installing
    all usb ports and reinstalled after rebooting... none worked.

    Any help/suggestions would be appreciated

    Thanks in advance
  15. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  16. triton1005

    triton1005 TS Rookie

    ok looks like i have a similar problem w/flash drives. i have read all in thread but none are a match; my sys runs xp pro sp2 and it finds the mass storage usb stick but in my computer it shows 0 bytes free, 0 bytes used, cannot be formatted, does show as drive G. i tried disabling onboard usb ports and installed a pci card w/4 ports still same. when i querry drive G it says insert disk into drive G. tried plugging and unplugging it ....? flash drive works in my thinkpad, but not this desktop....pls terry
  17. nautiq

    nautiq TS Rookie

    Window XP Solution for flash drive not showing in my Computer:

    It sounds like a drive assignment conflict.

    Save yourself a huge headache and do the following:

    1. Right-click My Computer, and then click Manage.
    2. Under Computer Management (Local), click Disk Management.
    3. In the list of drives in the right pane, right-click the flash drive and then click Change Drive Letter and Path(s).
    4. Click Change, and in the drop-down box, select a drive letter for the new drive that is not assigned to a mapped network drive.
    5. Click OK, and then click OK again.
  18. ramseybuckeye

    ramseybuckeye TS Rookie

    I had a Lexar jumpdrive quir working and finally got it to work by formatting it with Maxtor Maxblast software (for hard drives). No problem since then.
  19. flashout

    flashout TS Rookie

    I've got the same non-recovered failures as mentioned on the posts above.
    Well, it seems that the new USB flash memories are at least as much unreliable as the old floppy disks!
    They're just more expensive.
  20. DAStorm

    DAStorm TS Rookie

    Try This - It Worked For Me :)

    if anyone has problems on XP loading USB drives plug the USB in just before the YOU log into the machine that may fix it.iF YOUR COMPUTER BOOTS IN THE THE os WITH OUT LOGGING IN CHANGE THAT. You don't have to add a password just make sure you have to login.
  21. Percy

    Percy TS Rookie

    Problem formatting a 8GB USB Flash Drive


    I have an 8GB flash drive that I tried to format it using Disk Management in Windows XP. After the formatting process failed I plugged the flash drive again in the USB port. The computer recognizes the drive assigning it a letter. When I click on the drive it returns a message saying now "Please insert a disk into drive J:" If I right click on the drive and try to format it it returns a message "There is no disk in drive J: Insert a disk, and then try again". In Disk Management the drive is shown as "Disk4: removable (J), No Media" How can I format this USB flash drive?

    Any help/suggerstions etc. is appreciated
  22. cascadia15

    cascadia15 TS Rookie

    usb memory stick problem

    I’ve got a problem with the usb port and a flash memory stick on an XP pro system– sure would appreciate some help. I purchased a new cpu (XP OS)and was attempting to transfer files and data from my old system to the new (also XP OS). To do this I bought a 1 gig PNY memory stick. I plugged the stick into the new system usb port and got an ikon on “my computer”. Thinking everything was OK, I plugged the memory stick into the old system usb port preparing to down load various files. On the “my computer” screen I didn’t get an ikon. So, wondering what was wrong, I plugged the stick back into the new system – now, no ikon here either. I’m not that computer literate, but it looks like the memory stick has been “write protected” some how. Any idea what has happened and how I might fix it? I've got to say, I'm not very computer literate at all -- I've read the various threads about reassigning drive letters, deleting partitions, formating devices, etc. etc. -- so much "computerese" to me. Is there a written guide out there that can walk me through these fixes on a very primary level? Thanks. Geo.
  23. SisterG

    SisterG TS Rookie

    THANKYOUTHANKYOUTHANKYOU!!!! That worked for me, as well. I have a SanDisk Cruzer 2 (2gig) and it simply stopped working overnight. Not only did the fix you provided work, I didn't lose a single file in the process. And these files are mighty important to me, too. (Yes I had a back-up, but no it wasn't recent enough to keep me from cursing....) Btw...all who read, make sure you back-up your sticks regularly - for this very reason. Weekly is a good idea.... :)
  24. shaggy4284

    shaggy4284 TS Rookie

    what happened with me, windows automatically updated my usb drivers. all i did was disable the enhanced host controller and all the attached usb devices started to detect. Good luck to all.
  25. russ

    russ TS Rookie Posts: 39

    which method worked

    SisterG which one of the above solutions worked for you?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...