USB Flash Drive Problems

By cs_desertrat · 38 replies
May 25, 2005
  1. Hi, I have a 512meg usb flash drive Pen (No name brand from e-bay) and a sony 2 gig micro vault. Flash drive. I also have 4 different Computers. 2 - Dell 8400, 1 - Dell XPS laptop and 1 that I put together myself. (I’ve been building them for over 10 years). This is the first time I’ve tried “Flash Drives” Both of the flash drives are doing the same thing, on all the computers. I have spent the last week reading every “Forum” I can find about my problem and have found “Nothing”. This is what I’m dealing with, When I plug in ether drive into any one of my computers, the flash drive is recognized and the space available is correct. I can copy anything to both drives. I can also watch the “Copy” progress, something is being copied. When I view what I've copied on ether flash drive, I can see “Every” file I’ve copied. It appears to be there. Even the size is correct. But when I try to access any of the files, I can’t... I get one of the following errors, 1 – “The Parameter is Incorrect” or 2 – “Only part of a Read Process Memory or Write Process Memory request was Completed”, or 3 – a dos window will open for about 3 sec. and then close. Only 1 or 2 files I copy, Work… PDF files are in tacked and readable, as are Word Docs. But Nothing else. I find it hard to believe that I have 2 bad drives or a problem with all 4 computers. I hope someone can help before I give up entirely on “Flash Drives”… :giddy:

    Thanks guys, DRat...
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Have you tried formatting the flash drives? A corrupt filesystem will play all kinds of tricks on you.
  3. cs_desertrat

    cs_desertrat TS Rookie Topic Starter

    Yes, I use "Disk Managemant" to format both drives (fat32). When it's finished, "DM" tells me that the Partition is "Healthy and Active". And it shows the right size. Also, all of my computers are running XP Pro. I've have done this 7 or 8 times. Each time the same thing...
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Do you remove the drives with the "safely remove" thingy?
    Windows doesn't buffer writes to flash drives so it should be OK to just unplug them but who knows..

    A good thing to rule out any Windows issues is to use some CD Linux like INSERT or Knoppix. Just boot one of those and try formatting/writing/reading the drives in there.
  5. cs_desertrat

    cs_desertrat TS Rookie Topic Starter

    Yes, I use the "Safely Remove" tool... I do have Knoppix. I will try that... This is crazy... I'll let you know if it works. Any other thoughts will be greatly appreciated. Thanks...
  6. crshoveride1

    crshoveride1 TS Rookie

    I'm not sure about the no name drives, but the ones I use have "secure" options on them. Lexar and Sandisk. If the files are put into the secure folder, they go in to a hidden folder. Obviously you can see yours but is it in secured folder or does the properties have the "read only" box unchecked?
  7. cs_desertrat

    cs_desertrat TS Rookie Topic Starter

    Ok... Now I'm screwed... This is the first time this has happened since I've been working with the Sony Drive, I plug it in now and it shows up as a "Removeable Disk" or (Floppy Drive) with "NO" media. I can't even format it now.
    I didn't do any thing... Anyone run into this?

    When you mentioned "properties having the "read only" box unchecked?"
    I went to check it again. But now this...

    I do remember that the "Read Only" box WAS check on "some" of the files,
    But it never said "Access Denied"... ??? Just what I wrote above...
    And it would not let me change it. I DID try when I could see them...
  8. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    I don't know if this applies in your case but I have a couple of PNY flash drives that have a locking mechanism that works like the read only locking mechanism on old 3.5 floppies. At least, I think that's how they work because I've never used that feature on my flash drives.

    That could explain the read only files but not necessarily the inaccessibility issue. BTW, I've never had to format any of my flash drives (I also have a Dell flash drive). It's always been plug and play. I can open, edit and create files and folders just like on any other drive.
  9. cs_desertrat

    cs_desertrat TS Rookie Topic Starter

    Ok... I finally got a chance to try Knoppix. It did not recognize the sony flash drive.
    Maybe becouse the computer sees it as a "Removeable Disk" or floppy drive now.
    When I try to format now, it says to "Please Insert Disk".

    Anyone know why a Flash Drive would be seen as a "Removeable Disk" or Floppy Drive...?
    All my computers see it that way... ???

    Also, the drive does not have a locking mechanism of any kind.
    At least as far as I can tell by looking at it...

    Thanks for your help.
    I'll keep trying and will post the answer if I find one...

  10. cs_desertrat

    cs_desertrat TS Rookie Topic Starter

    Ok, here’s a thought, Up until now I’ve been assuming that a “Flash Drive” is a Flash Drive.
    Like as if, “No One” would try to “RIP us off” by selling us a Flash Drive that was anything less than what they clamed it to be.
    Well if the truth is to be known, everything needs to be considered as a possibility until it can be ruled out. All things considered, Visiting every web-site that seems relevant and every Forum that I can find, I have found “Nothing” that has even come close to fixing this problem I’m dealing with. I have noticed however, a lot of people are experiencing the same thing.
    My thought on this is over my head, as far as being able to say if it is even possible. Hopefully if the right person reads this, they will share with the rest of us, if it is a possibility.
    I tried to “Save a Buck” and bought 3 different Memory Sticks (usb flash drives) from e-bay. One of them is a “Pen” and 2 of them are oval thumb drives. The pen is a no name brand bought here, in the USA. One of the thumb drives was bought from “China” and the other thumb drive came from Taiwan (Sony). None of them work on Any of my computers. They all worked a few times and then stopped. Now, Nothing… Maybe this is an age old lesson, in that “If it’s too good to be true, It probably is”, Or “You get what you pay for”…
    Is it possible to make something “CHEAP” that will “Display” a specific “Size” (even if it’s NOT there) and hold “Some” data (to give the impression that it is a working flash drive), but will only display the file names and sizes of the reset of what ever you may copy to the “Fake” drive (again to give the “impression” that it is a working flash drive) And in a short time, just burn-up, wear-out, “Die”…
    I don’t know… But that seems to be what’s going on here… I’m starting to thing that I just got “Ripped-Off” 3 times in a row. All because I tried to “Save a Buck”.
    If this is true, Bottom Line, Stay with the “Name Brands” But in the USA “Only”. Do you’re homework; find out if what you’re buying, is what the seller says it is (The Sony I bought is not like anything Sony ever made :haha: )...
    And maybe Most Important of all, “You Get What You Pay For”…

    Just a Thought, -DRat
  11. satchmo

    satchmo TS Rookie Posts: 83

    Same problem

    I've had the same problem with some no-name USB drives. I posted my problem at this forum, but ended up with the same conclusion, that my no-name drives are just defective.

    I bought two of them, and both of them are defunct. So I support your conclusion. Buy name-brands. It does matter.

    I had the same bad experience with computer memories (PC3200 DDR memories). Name brand cost more, but it's worth the quality and it'll save you a lot of headache at troubleshooting.
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Go find someone with a PC that has W98SE on it, and that also has working USB ports.
    Format those keys there (in FAT32), problem solved.
  13. crshoveride1

    crshoveride1 TS Rookie

    I'm not sure about other machines but all mine see any one of my usb drives as "removable disk". Even the ones at work so I would assume that YES thats what they are supposed to see.
  14. cs_desertrat

    cs_desertrat TS Rookie Topic Starter

    I was hesitant to include the Point that my usb flash drives are seen as “Removable Disks” because I am aware that a system will view them that way. The difference is that there are different types of “Removable Disks”. One is a Flash Drive, Another type of removable disk is a “Zip Drive” or a “Floppy Drive”. With that type of drive you can “Remove” the Media or Disk and the system will still see the drive but there is nothing for the system to “Write to”, (if the media or disk is out of the drive). That is what's happening here. It sees the drive, but it’s telling me that there is “Nothing” to write to. It tells me to “Insert Disk”.
    “realblackstuff” just mentioned to try Windows 98se. I have a spare Hard Drive and a copy of 98se. I will use that drive and install a fresh copy of 98se on it and see if that works… At this point I will try just about anything, if it works…
    Thanks a lot “realblackstuff”. I hope you're right. I will try it shortly and Post my results, as soon as I can.
  15. slipknot

    slipknot TS Rookie

    i have a problem with my SANDISK 256 mb cruzer mini. i have had this for over a month and recently neither computers, (at home, nor at school) can recognize the port. it was working before, i have a lot of files on it, maybe half empty, but all of a sudden, it wont open. BUT when i double click safely remove hardware, behold!! it is there, BUT takes about 2 minutes disconnect, when before it took only 3 seconds. can anyone help me, oh yeah im running on XP. AND the green light is on. thank you

  16. craft99

    craft99 TS Rookie

    Excellent advice, your advice helped me solve my problem with my flash drive.

    Cheers buddy
  17. crshoveride1

    crshoveride1 TS Rookie

    try doing what they did in the previous post. If all else fails... there is a warranty that comes with your drive. Register it with sandisk and they should be able to help. Keep in mind that there's a chance you may not be able to retrieve those files again.
  18. ebayvictim

    ebayvictim TS Rookie

    I just bought a "Sony USB" 2Gb drive from Ebay. It allowed files to be copied to it, but I couldn't access them. I formatted the drive, and copied more files to it. When I went to use it in another computer, the computer said "please insert disk" even when it was inserted. Perhaps it is a faulty drive. Who did you buy it off? Maybe it is the same source?
  19. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Go again to the old W98 PC, FDISK the USB-key (delete/new partition) then format in FAT32.
  20. Craigg

    Craigg TS Rookie

    Yeah W98 might of sucked, but it does have it uses when XP decides to crap out on us.
  21. halo71

    halo71 TS Rookie Posts: 1,090

    slipknot, I have that same exact drive you mention. Had it about 6 months now with no major problems. It even survived a cycle through the washing machine and still works.

    Realblackstuff....please forgive me for asking this same question again in this post. But can you tell me why some Dell PC's at work will seen this drive and some won't until I reboot the PC? (This is not a huge problem, just getting annoying have to reboot them every time.)

    Also...ALL of the IBM's at work and my home computers see this drive with no problems. All running XP Pro.

    thanks.... :D
  22. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Yes. A few weeks ago (probably about the time you posted this) Engadget had a story on some 'company' that had flash drives that were really much smaller than their advertised capacity, but when inserted into a Windows machine would report as bigger. I'd try and find the link, but I don't really have time right now (I'm at work), and I don't have internet access in my new apt yet.
  23. goatlip

    goatlip TS Rookie

    Sony 2.0 GB Micro Vault off of Ebay

    I just got a Sony 2.0 GB Micro Vault (a little blue thumbstick with detachable leash) off of Ebay from seller co-ophenney for $97 and have had nothing but problems with it. Very similar to what others mention here. I put about 550MB on it from one computer, take it to another and when I go to some of the folders, it is filled with 128 other folders named 00000000.000. I try to delete them and it says the file is corrupt. :mad:

    There's a tiny CD that came with it, windows 98 drivers i think, but I cant make head's or tails of it. The packaging has a USM2024 on the bar code.

    I haven't tried it on a 98SE machine yet, need to find one of those.

    any other ideas on this or anybody know of any reputable people with some good deals on flash drives? glad I finally found something on this.
  24. goatlip

    goatlip TS Rookie

  25. What this price you expect? My usb drive working fine until today. :knock:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...