USB flash drive write protection

By maxhar · 92 replies
Dec 28, 2004
Post New Reply
  1. Little while ago I brought Samsung USB 2.0 512MB OEM Pack. For few week I have copied data from one computer to another (with different operating system). Last time I used my Memory stick in XP...copy the stuff from memory stick to computer with 2000 and plug the memory stick into win 98... as it didn't have suitable USB driver it doesn't work. So I took out the memory stick from it. Next day when try to copy some stuff on it (Win Nt) system said it write protect, I need to remove write protection. I try to format it but same result . Now it has happen on every computer and every operating system. I can't see any physical switch...
    Please help .... Operating System : Microsoft Windows 98,NT 4.0 and 2000
    CPU/Processor : AMD
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Are you absolutely sure there is no switch???

    I have had a flash drive go bad on me and lock itself in read-only position. I even opened it up and shorted the locking leads on the chip but it would still refuse to be writable.
  3. maxhar

    maxhar TS Rookie Topic Starter

    yeap....there is no swtich... I shown Drive to four or five people just to be sure ..... there is nothing....
  4. olda26

    olda26 TS Rookie

    The same problem!


    I have the same problem with the same device!!
    Samsung 512 USB 2.0 worked properly for few weeks,
    but now on every computer is write protected...

    Did you already found some solution or is it corrupted?

  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    My flash drive that went bad had a Samsung flash chip in it too.. Maybe it's some design flaw?
  6. LGT1

    LGT1 TS Rookie

    Formating and Write Protection

    I recently purchased a Kingston Datatraveler 2.0 512mb and Tried to reformat it. It became unformatted and I was not able to reformat it showed up as being write protected. Kingston advised me that this sounded like faulty hardware and to return it which I did I have not tried to reformat the new one. But I did note that at usbflashdrive org website the samsung model looks almost Identical to the Datatraveler.
  7. kingelph

    kingelph TS Rookie

    I also have a problem with the write protection yet the lock is open on the flash disk. Does someone have a solution to this problem?
  8. markwperkins

    markwperkins TS Rookie

    usb write protected

    I've two EasyDisk flash sticks with the write protect problem. It doesn't matter which position the switch is in it still comes up as write protected :-(
  9. vn_boxer

    vn_boxer TS Rookie

    I got the same trouble

    I got the same trouble with my USB Drive.
    I got an USB Drive 'Space Disk USB2.0'
    , my USB drive dont have any switch, but now it become write protected.
    Does someone have any solution to this problem? Thanks.
  10. fatbird

    fatbird TS Rookie


    OK – after an hour or so of faffing around :knock: , I think that I have found a possible solution :p . The problem seems to be something to do with Microsoft’s SP2 :dead: !
    Here’s what worked for me (sorry for the *****’s Guide approach, but I used to :hotbounce hate it :hotbounce when I used forums and couldn’t understand what the technobabble meant!):

    - Start > Run > type ‘regedit’ (without the speachmarks) > Enter
    - Single-click on ‘My Computer’ > File > Export > save it to the Desktop (Always best to have a backup!!)
    - Go to the following:

    My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
    *There seems to be some spaces here in 'StorageDevicePolicies' in the text above, there shouldn't be, OK*
    - Double click on the string ‘WriteProtect’ and change the ‘Value Data’ box to ‘0’
    - Then: File > Export > save somewhere useful as something like ‘StorageDevicePolicies001.reg’
    - You also need to do this for the strings in any folders called ‘ControlSet***’ (* = any Digit, i.e. 001, 002) – for example: Everything is the same, just change ‘CurrentControlSet’ to ‘ControlSet***’

    My Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\StorageDevicePolicies
    *There seems to be some spaces here in 'StorageDevicePolicies' in the text above, there shouldn't be, OK*
    - Save these to the same place as before as ‘StorageDevicePolicies00*’

    The saves are in case it reverts at a later date, just double click (saying ‘yes’ to importing these to the registry) on all of the files and it will all work again!
  11. elvallie

    elvallie TS Rookie

    still not working

    I don't know how... but I dont have in registry editor \....\control Storage Device Policies or nothing similar.. I am so angry because I am have been trying to repair it maybe 2 hours now on 2 different computers.... grrr :dead:
  12. alessandro_s

    alessandro_s TS Rookie

    I couldn't make my USB drive get back too. Same problem: disk is write protected. I tried even killdisk, but the software simply locks. Any other sugestion? Thanx


    Resolved problem USB Drive " White protect"

    Hi, I'm work in São Paulo \ Brazil and try to this for problem ... is very easy ..OK :wave:
    Click > Start > RUN > type "CMD" Then
    Type "CHKDSK" and type o your Pendrive and "/F". Ex. chkdsk Q: /F > Enter
    Ok, You see many msg error. OK! :confused:
    Now, you remove your pendrive and plug again.
    Try to format.
    It's work very well in Profilit USB Driver 256 MB.
  14. joel_dmccfi

    joel_dmccfi TS Rookie

    solution :)

    try this one, hope it will work on your memory stick coz i tried this and i was able to format my write protected memory stick :)

    use a computer with XP OS.
    right click 'my computer'
    select 'manage'
    then select 'disk management' to format ur memory stick. but sad to say, all data will be lost, am pretty sure you know it :)
  15. pcaceit

    pcaceit TS Rookie Posts: 315

    Usb Flash Write Protect Resolved (without Using Regedit) 100%

    I Tried to set security to prevent my Children / trainees writing to my USB Stick, I Used a Program Called XPSecurity 2005c Build 1219. Thinking it would set XP permissions for users, But it switched on the write protect instead. Download the Software From www.[U][/U] (use their site search).

    When you have installed the software! Click the File system Tab on Left and then the USB Device accessability tab and select Disabled. and apply

    If you still get a Device is write protected error when you try to format, then just do the format again (give a couple of seconds for the policy to be set)

    PS Software is not freeware Please register it. alternatively!

    Use this information and uninstall (I take no responsibility for unauthorized usage) NAME: removed by sngx1275 CODE: removed by sngx1275
  16. malar2006

    malar2006 TS Rookie

    how to remove write-protect from usb drive

    I have using 128mb usb drive.When i have to copy any files or folder from other disk to usb drive.It will give the error message
    "cannot copy-write protected.
    remove write protected or use another disk
  17. rlsaplan

    rlsaplan TS Rookie

    Same problem with Write Protect Error

    Hi guys,

    I have the same problem with my iVogue 256MB Flash Drive.

    At first I was able to copy a folder to the flash drive but when I tried to copy another one, the system says Write Protect Error, Please remove the write protect something like that. I tried to format the drive but it also says the same problem. But When I dismounted it to the computer and mounted it again, you can now delete the files stored in it and also format the drive but still you cannot copy a file/folder to it because of this error.

    Anyway I have formatted my flash drive 3times now, under FAT32 filesystem, but the error still persist after you've copied a file to it.

    I haven't tried to do the instruction that pcaceit posted but all other instruction was a failure.

    Hope pcaceit's instruction can solve my problem. But if it doesn't, I'll try to bring this back to the store where I bought it.
  18. rlsaplan

    rlsaplan TS Rookie

    still have the problem

    I've tried to install the XPSecurity but still have the problem.

    I also notice something that I can only copy a file/s that consists of 8.6MB but in exceed to this file size with trigger the Write Protect Error.

    I think I should bring this back.
  19. computer novice

    computer novice TS Rookie

    USBDISK/MP3/WMA MD130-overcoming 'write protection'

    I was lead to this site in search for myself to be able to remove previously downloaded files, in my case, windows media player files. Anyway, I found a way to remove my files from my mp3 player to make room for new files I wish to put on. My computer is XPwindows software. OK, what I did was
    1)Start menu--my computer
    2)locate device, eg.Rmovable Disk(F:), and right click mouse
    3)look for 'Open as Portable media device
    4)Double click icon(should be only one)
    5)Now proceed to remove old files, this time it will allow after the first time it says are you sure you want to remove file, click yes.

    Hope this helps some of you :)
  20. chesspdh

    chesspdh TS Rookie

    Flash Drive Write Protected

    I had the problem this morning. Couple week old flash drive that was used once with no problem, was now saying write protected no matter what I do? Plugged in my external {also USB} cd drive to see if the flash drive documentation said anything about this. It didn't. However, my computer now reads the cd as drive D:\ and the flash drive as drive F:\ and is not reporting write protected. Performing as expected. Check your drive letter assignments.

    WinXP Home Service Pack 2
    OmniTech 933mhz Pentium III
  21. jen182

    jen182 TS Rookie Do You Remove Write Protection Off Of Mp3 Player....

    I'm only 13 and i need your help:D

    Well i just ripped some songs off my new taking back sunday album and they went into folder 'My music' i moved them to my folders where i keep my music and now im trying to copy and paste them onto my mp3 player file but its keeps coming up with a "warning" saying 'THE DISK IS PROTECTED. REMOVE THE WROTE-PROTECTION OR USE ANOTHER DISK'


    my brother wouldnt tell me how to take the write protection off since we had a fight =( please help me people
  22. Ken

    Ken TS Rookie

    Flash Drive Write Protection Issue

    Had the same problems myself with a Kingmax USB 2.0 512MB drive on WinXP sp2. Found that if you boot in Safe Mode and do a reformat of the drive from there it works. You lose all the data on the drive, but hey, at least you get your drive back...
  23. matty-salmash

    matty-salmash TS Rookie

    call me a noob

    call me a big fat noob but how i boot in safe mode? :S
  24. Tessa

    Tessa TS Rookie

    Kingmax USB2 drive (remove write protect)

    On the Kingmax USB2 drive, the little slider on the edge operates the write protect function. First push the slider right to the end, by pusing with your thumb on the black moving part you push with (on the flat surface). Keep your thumb there, and then move the little lever on the side - it is now on the far left. You will find that it will move a little bit. One position is write-protect and the other position is not write-protect.
  25. mscientist33

    mscientist33 TS Rookie

    I have had trouble with my usb drive saying it was write protected, just like everyone else. I finally made some progress. This is what I did to fix it. I went to 'start', 'run' typed 'cmd'. at the command prompt, i typed format f: (the letter of my drive) /x ... IT Worked, I have my usb drive back!!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...