1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice


By Roseburg
Aug 27, 2006
  1. I just purchased a self powered 4 Port USB hub for my computer. I also purchased a 4 Port USB hub that is not self powered.

    I can plug both hubs into my computer and find the hubs as Generic USB Hubs in my Hardware Device Manager. If I look at the properties of both, they say that the device is working properly and I can see that there are 4 ports available for each one. So, I am assuming the USB ports on my computer are working properly.

    However, I cannot get the computer to recognize anything I plug into either one of the Hubs...if I plug something in and look in the device manager, it still shows that I have 4 ports available.

    The only exception to this is if I plug the non-self powered hub into the self powered hub. When i do that, i get a light on the hub acknowledging that there is a device in that Port and my device manager shows that there is a 4 port hub using one of the ports on my self powered hub and that 3 ports are now available.

    Thus, the only device my computer will recognize plugged into the hubs is another hub.

    Having seen that, I tried plugging a device into the non-powered hub while it was plugged into the powered one, but no luck, the computer did not recognize anything then either.

    Items I have plugged into the hubs are a set of speakers, a wireless network receiver and a wirelsss keyboard and mouse receiver. I have sense plugged the wireless desktop directly into a USB port on the computer and it is working fine, so again, I think my USB ports are working ok.

    My computer is an E Machines T3418 with 512 of Ram.

    Is this just a case of two non-working hubs, or is there another issue I have to solve?

  2. Darth_Terra1

    Darth_Terra1 TS Rookie Posts: 212

    I don't know what your trying to do , hubs are for networks you use them to connect 3 or more PC's and or other hubs routers etc together not for plugging in your speakers and or wireless adapters.
  3. Roseburg

    Roseburg TS Rookie Topic Starter

    LOL..No not A network type of hub. This is a USB Hub...you plug this into a USB port on your computer and you get three additional USB ports to be able to plug devices into (the 4 ports on the hub less the one on the computer you have to plug the hub into).

    Since I posted that and got zippo responses, I have since went and bought a different brand of hub. Took it home and got the exact same result. The only device it would read were the two other hubs I already had.

    So, I started thinking a bit and tried something different. I plugged in an external DVD recorder and low and behold it read it.

    I then figured out that my wireless network receiver had a loose connection onthe device end. When I pushed that in farther the hub could read it too.

    Thanks for the post though.

    The only thing that does not show up on the device manager still are the speakers. Not sure why, they do not cause the device manager to show that a port on the hub is being used. Maybe because they are only drawing power from it.

    However, I think this was a case of using the wrong test devices and one that was not plugged in correctly.

    In addition, I plugged my original self-powered hub back in and it too works, so will take back the second one I purchased as a replacement.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...