1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB intermittant failures

By Archeron ยท 8 replies
Aug 22, 2003
  1. Hey,

    I've just bought a new system and it's been running for about 10 days with a few hiccoughs here and there.
    Over the past 4 days however, my usb mouse has begun to fail intermittantly. It will stop and start continuously.

    My specs:
    AMD Athlon 2700XP
    Asus A7V8X-X mobo
    Nvidia Geforce 4 AGP 8x
    Windows 2000 professional
    usb devices:
    microsoft intellipoint usb/ps2 mouse
    logitech ps2/usb 105 keyboard se
    alcatel usb adsl modem
    1x 512 ddr ram

    I've updated the drivers for the usb host and ports, i've updated to the latest usb mouse drivers, windows is fully updated, including all crticical/non-critical patches.

    I haven't updated the bios from when I first got it.

    Occasionally the mouse stops working and the "found new hardware" wizard appears to tell me that I have a new USB Human Interface Device (which turns out to be the mouse)

    I've tried the mouse on all 4 usb ports and I keep having problems.
    I've tried using the keyboard and mouse as ps2 but the keyboard stops working if I try that. (after a reboot)
    I did try this morning to play around with the mouse while the usb modem was unplugged and there didn't seem to be a problem (but I'm not sure if there is or not)

    I can't understand why the mouse stops working if there is only the mouse and modem using the usb ports.

    oh and the psu is 350w.

    Does anyone have any ideas?
    my ancient laptop can run the modem and mouse at the same time with no problems...

    Any help appreciated,
  2. vassil3427

    vassil3427 TS Rookie Posts: 640

    It's possible Windows 2000 is causing it, perhaps you ought to get XP....
  3. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    I no longer wonder how MS sells so many OSes.;)

    Go to the device manager, double click on your mouse & see if you have a "Power Management" tab.

    On certain USB devices, by default, there's an option called "Allow computer to shutdown this device to save power".

    Untick that option & see if you still have the problem.

    BTW what version of the 4 in 1 drivers are you using ?
  4. Archeron

    Archeron TS Rookie Topic Starter

    4 in 1

    Hi, Thanks for the quick replies.
    No I hate XP, so that's not an option. Besides 2000 should work on it.

    I've checked the device manager. The option is greyed out. I've made sure none of the usb hubs/ports can be turned off to save power.

    4 in 1 drivers?
    I ... haven't installed any.
    I installed the usb drivers from the asus website.

    The root hub version is 5.0.2195.6717
    The rest of the usb driver versions are the same.

    Thanks again,

    Oh: The problem still occurs. It just completely dropped all of my usb devices as well (they all stopped functioning)

    I've updated to the latest bios revision 1006 and still no joy.

    Could it be a usb failure on the actual m/board?
    I've had it working before... even if only for a few days.
  5. iss

    iss TechSpot Chancellor Posts: 1,994

    that is a via chipset try installing the latest 4 in 1 drivers as Didou suggested ( hyperion) and see if that solves the problem. these are the motherboard drivers that are needed for proper functioning.

  6. Archeron

    Archeron TS Rookie Topic Starter


    Sorry it takes me so long to reply. I only get a few minutes here and there to test out these ideas.

    I've installed the Via 4 in 1 drivers (latest version from that website) and the mouse is behaving a lot better.
    It does stop for about a half second and then find itself again and carry on working, but that's nothing compared to how it used to be.

    Although it's still not 100%...

    Thanks for all the help so far. Does anyone have any other ideas to try?
    As this was the first AMD i've built i'm a little disheartened by all of this...

    Guess you have to learn somehow..
  7. iss

    iss TechSpot Chancellor Posts: 1,994

    if the board has USB 2.o support did you install the usb 2.0 drivers?
  8. Archeron

    Archeron TS Rookie Topic Starter

    *shamelessly hangs his head*
    I've installed all of the correct drivers and the system is fine.
    I've just moved the mouse to another PC where I know it has always worked and I think it's got and had an 18 month lifespan.
    I've ordered a new mouse because I think this one is on it's way out.

    Sorry to have caused all the trouble! I'll check the obvious next time.
    I'll post back in a couple of days when my new mouse has arrived and let everyone know if that solved the problem.

    If it does, it's a strange coincidence for my mouse to start failing as I buy a new PC.... maybe it got jealous...
  9. Archeron

    Archeron TS Rookie Topic Starter


    It appears that the mouse was faulty. But I never knew that one faulty usb device could knock out the entire hub...

    If i plug the old mouse in, eventually it kills power to the rest of the usb hub. The new mouse just works like it's meant to with no problems whatsoever.

    I just wanted to do a final update to let you all know the problem was solved and to thank everyone again for the suggestions!
    At least I have up to date everything now!

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...