USB Mass Storage Device not working properly

By X DarthMonkey X · 16 replies
Jan 31, 2006
  1. Okay, here's the deal:

    I have the following USB Mass Storage Devices, and none of them are working.

    ~SanDisk 6-in-1 Memory Card reader
    ~Memorex 512m flash drive
    ~Nikon 5700 Digital Camera
    ~Samsung Yepp T7z Music Player

    I also have the following USB Devices that ARE working, which are not classified as Mass Storage Devices:

    ~Targus Wireless Laser Mouse (Descriptive, huh?)
    ~Sony Clié PEG-TJ25 (Palm OS 5.2)
    ~External HDD (Samsung 40G mounted on an external HDD kit, not detected or classified as Mass Storage, but as a physical hard drive)

    These devices are installed on Windows XP Professional SP2. All Windows updates are installed. They worked properly until I bought a new mobo and CPU. (Ran repair from boot CD after installing them, just to be safe)

    I'm probably forgetting some non-Mass Storage devices, but that doesn't matter. The point is that my Mass Storage devices don't work. They all work fine on another computer running the same OS.

    I can go to the Device Manager and I can see them, it says they're working properly (It always says that, whether something is actually working or not)

    So, here's where it gets wierd: I can go into Disk Management and I can SEE the devices plugged in, and there's no drive letter assigned. Okay, easy enough, just assign a drive letter. (In this case it's F, as it's not in use by anything else) So I go into My Computer, it still ain't there. Also, when I reboot the computer or remove and replace the device, it will no longer have a drive letter, I have to assign it all over again.

    I go back to the Disk Management and right-click on the Mass Storage drive and hit 'open'.

    Bingo, it opens. (Halellujah) I can see all the files, and I can change them, open them, etc... But I still can't get to it in any other way. I type f:\ in Windows Explorer, but it says there is no such drive. Stupid Windows...

    Anyway, even if I can get at the files, it's still very inconvenient. I'd much appreciate some help here, if anyone's got any ideas.

    Here's most of the stuff I've tried to do to fix it, but didn't work:

    ~Uninstall USB Drivers, then reinstall
    ~Delete all USB VID_ entries in the Registry (They reinstall on startup, and this supposedly fixes problems with Mass Storage devices according to Microsoft... no dice)
    ~Repair from Boot CD
    ~Uninstall/Reinstall device drivers (It never works, but it's always worth a shot)
    ~Unplug computer for an hour (I was desperate, and someone said it would work.)
    ~Try different USB ports
    ~Smack it :knock:
    ~Smack it again :unch:
    ~Leave it alone for a day, then try again later (It's worked for me before!)
    ~A really long and pointless list of commands in cmd that Microsoft said should fix it.

    Also tried most of the things at the following site:

    There are loads of suggestions on that page, but you can't see them with the link because they want you to register (If you're registered there, good for you!). To see it, do a Google for "Hardware: XP Pro will not recognize USB mass storage devices" and click the top result (rofl, getting through a site's security with Google search results)

    None of them worked, I tried all of them except for actually buying a new USB card. Oh, and someone said it's possibly 'Line Noise" on the USB cable, that long USB cables will sometimes have that. Well, I'm using a 3/4 inch USB adapter instead of a cable (the adapter is supplied with my MP3 Player!) So that isn't my problem.

    So, please give me any suggestions! Or if you've had a similar problem, then tell me what you did to fix it! (I'm not willing to do a fresh install, but if that worked for you then tell me at least)
  2. X DarthMonkey X

    X DarthMonkey X TS Rookie Topic Starter Posts: 76

    Oh, and I just noticed something: When I try to put a file on it that is more than 12 characters long (Including extension) it will tell you that "The destination soes not support long file names"

    And I can't include spaces... this is just stupid.

    Ya, now THAT is going to annoy the puke: out of me. HELP ME!
  3. Peddant

    Peddant TS Rookie Posts: 1,446

    I haven`t a clue what the solution to your problem is,but I must congratulate on providing such an entertaining and informative post.An excellent troubleshooting guide for the future. :)
  4. X DarthMonkey X

    X DarthMonkey X TS Rookie Topic Starter Posts: 76

    Entertaining? Do you think my problem is funny? lol
  5. Peddant

    Peddant TS Rookie Posts: 1,446

    The description was entertaining not the problem. lol I`m still trying to google the solution.
  6. X DarthMonkey X

    X DarthMonkey X TS Rookie Topic Starter Posts: 76

    Ah, well I'm glad my post was entertaining... i think. Anyway, please continue with your googling. Even if I wasn't able to turn anything up, maybe you can! Don't let me down!
  7. N3051M

    N3051M TS Evangelist Posts: 2,115

    just to clarify waht do you mean by 3/4 usb adaptor?.. um.. have you tried (most likely)..
    checking what format the drives are (fat, raw, fat32 etc), check for bios setings relating to usb, using direct to onboard usb ports instead of through hub, taking out every other usb connected currently and see if it works and if it does plug in one by one to see if there's any conflict.. wiggle it abit and hold it steady :)..

    btw it is normal for teh external hdd to be recodnised as a hdd because it doesnt use a flash chip to store stuff
  8. X DarthMonkey X

    X DarthMonkey X TS Rookie Topic Starter Posts: 76

    I mean: The connector from my MP3 player to my PC is 3/4 of an inch long, no way it could get line noise. And yes, I also tried different cables. (Before you ask)

    It's fat32.

    Checked everything in BIOS, and installed fresh copy of Windows on my secondary HDD (After moving all of its content onto my primary of course) And set up a dual-boot system. So, that's my temporary fix until I can find out how to fix it on my primary boot.

    So, I know it''s got something to do with Windows. Still need help

    Edit: And I removed all other USB Devices (Excluding my mouse) Still didn't work. And I know that most external HDDs are not supposed to be recognized as Mass Storage.
  9. N3051M

    N3051M TS Evangelist Posts: 2,115

    hmm.. if it is something to do with windows i can only think of either registry or driver conflicts..... i might probably be repeating things but try getting rid off
    generic usb hub
    usb composite device
    usb mass storage device
    usb root hub

    or maybe try export that whole directory in registry with usb related stuff and then load it into the problem xp..
  10. X DarthMonkey X

    X DarthMonkey X TS Rookie Topic Starter Posts: 76

    Tried all that already... :blackeye:

    But keep it up with the suggestions! :grinthumb
  11. N3051M

    N3051M TS Evangelist Posts: 2,115

    tough cookie. :unch: :blackeye:

    ok. you say it works with your other winxp on the same machine. that means that it would do with:
    1. a program that is using/uses/or needs the usb ports to run eg: camera prog that can read the imgs off your directly without a card reader..
    2. a service is hanging or stopping it from detecting/reading..
    3. differences in the setup with both windwos.. take note on hardware configs, programs installed, registry etc on both boots
    4. won't know if this is will help but just in case full system scan your comp for the usual 3.. spy/ad/malware etc

    programs to get that might help you would be
    process explorer- like task manager expt more detail and control
    everrest- displays system hardware/software configs/info
    adaware.. spybot.. avg.. ker-something i forgot the name..

    thats all i can think of this present moment.. starting to run out of ideas so i'll open up the floor this time while i try to find out more..

  12. mr-internet

    mr-internet TS Rookie

    FIXED Windows has problem with USB2 mass storage device or

    Had this problem for ages and no fixes anywhere.

    Had this problem and it was driving me nuts

    Turns out it is a known issue with windows xp with no SP, SP1, and SP2 perhaps with windows media editon also.

    If you google KB90863 you get the MS url below

    You then phone MS (free) and get the hotfix (free also) you need a password

    They then send you the hot fix (notice it is SP3)

    This is how MS track how bad a problem is so please try it.

    It then allowed my system to see USB2 devices.
    I believe it happened from not being able to disconnect USB drives and just unplugging them. This created a list of over 100 mass storage devices being hidden in the devices

    Hope it helps.

    Regards Mr-internet

    If it worked let me know
  13. bbadfox77

    bbadfox77 TS Rookie


    i have a similar problem my comp had a meltdown lighting messed it up i had to hit the r button to repair problem it did i have windows back but my usbs are gone i hook up to the internet through my usb printers etc.. nothing works. in my device manager its says no drivers are installed and its not signed ? when i use my e machinr restore my comp goes on fritz no xp again i have windows xp disk which brings xp back again but my usb dont work any 1 that can help any advice would be appreciated
  14. X DarthMonkey X

    X DarthMonkey X TS Rookie Topic Starter Posts: 76

    I wound up reformatting. Nothing else worked, even a detailed step-by-step registry modification recommendation that I got from Microsoft.

    So I recommend backing everything up and reformatting.
  15. Rick

    Rick TechSpot Staff Posts: 4,572   +65

  16. X DarthMonkey X

    X DarthMonkey X TS Rookie Topic Starter Posts: 76

    That didn't help me.
  17. spanky48

    spanky48 TS Rookie

    I just had the same problem with two different mass storage devices (thumb drives).

    What I discovered was that I had other drives assigned to Drives E and F, and so the devices couldn't be read.

    When I moved those drives occupying E and F tyo Y and Z (for example), my devices worked.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...