USB mass storage device that doesn't install completely?

By SanpaMelu
Jun 13, 2005
  1. Flash Disk message "USB mass storage device that doesn't install completely"

    I have a MicroX StormBlue USD-3551 with 1GB that suddenly stopped working.

    The symptom is a bit strange.

    In some computers the USB Flash Disk doesn’t install completely saying that is an error in the installation. Nevertheless a Removable Disk appears in My Computer.

    In other computers there isn't any installation error, and a Removable Disk is installed in My Computer.

    In both cases the Removable Disk installed when accessed in the explorer drops a window saying "Please insert a disk into drive F:".

    I already tried to format the flash disk in several ways but the drive is always recognized with 0 MB.

    I also tried to use the stormblue available software, but the usb flash disk is not recognized by all the software I've used.

    The cause of this is not of my knowledge, but I suspect that my flash disk was removed without dismounting it first, but I'm not sure.....

    Thus anyone have a clue to resolve this?


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...