Build a PC Usb mass storage device

Not open for further replies.
Im having a problem with my usb mass storage device. I have a external io magic dvd 4x dual drive burner. I install the drivers restart my computer it detects the usb storage for when the computer boots till windows is loaded up and then i get the the yellow sign in the device manager. I havent changed or added any software. It has worked for the last 5 months till this last week. Anyone have any ideas?


Posts: 5,452   +7
What does the yellow sign say?

You could try uninstalling all USB related drivers and let Windows reinstall them from scratch.
Similar problem with newly acquired External DVD-Burner

I've only just acquired my external dvd burner this week and have yet to see my financial outlay come to fruition! I bought a LG GSA-4163B in an external casing and it is connected via a USB2.0 port on my laptop. (ASUS A2500D) The driver disk i was given only had 98/2000/ME drivers, and from what I can tell my XP Pro utilises thge SP2 upgrade to detect all Mass Storage Devices/USB Drivers? Windows detects the drive when I turn it on, but says it failed to install properly and 'The device cannot start' in my Hardware Devices (code 10).

Could this potentially be faulty casing/burner or just isolated to the power supply in any way?

Any help would be appreciated as i'm not too familiar with solving problems with laptop peripherals.
  • Thread Starter Thread Starter
  • #4
Have you tried to hook any other usb devices to the port you have the burner hooked up to? Have you tried any other usb ports on your laptop? Do have another computer in the house or a friends to hook up the burner to see if it works.


Posts: 64   +0
Before you go off and do anything rash, let me tell you to make sure the power cord is plugged in nice and tight.

That was the problem with my external hard drive enclosure. I got the same message about a USB Mass Storage Device failing to install.

Turns out I just didn't have the power cord tight enough. I'm talking about the cord from the wall socket to the adapter.

Wall socket -> cord -> adapter -> USB device.

Make sure the cord -> adapter connection is tight. You have to really push it in.
Ok, thanks for the help everybody. Exhausted all possible solutions and still didn't work, so I took the burner to my IT department where I work and they tested it and found it had a faulty power supply. *sigh*

Thanks again for the help.
Not open for further replies.