USB Mass Storage Problem

By donald1225 ยท 5 replies
Nov 29, 2005
  1. My problem is that when I plug in any type of USB mass storage device - digital camera or thumbdrive I never get the message "finding new hardware". But I can see the device fine. I can open the drive, retrieve or store files, etc., etc. However I cannot unplug the device. Whether or not I use "Safely Remove Hardware." Whenever I attemp this will get a fatal (blue screen) error and have to restart the system. I have tried reloading the USB drivers. All other USB devices (mouse, keyboards, Logitech camera,etc.) work fine. Any help is most appreciated.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    Not seeing the new hardware message is normal - it only happens when Windows sees a device the first time.

    Posting the contents of the blue screen and/or the minidumps would help. Also, the exact specs of your system - OS, hardware, devices used would help.
  3. donald1225

    donald1225 TS Rookie Topic Starter

    Blue Screen Error

    Thanks Nodsu, but this use to work without any problems. I cannot figure what changed on my system to cause this. I did add 512 MB to the 256 MB that came with the system of RAM and upgraded my BIOS (Compaq recommendation for my system) but I think it worked afterwards, however I am not sure.

    At one point and time I ran a registry cleanup program and I feel this is when the problem occurred. However it was beyond the point of restoring to an earlier time.

    The Blue Screen Error is: IRQL_NOT_LESS_OR_EQUAL with the Technical Information Line of:
    STOP: 0x0000000A (0x0000000D, 0x0000000Z, 0x00000001, 0x806FFAZA)
    I am running Windows XP Home Edition Service Pack 2.

    Since it will see my Mass Storage Device, let me access it (I can both store on and retrieve from). Everything works the way it should until I try to disconnect the device, I cannot pinpoint what might have changed to cause this problem. I have tried all of my USB ports with the same results.

    Let me know if there is any additional information I can supply. And many, many thanks.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    How did you reload the USB drivers? Are the motherboard drivers the latest for your system?
  5. donald1225

    donald1225 TS Rookie Topic Starter

    Nodsu - I went into the My Computer - Hardware - Device Manager and deleted the drivers. Then I rebooted the system and let it find the devices again.

    In case I forgot I want to thank you for your assistance.
  6. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    wth are you thanking for? I have been of no use :p

    Did you remove all usb devices? Can you download and install newer chipset drivers than the ones Windows installs?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...