USB MP3 player cheap, not working

By Vigilante ยท 4 replies
Jun 22, 2005
  1. Hey, I got an MP3 player for free from some web site when I made an order. It is a Sakar 39379 Digital MP3/FM Player. Looks silver with a "x" sort of chrome on the front.

    It came with a CD and poorly translated manual. But anyway, I run the CD, it installs the software and wants to restart. So I did that.

    Then I had some trouble getting it to not error on me saying unknown device or unrecognized device and so on. It now works in that regard.

    It creates the TWO new drive letters which I can SEE in My Computer.

    F: is titled "multimedia"
    G: is labeled "Flash Disk" and even has a fancy icon for it.

    However neither works. Note that it has 2 letters because it has a built-in 16mb flash and also an SD slot, which I have another 16mb in there.

    I can double-click the icons and it goes in, but there are no files or anything. If I right-click and try to create a file, ANY type of file into either of those drives, it pops up an error saying this:
    [title] "Unable to create file"
    [yellow exclamation icon] "Unable to create the file "New Rich Text Document.rtf"
    "The system cannot find the file specified"
    [OK button only]

    OR if I try to drag and drop a file into one of those drives it pops up an error like this:
    [title] "Error Copying File or Folder"
    [Has red X icon] "Cannot copy FILENAME: Cannot find the specified file."
    "Make sure you specify the correct path and file name."

    So obviously there is a problem, Windows can see the drives and gives them letters but can't do any file operations on them?!

    Let's say I go to command prompt and try to browse into one, nope, says this:
    "The system cannot find the path specified."

    So the question is, why does My Computer recognize the two drives, give them letters, but not be able to do anything with them?

    Here are some facts though:

    - Disk management shows NO sign of these drives. They do not appear in any form here.

    - If I go into the properties of either drive, they are listed as this:
    "ICSI MP3 PlayerMMC/SD USB Device [type=Disk Drives]"
    "ICSI MP3 Player Flash USB Device [type=Disk Drives]"

    - If I delve further into the properties, I see that Device Manager sees them and says they are "working properly" with no errors.

    - It uses drivers by Microsoft (so I'm not sure what the CD install did, if anything)

    - The two driver files it uses are "disk.sys" and "PartMgr.sys"

    - The properties show that the volumes are named "Disk 2" and "Disk 3". Status is "unreadable". Partitionstyle is "Not Applicable". And Capacity is "0mb".

    What it really sounds like is that the disks are not partitioned or formatted. That doesn't make sense cause I use the SD card in my camera, and the built-in flash should be prepared already. I've also tried using the device without the SD card in it.
    But if it was just a regular, unpartitioned disk, then it would show up in Disk Management and I'd be able to do something about it.

    Well this was a really long explanation, but hopefully all the info you may want is within.

    To sum up, I see the drive letters, but can't do jack with them.

    Thanks for your suggestions.
  2. kris_h

    kris_h TS Rookie

    Does your player have a hold button/switch or similar on it? It it does, make sure hold is switched off. My mp3 player will let you read OK, but will not write when hold os on. Remove the USB cable, switch hold off, switch the player off, and then plug into computer again. Don't know if this will help, but you can give it try.
    Some disk managers may not recognise or be able to use USB/Flash drives, (outdated perhaps?).
    One last thing: Check in device manager for any conflicts, especially with USB ports etc.
  3. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666


    The device does have a hold switch. Though I remember switching it. But will try again tonight.
    There are no conflicts, at least, if there is XP isn't telling me.

    It's XP Pro SP2 up to date.

    Whether hold is on or not, when I go into the SDcard drive letter, it is empty. However you say you are able to "read" but not write. I'm positive the SD card has data on it, but I can't see that either.
  4. trout_face

    trout_face TS Rookie

    Very stupid demand

    Ok i got a big problem. all my mp3 players got screwed up and are broken and i only have the icis mp3... but i accedently deleted the system data that u listed above (drivers)
    i was wondering could u send them to me or post them or else i wont be able to listen to music ever AGAINNNNNNNNNNNNNNNNNNNNNNNNNNNNNNNN!!!!!!!!!!!!!!
  5. TheTracker

    TheTracker TS Rookie

    Got your fix here

    Hey,i had the same problem with the39379 digital MP3/FM Player to.what i did was this.Went to were you see the FLASH H DRIVE that you mentioned.Andright click that and format it even it says it will earase the info.YOU WANT IT TO EARSES ALL OF IT.It some useless mumbo jumbo that does nothing.Perhaps they forgot to format themselves i dont know but format and the scan disk it like you would your hard drive just make sure it is selected to scan the flash h drive.I tried just to delete like you did but it kept saying that is was in use or something to that nature.Just right click the icon flask h and you will see format format it full with no label.It worked for, but i have to completly agree this is a big CHEAP!!!Piece of junk.Oh ya and by the way when you format it and all the space is restored in the 16 mb flash memory just drag and drop you mp3 right over the icon you just formatted.K.Good luck.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...