USB port cannot install?!?!?

By amandalulu
Jul 22, 2005
  1. PLEASE help me!!!
    My USB port on my pc has not worked for a long time now..i dont know what went wrong..anyways i went to microsoft support website, uninstalled the USB ports as directed, restarted my computer and the 'new hardware found' bubbles poped up.
    Life was grand until i tryed to intall the USB ports and they could not be intalled : "Cannot install this hardware, this data is invalid" "An error occured during the instalation of this device"
    So, my question is what do I do now, is there a problem with my computers set up, the BIOS config. or is it just the USB ports physical connection onto the motherboard?
  2. Ric_123

    Ric_123 TS Rookie

    same happened to me

    that happened to me too but my back ones work and my front ones dont
  3. Ric_123

    Ric_123 TS Rookie


    but i didnt do any thing i just use the back one now and bought a usb adapta
  4. techsplotchjb

    techsplotchjb TS Rookie

    I've been having this problem for a while now, but by looking through some google groups post I've been able to find the recovery! So I'm spreading the good word!

    When I attach one of the problematic devices, the Found New Hardware wizard
    starts up, but ultimately returns the errors:

    "Cannot Install This Hardware

    There was a problem installing this hardware:

    [device name here]

    an error occured in the installation of the device

    The data is invalid."

    In place of "[device name here]" as described above, my screen would say "USB 2.0 FD".

    I recieve this message whenever I try to attach
    - Sony DSC (some Sony digital camera, I don't remember the model)
    - Creative Zen Vision:M
    - PNY Attache USB 2.0 2 GB thumb drive

    When I wrote this post, I only had the PNY, but the fix below worked. I'm pretty sure the same procedure will fix the problem with my other devices.

    1. Start > Run > regedit
    2. Dig to the folder ...
    Next, you may see a series of folders named Vid_XXXX&Pid_XXXX.
    3. Flip through each Vid_ folder, looking at Name "LocationInformation" for the value "USB 2.0 FD", or whatever you had in your Error message.
    4. To make sure you find the correct folder, go to Device Manager (How? Right-click "My Computer" > Properties > Hardware tab > Device Manager button). When inside Device Manager, look for a yellow icon with a question mark, possibly labeled "USB 2.0". Double-click the icon which will open the Properties window, click on Details tab. The default selection will be "Device Instance Id", and the value of that should be in the text box below. This value should look something like "USB\VID_154c&pid_0009\". This should match the name of the folder from step 3.
    5. Right-click the Vid_ folder > Permissions > Permissions for Everyone > check Allow for Full Control
    6. Exit. Best of all, you don't have to reboot!

    Here is where I was able to get this information
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...