USB storage devices inaccessible!

Not open for further replies.
Alright, so here's my problem:
My Dell Inspiron E1505 laptop hasn't had any problems in the past as far as USB storage is concerned. But recently it's developed problems being able to read these devices. It's only storage devices like flash drives and my external HD - my mp3 player and my cell phone can still hook up to it without problems. Also, new "Local Disks" are showing up.. There's my original "C:" HD, my backup "D:" HD that came with the laptop, and now there's also a "F:" and "G:" that show up- I looked on PC Inspector to see what they were and it appeared they are Dell setup partitions called "DellUtility" and "DellRestore".

Anyways, when I plug in a USB storage device, it doesn't bring up the "what do you want me to do with this thing?" autoplay that XP normally does when you put something into it. When I go to My Computer and click on the removable drives ( usually H: or I: ), it says "The disk in drive _ is not formatted. Do you want to format it now?" and I have tried formatting it since I don't have any valuable information on my flash drive but it still doesn't fix the problem.

I've tried looking up myself how to fix this problem but I'm only finding bits and pieces of information on similar problems but nothing has helped. I'm hoping someone here has an idea of what I might do because now I can't use flash media for movement of data on and off my computer and I really miss all the extra storage space my laptop HD isn't very big :(

  • Thread Starter Thread Starter
  • #3
Well I have PC Inspector on my computer and that works to get files OFF of the devices onto my computer.. but I have no way to get stuff ONTO them from my computer :/ I'm going to try out Datacatch Librarian Standard Edition but I'm not sure whether it'll do what I want it to..
Hello. I formatted my USB flash drive in win xp and now eahc time I connect it raises a warning: "The USB device can run faster if you connect it to a usb concentrer". Before format this message don't appear. The USB anyway works in win XP but doesn't work in Linux, an before the format it does.
My usb is a GeeDom 512 Mb. Somebody knows how to solve this problem or who is the frabricant? I need mi USB because I pass data beetween PC's with Linux and Windows.
Not open for further replies.