USB storage devices showing up in 'Drive Management' but not in 'My Computer

By peanutismint ยท 4 replies
May 8, 2006
  1. I've been trying to post a message on this board for about 40 minutes now :D, and I keep going around in circles. When I first hit 'post' I got this message:

    Then, when i clicked refresh, i got this message:

    The board seems to think my message got posted first time but i can't see it anywhere. This is my first post, therefore :D. Shall I keep trying or shall i just post my original message in this thread?!
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    The fact that I`m replying to you, means you`ve obviously managed to post.

    Yes you should post your original message into this thread. I can always edit the thread title for you, to reflect your question/topic.

    Regards Howard :wave: :wave:
  3. peanutismint

    peanutismint TS Rookie Topic Starter

    hahah thanks! Right, here it is in all its former glory:
    TITLE: "USB storage devices showing up in 'Drive Management' but not in 'My Computer'"

    MESSAGE: "Ok, let me begin by saying I don't know if this is in the correct forum as I don't really know where the problem lies, but I imagine it'd be with Windows. I'm running XP Pro btw.

    SO, for the past few weeks, whenever I've connected any form of data storage device to my computer (via USB, usually USB2 to be more precise), it has failed to show up in 'My Computer' as an external drive or 'mass storage device' with its own drive letter like it used to do. I'm talking about stuff like compact flash cards in an external USB card reader, my HiMD minidisc unit and a memory stick in my PSP, all of which used to pop up in My Computer when connected. When I plug them in, the little 'found new hardware' icon pops up in systray for a few seconds, as does the 'safely remove hardware' icon, which lists the hardware connected. If i then check in 'Disk Management', the drives usually show up, but I can't access them unless I assign them a drive letter, and it won't let me assign a drive letter without rebooting. After a reboot, whatever I had connected still doesn't show up in My Computer, but i can then usually access it through Disk Management, right-clicking on the drive and then clicking 'open'.

    The problem compounds in that, if anything that's not 'Disk Management' wants to access my external peripherals, such as my PSP media program or my minidisc media program, they can't see the drive as it's not recognised in 'My Computer'. I've tried reinstalling drivers for the individual devices, uninstalling all my USB controllers from device manager and rebooting to let them reinstall, i've tried all 4 usb2 ports on my computer, with and without my hub, all to no avail.

    Does anyone have any idea why my computer might have stopped automatically displaying/assigning drive letters to external things as they're connected? To re-emphasize, this is only a recent problem, it all used to work fine a few months ago, and I can't recall doing anything that might have made this happen. Virus scans and spy/ad/malware checks all check out.

    I've made a little picture to further emphasize/explain my problem:
    (Click to enlarge)"
  4. kirock

    kirock TS Rookie Posts: 1,221

    Have you run SFC /scannow? This will replace any missing Windows system files. Need install disc most likely if it finds missing dlls.

    Also check that these services are running Logical Disk Manager, Plug and Play and Universal Plug and Play, Removable Storage, Shell Harware Detection.
    To open services: Start/Run: type services.msc.
  5. sweetyb

    sweetyb TS Rookie

    having same problem


    I have DELL Optiplex 620's all with the same problem. Originally, plugging in a flash drive would restart the computer, or depending on which options you have set, it will blue screen "0x00000035 NO_MORE_IRP_STACK_LOCATIONS". What fixed that was uninstalling the Symantec Ghost Client from the system.

    But now, when plugging in the USB flash drives, they will be recognized, as noted by the person above--it will install the hardware and will be seen in Disk Management and in "Save As" dialog boxes, but will not show up in "My Computer". EDIT: Also, plugging in the flash drive before logging in is the only way it will show up in "My Computer". I've tried uninstalling all the USB hubs and controllers; I've also updated the BIOS from A05 to A07; I've changed the USB controller settings in the BIOS from "ON" to "NO BOOT"; I tried changing the flash drive letter to other letters--none of these have worked.

    Is there anything else I can try?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...