1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB thumb drives don't read anymore

By leosoybean ยท 9 replies
Dec 27, 2006
  1. I'm experiencing a USB device problem. I have two USB thumb drives of different brands that used to work. Now, if I plug them in (either front-side or back-side ports), the computer tones/beeps to let me know that it recognizes them, but neither drives auto-open nor are accessible via My Computer. I know for sure that the drives work, as they can be opened, explored, and formatted on other computers.

    The device manager shows the Host Controllers and Root Hubs as working properly. I've looked for driver updates, uninstalled and reinstalled the drivers manually, uninstalled and allowed Windows to reinstall automatically on reboot, and I've tried disabling the 2.0 USB on BIOS and re-enabling it on reboot.

    The Disk Manager shows the USB thumb drives. I've tried reformating them there, but a prompt informs me that is not possible because "the partition or volume is not enabled". Assigning drive names seems to do no good, and I can't disk-check for error either.

    What bugs me is that the drives work on other computers. I would think it's a virus of some sort, though that is improbable as I did a full scan and clean a few days ago.

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    We really need the brand and model of the computer or motherboard.
    Setup error on your computer. You may have changed something accidentally while working elsewhere. If your USB ports work for printers, scanners, and other components, you need to do a reset somewhere. You have done everything correctly.
    If you haven't done this, go to your BIOS at startup, and see if there is something disabled... There will likely be something on one of the BIOS screens that must be enabled.
    Or go to the motherboard manufacturers web site, and scroll through the online manual for that motherboard.
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

  4. leosoybean

    leosoybean TS Rookie Topic Starter

    @ Tedster:

    I tried the thread, but I got stuck on formatting because it simply won't let me. I'm told I can't low-level format the drive because the "partition or volume is not enabled", and the computer won't let me activate any sort of partition. I believe my problem is different altogether, as the two drives (EasyDisk and Lexar) work on other computers.

    Essentially, I was able to pull out all relevant data on both drives, but it seems that my computer can't read USB mass storage devices properly anymore. I tried other flash drives and even digital camera memory sticks with a USB adapter. Looks like I'll just have to reformat somewhere down the line.
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You could try checking if the USB devices work properly in a Linux live-CD environment (such as Knoppix). That would at least rule out hardware problems.
  6. leosoybean

    leosoybean TS Rookie Topic Starter

    @ Mictlantecuhtli

    I'm assuming running on XP will be ok with Knoppix?
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

  8. leosoybean

    leosoybean TS Rookie Topic Starter

    Wow excellent! I read through the thread and found a solution; it was a registry thing. I appreciate all your help guys!
  9. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Tell us a bit more... what kind of registry thing and how, exactly, did you resolve it.
  10. leosoybean

    leosoybean TS Rookie Topic Starter


    I really can't say. I just read through the thread and the original poster seemed to have a similar problem. Luckily, he was computer savvy enough to solve the problem himself and posted up his solution.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...