USB trouble in XP, what's going on?

By iMan ยท 5 replies
Sep 10, 2007
  1. Recently I bought a Lexmark X5470 all-in-one printer, only problem is I cant connect it trough the USB.

    What happens is that, as soon as I connect the USB for the printer, XP search install and ask for drivers, so I install the drivers and suddenly it says that the printer havn't been installed correctly.

    And if the USB is in computer while rebooting, windows wont even start. The screen just go black .... untill i unplugg the USB. And when I do that XP starts as it should be. I've noticed one more thing too. My mouse suddenly stops working when my printer is connected, and when i unplugg the USB - once again ... mouse work.

    Now, I've installed the latest driver both for the mouse and also the printer, on lexmark website.

    I personally think that it's a conflict in XP, something to do with IRQ settings, but I'm not sure. I've formated the HDD. Used other USB slots - nothing. Tried to uninstall my printer drivers and reinstall them, and same with the mouse vice-vera. And there is also a yellow exclamation mark on 'USB Universall Serial Bus', which means the drivers arn't installed correctly.

    I'm thinking about buying a USB slots on PCIcard. But I don't want to spend something that could be fixed. So what do you think? What's wrong?

  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    it is unlikely to be IRQ related unless you have modified the settings in the BIOS. If you have, I recomnend you set it back to default.
    This is consistent with all USB ports being the same and a reinstall of the OS not changing anything.
    It is more likely to be the motherboard dying, but before going further you should try the printer and the USB cable on another machine.
  3. iss

    iss TechSpot Chancellor Posts: 1,994

    I agree it sounds like the USB host controller is going bad. one other possibility COULD be bad\flucuating rails on your PSU. download speedfan and check the rail voltages that they are in spec.
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    USB controllers seldom go bad... very seldom. But Lexmark installs are notorious. Most "all-in-one" printers from LexMark, Dell, Epson, Brother, and HP are trouble unless you get the costly ones at the high end.

    I would first download all the latest LexMark drivers. Then I would remove the reminants of the first LexMark Install. Following that, I would install the free RegClean, RegCleaner, or CCleaner and remove all pieces of the LexMark that remain in the registry. Reboot, and check for LexMark again.
    Then reinstall from the downloaded version, being very careful to not plug in the USB cable from the printer until all other aspects of the install are complete.
    Usually the power supply will have nothing to do with the printer. The more probable cause is inadequate memory, as all-in-one printers hog it up with some of the "free" software they install. Following that, I would suspect the video graphics card.
    Be sure you have the lastest BIOS installed, along with the most recent chipset, and all other drivers released since you bought the computer... and the printer.
  5. iss

    iss TechSpot Chancellor Posts: 1,994

    I agree that Lexmark printers are bad news. as far as USB controllers going bad being rare, I would say that is true with quality mobo's. but I have seen plenty of bad USB controllers on third tier mobo's.
  6. iMan

    iMan TS Rookie Topic Starter

    Allright, I wanted to solve the issiue without buying a new hardware. I've tested all the things you guys listed, even a few things more. It was no success.

    I checked the IRQ setting, and also tested to put standard in bios setting as one of you mentioned. Checked the cable, tried different ports.

    One thing I noticed was the printer would work perfectly with USB to PS/2. But as soon as i hooked up another USB cable plus the printer who already was hooked, the printer stopped to work suddenly. So I thought that there MUST be something to do with a conflict between those USB ports.

    Anyway to solve the problem, I just went to my local store and bought a PCI USB Card, it only costed 20$. And it worked like a charm. I didn't need the USB to PS/2 anymore. The printer could be hooked, as well other USB devices.

    I appreciate the help I got from you guys. Take care!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...