USB won't enable in Award BIOS

Not open for further replies.
My apologies if this has been dealt with before. I've spent days trying to get a Belkin F5U005 USB 2 Port USB card to work in conjunction with:

Windows 98se

Model : AMD-K6(tm) 3D processor
Speed : 351MHz
Performance Rating : PR351 (estimated)
Type : Standard

Bus(es) : ISA AGP PCI USB i2c/SMBus
MP Support : No
System BIOS : Award Software International, Inc. 4.51 PG
System : System Manufacturer Product Name
Mainboard : First International Computer, Inc. VA-503+

Chipset 1
Model : VIA Technologies Inc VT82C597/597AT/598MVP Apollo VP3/MVP3 System Controller
L2 External Cache : 1024kB Pipeline-Burst Write-Thru
Front Side Bus Speed : 1x 100MHz (100MHz data rate)
Total Memory : 64MB SDRAM
Memory Bus Speed : 1x 100MHz (100MHz data rate)

Windows froze on the first attempt to install. After a lot of online research I found that this was a clock mismatch problem and I got it to install after downloading a fix which was supposed to be unnecessary with 98se.

I took every reference I could find to USB out of Device Manager, took the card out manually, restarted, shut down, put the card back in, started up and it installed normally.

The USB OPTi 82C861 PCI to USB Open Host Controller and
USB Root Hub are now showing normal in Universal Serial Bus Controllers in the Device Manager. No yellow exclamation marks are anywhere in the Device Manager.

The Award Bios shows USB Controller Disabled in Integrated Peripherals and there is no other option - I expected to be able to toggle between enabled and disabled but it won't. Also disabled are various IDE options and one HDD, just above the reference to the USB.

I tried to get a BIOS update from Award and after initially telling me 'we have just the thing for you, boy are you going to be a happy bunny' (or something very similar) they wrote and said 'we've taken the money from your credit card but you already have the latest BIOS' - (or something even more similar).

Belkin refer me to everybody else except them.

Should I quit now while I'm ahead ? The floppy disk drive is still working, after all...


Posts: 13,970   +1,778
Normally, your USB BIOS would only be required to allow BOOTing a USB HD.

Your Belkin USB is not accessed at BOOT time, so stop fussing with BIOS.

If you have modem-->router setup, then the drivers are not required at all!

Use the Modem->Router using Ethernet cable and from the router->pcs as well.

Otherwise, modem-->pc(USB connected) requires a driver.

Does this clarify/help?
  • Thread Starter Thread Starter
  • #3
Ah - a light comes on dimly

That's how it all started. This is an oldish computer with dial-up. I recently signed up to btinernet and I'm trying to connect to the BT Homehub, which only wants to play via USB - the newish computer is linked to the Homehub Ethernet 1 socket and I guess it wants to keep Ethernet 2 for the much hyped TV connection.

So, I tried to install a USB card, and the rest you know. I've got an Ethernet card for the old PC but I've no great hopes for it working with the Homehub even if I get it running. Thanks for the advice.
Not open for further replies.