Spread the love! TechSpot Tech Gift Shortlist 2017

USB2 enclousre & Maxor 80GB IDE not working

By des1fool ยท 10 replies
Nov 5, 2006
  1. Hello all! I got a new USB2.0 3.5" HDD external box a while ago with a Maxor IDE 80GB everything was setup ready to go. Only recently I encountered some serious problems.

    I don't know what wrong but when I plug it in now I hear the bleep from the computer indicating that hardware has been inserted but no autoplay action that i've been getting for the longest time.

    Its not showing up on any of my computers. But I can hear it spinning and I doubt the harddrive is to fault, but it very well could be.

    Some other things that have happend when I try to defragment it is that it crashes the defrag application and even sometimes when i go into windows explorer it crashes that also!!

    If anybody could please help! I would prefer not to loose any data that is stored on the drive but if thats what it takes then its ok.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    How do you defragment it if it doesn't even show? :p

    Take out the hard drive and connect it to a computer directly. Run Maxtor diagnostics on it. Reformat the drive if it was OK.
  3. des1fool

    des1fool TS Rookie Topic Starter

    Well I meant to say when I have the harddrive inserted and I try to launch Defragmenter it gets frozen and when i say it doesnt show up it doesn't show up in Windows EXPLORER. And when I unplug it from the USB port It freezes up a lot of apps including Itunes 7.0.2 ( Which is already EXTREMELY buggy). And I cannot put it in my comp because both IDE cables are occupied and the main harddrive is SATA. I wold prefer not to refomat the drive because of all of the musis stored on there :p anybody please help!!

    My specs are -
    AMD Athalon 64 3700+
    1.50GB RAM
    Inno3D NVidia 7600GS 256MB AGP
    TV Tuner (From HP desktop hauppage something)
    Creative Sound Audigy 2Z ( Another from a HP desktop)
    160GB SATA
    Media Card Reader
  4. tipstir

    tipstir TS Ambassador Posts: 2,426   +112

    Try it this way...


    only plugin what you need for USB2 devices then connect the MAXTOR USB2. If it doesn't work, then remove all USB2 drives from Windows XP Device Manager then reboot the PC. This will let Windows XP re-install the drivers. In time they do get corrupted for USB/2 as do other drivers. Some MAXTOR drives do come with drivers but XP should see your MAXTOR drive.

    You can always use a different defrag,,

    under start, then run type : cmd
    then type: defrag e:/ f (e: would be an example for your MAXTOR USB2)
  5. des1fool

    des1fool TS Rookie Topic Starter

    I tired both methods. It was unsucessful and the extention E C etc wasn't even active. For some reason when having this harddrive attached to my comp it makes MANY tasks not respond. I need somekind of diagnostic software or something to keep from removing all of my valueable data. Anything will help thanks!
  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    What does your event viewer have to say?

    Start > Run > eventvwr.msc

    Look under the "System" area for obvious warnings, such as I/O, block and sector errors.

    I've personally owned a number of enclosures. A few of which, since the first day, did not work properly with inconsistent slowness and problems getting the drives to actually spin or be recognized at times. This also included difficulty 'loading' partitions in Windows, taking 1-4 minutes to assign drive letters and so on. Maybe you enclosure is on its way out?

    A good way to determine if the drive is bad, which may have already been mentioned, is to remove the drive from the enclosure and install it internally into your computer. Next, run the manufacturer's diagnostic on it and see what happens. :)
  7. des1fool

    des1fool TS Rookie Topic Starter

    I checked the Event Viewer and there where multiple warnings about disk such as "An error was detected on device \Device\Harddisk5\D during a paging operation." and a error "The device, \Device\Harddisk5\D, has a bad block." So what do you think is it my enclosure or my drive?? Do you recommend me trying another drive before I completely replace it??
  8. des1fool

    des1fool TS Rookie Topic Starter

    Just an Update I tried a Western Digital WD400 Caviar and It does work so I guess the enclousure is not to blame.....
  9. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    These are common drive problems. Not to say an enclosure can't be to blame, but you should definitely check out that drive.
  10. des1fool

    des1fool TS Rookie Topic Starter

    Hi all! I actually did take the drive and plug it into my comp and took out one of the cd drive cables and it is a failed drive. It lets me listen to the music files on it but Does not let me copy any of them. I ran the error checker and it passed off as healthy and usable drive, I can view some .txt files when i click on it in the windows explorer but when I try to copy a media file it gives me a cyric redundincy check.
    Please advise!
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,243   +234

    Go back and look at my reply to your previous post on this same subject
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...