vanished c drive

By kate.tompkins ยท 11 replies
Mar 12, 2005
  1. win95 osr kept losing files so I formatted the c drive. Big mistake. When I rebooted I had an A drive, the cd rom was assigned to C and absolutely nothing else. I tried fdisk but all I got was "error reading fixed disk." In fact everything has a problem FINDING a fixed disk. Tried fdisk/mbr and learned the the master boot disk could not be updated. Tried fdisk/cmbr and was told that I had to assign a drive..WHICH I DON'T HAVE!!!!

    WHAT DO I DO ???

    Anybody out there have any idea?

    Many thanks for listening

  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Welcome to TechSpot

    How did you format it?

    Is it still recognized when you turn on the computer?
  3. kate.tompkins

    kate.tompkins TS Rookie Topic Starter

    1. At A:\ I typed format C: Got message "all information will be lost" Thought this was fine as I'd done it before and it worked for me. Not this time.

    2. If you mean does computer still recognise that I have a hard-drive..I guess so. It says that C: is the cd-rom and that there is no other valid drive specification. Apparently its not allocated, not just missing or damaged.

    3. You can probably tell that I am not exactly technologically advanced but I have done this thing twice before and had no expectation that it would all fall in a screaming heap this time.

    4. Is there something I can do to the BIOS that would help?

    Thanks for being there

  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Did "format c:" report any bad sectors? That "error reading fixed disk" could indicate physical problems with the disk. It could be that the drive is about to fail, or just that connectors are loose.

    In any case, you could try low level format utilities.
  5. joshuaCHedges

    joshuaCHedges TS Rookie

    Try the following.

    You mentioned the BIOS. The first thing to check is that the system still recognises that you actually have a harddisk. Go into the BIOS to do this.

    AMI BIOS key press is 'del'. A lot of the other BIOs's now use this, but if that key press does not work try 'F10' for Compaq, 'F2' or 'Shift+F2', 'Shift+Esc'.

    If the BIOS does not see the harddisk try auto-detecting it. Most BIOS's have this option.

    If the system does not see the Harddisk you will need to check the connections on the IDE cable. Listen to the harddisk when you turn on the computer. It should initialise and make a noise. Listen to a working one to recognise the noise pattern.

    Do NOT do a low-level format on an IDE hardisk, it is very likely that it will not work correctly and the disk will be ruined forever.

    If fdisk does not see any fixed disks when you run it, then it is not working. You could try it another computer, but that would mean setting the jumper(s) on the drive correctly. Do you know what make and model of harddisk it is?

    If you have gone through everything and you still have no luck then get hold of a set of boot installation disks for NT4 or W2k. There are 4 in the set. It does not matter that you don't have or are not installing either of these operating systems. When you boot with these & go through the start of the installation you will get the chance to view, delete & create partitions.

    If you want a set of these disks, I can e-Mail you a zipped file with the disk images and the program(s) to make them. The zipped file is 3.39MB

    Good luck :grinthumb
  6. kate.tompkins

    kate.tompkins TS Rookie Topic Starter

    Bios screen "Bios CMOS Setup" tells me that I have a Primary master and a Secondary Master.
    "Bios Features" looks pretty much the same as it always did
    "Chipst Features" only has 3 entries ( Dram Data, Memory Hole and AGP aperture)....don't think this was the case earlier but I could be wrong.
    "PNP/PCI Configuration" has PNP OS, Resources Controlled By and Reset Configuration (disabled)

    On startup there's any entry against Primary Master - LBA, EDMA2, 15021mb
    against Secondary Master - CD Rom UDMA2

    CPU = Pentium III - MMX,
    Hard Disk is a Quantum FireballICT10 15, Version AO3.0900

    Read somewhere that disabling the BIOS on the motherboard will reset it to factory default. Is this true? Is it worth trying? (Not me, someone who knows what they're doing - of course).

    The wretched disk is there. Just nothing I've tried seems able to access it. Could be a loose connection I suppose but if it is it will just have to wait until someone drops by who can check it for. Oh well, such is life!

    Believe me, I really appreciate that there are people out there willing to give me some of their precious time and advice.

    thanks heaps

  7. kate.tompkins

    kate.tompkins TS Rookie Topic Starter

    Guess what!

    It's back. It's back. It's back
    Don't know where it's been or why it decided to reappear. But it IS back.

    Thank you, thank you, thank you.

  8. joshuaCHedges

    joshuaCHedges TS Rookie

    Welcome back 'C' Drive!!

    So tell us what you did. Did you change anything??
  9. kate.tompkins

    kate.tompkins TS Rookie Topic Starter

    What did I do?

    I'm not entirely sure.

    Changed the USB Keyboard thingy to enabled....ran the debug thingy (got nothing but error messages mostly). Turned the wretched thing off for a few hours.
    Was so excited when it came back. Now I'm finding that the C drive only has about 2gb and the rest of the memory is "unallocated"

    Is this how its supposed to be? If not, what do I do about it?

    Aint Life Grand

  10. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You created a FAT16 partition. If you get the question "enable large drive support" in fdisk, you should answer "yes" to get FAT32 support and bigger partitions.
  11. kate.tompkins

    kate.tompkins TS Rookie Topic Starter

    Well look who's back.

    You probably thought I'd fixed everything. No such luck!

    Yes, I have a C drive and even a D drive.

    Have reformatted the C drive. Ran Scandisk.

    Message - "Scandisk encountered a data error while reading root directory entry number 0.
    This error prevents Scandisk from fixing this drive."


    Am getting really discouraged..or mabe I'm just coming down with some bug.

    Any ideas?

  12. joshuaCHedges

    joshuaCHedges TS Rookie

    Disk Problems

    I would be tempted to scrap the partitions again and re-create with at least FAT32, as stated above, so that you can get the largest size.

    What operating system are you installing? If you have a NT operating system (that is; NT4, W2k, XP) then install that and delete and create the partitions during the install.

    This problem sounds like the harddisk has become damaged. What is the make and model?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...