1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

VERY strange Seagate HDD problem - cannot detect on cold boot, but detects on reboot

By crice ยท 8 replies
Mar 22, 2005
  1. Here's my strange problem:

    I have a 120gb Seagate HDD that I use for backup storage. I have been using the drive for about 5 months now without a problem. One day I booted it up and realized that BIOS did not detect it. It is currently SECONDARY SLAVE. The strange part is, once I get into winxp, it sees the drive - albeit in PIO ONLY mode instead of DMA. Once I do a reboot (NOT A COMPLETE SHUTDOWN), BIOS sees the drive and it functions normally again - winxp sees the drive as correctly functioning and in DMA mode.

    What's strange is that once I start up the computer from a cold boot, go into BIOS, and check what devices are where, BIOS does not see anything in secondary slave at first. Once, I do an "auto detect" it picks up the info on my HDD and it works fine.

    I've tried flashing the BIOS and the problem persists. HOWEVER, the drive works fine as secondary MASTER. I swapped my sec. slave and master and the setup works fine. The device that I put into slave (a liteon 811s dvd writer) detects correctly and works fine in windows. I just have no idea why the seagate drive does not detect at first boot.

    Here are my specs:
    pentium 4 2.4
    EliteGroup L4S8A2 mobo latest 1.0E BIOS
    PRIMARY MASTER: maxtor 80gb
    PRIMARY SLAVE: seagate 80gb
    SECONDARY MASTER: liteon 811s
    SECONDARY SLAVE: seagate 120gb (problem drive)
    OS: WinXP Pro SP1

    Please provide any feedback, this is driving me crazy!
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    A big drive like that 120G requires an 80-wire IDE flat-cable. It will run on a 40-wire cable but only at a reduced rate. Being on the same cable as a CD, reduces the HD to the DMA/PIO level of that CD.
    The CD-drive only needs a 40-wire and will probably not even function with an 80-wire cable.
    So unless you get another PCI-IDE controller, you will have some speed and/or compatibility problems.
    Make that 120GB master and run that CD as slave, since that works (as you say).
  3. crice

    crice TS Rookie Topic Starter

    Oh wow, thanks!

    Will there be any problems with setting the DVDwriter to Slave? Of all the cd/dvd writers that I have installed in the past, all of the instructions say that you "should" put the writer as MASTER. Any possible problems with it as slave?

    Also, how the heck did it work before?! and how does rebooting remedy this problem?

    EDIT: Ah, that makes a lot of sense now. I am checking the device settings for the HD right now (the DMA/PIO part) and it says that it is "MULTIWORD DMA MODE 2". The DVD writer is currently "ULTRA DMA MODE 2". DVD Writer is master and HDD is slave.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,452   +7

    Looks like your hard drive too long to spin up and it doesn't respond to the first queries by BIOS.
    There should be an option in the BIOS to set IDE HDD detection delay. Set it to 10 seconds to give your HD time to spin up.
  5. crice

    crice TS Rookie Topic Starter

    Unfortunately I do not think my BIOS has this option! I believe I am running PhoenixBIOS
  6. BurningWaste

    BurningWaste TS Rookie

    Hi Guys!

    I actually signed up just because of this post! My words to you: YOUR NOT ALONE!!

    Really, I have exactly the same problem with a Seagate HDD: Momentus 4200.2 80Gb. This time I have little options. It is 'n laptop's drive, and it worked for about a year now with no probs. But suddenly this symtoms started showing.

    When I boot the laptop it don't detect the drive, then I hit: Ctrl+Alt+Del and it words fine. Sometimes I have to hit it a few times before it detect again. I have checked for virusses, but the drive is totally fine, no bad sectors or corrupted stuff.

    Is this the HDD or the BIOS? Cause when you use the HDD in another laptop it is fine, and when you use another HDD in this laptop it is also fine....

    I am concidering buying a new drive, but really it's a waste, the old one is not really broken.

    Hope some Seagate Techie can shine some light on the subject...
  7. k.jacko

    k.jacko TS Rookie Posts: 483

    I think as already mentioned by nodsu the drive seems to be taking too long to spin up and thus is not found in time by the bios. Soft reboots don't spin the disks down to a stop so it will be recognised.
    You may not have bad sectors with your hdd etc, but maybe the motor is on its way out.
    crice: your cd drive should work with 80-pin cable, but will not run at the higher speed. And as RealBlackStuff said, you will have speed issues with a hdd and a rom drive on the same ide controller.
  8. BurningWaste

    BurningWaste TS Rookie

    And sadly but true, after a while my HDD has died. It have completely stopped working. The PC still detects it on reboot, but when I try to do 'n "dir" it never shows up (PC hangs). So to all who have this type of problem, of a drive working and then later not working except with rebooting, your drive is dying! Backup!!
  9. johnnycake

    johnnycake TS Rookie

    turned off fast POST

    Thank you for the insight into this frustrating problem. Hard boot wouldn't detect the HDD, a soft reboot usually would. It does seem to have to do with giving the HDD time to get up to speed. Although my setup program doesn't have an option for length of the HDD detection delay, turning off fast POST seems to do the trick. That option causes a very long memory test, but cancelling the memory test results in the HDD once again not being recognized, so apparently while the memory is being tested the HDD is getting itself into shape to be recognized. With fast POST turned off and enduring the long memory test, a hard boot is always successful.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...