Spread the love! TechSpot Tech Gift Shortlist 2017

Viamraid.sys causing BSOD's

By ryboto ยท 15 replies
Jul 30, 2006
  1. So, I've had my current setup, minus the 150gb raptor and 320GB caviar drives for a year.
    A64 3700
    Abit AV8
    Mushkin XP4400 DDR550 1GB
    NEC 3250A, generic dvd-rom
    Ati x800 pro
    D-link AG 530 wireless card
    and the hard drives.

    At one point I attempted to install an AX8, but was presented with random bsods, much like I am having now. I have tested all the components, hdds, cpu, memory, wireless card/video card on other computers, and never have instabilities, never have errors. I used crystal cpuid to overclock and set up a user defined Cool n Quiet. Currently I'm using it, as I had been for the 5 months before I attempted installing the AX8. Now, after a month of running overclocked, I am getting bsod's at random times. At first, they happened inconsistently during BF2, maybe i'd play 5 times in a week, and it would happen twice during play. Now, it doesn't seem limited to bf2. When I would get the bsod in bf2, the blue screen would show me garbled text, I couldn't read the stop code, and there was no save dump. Now, I seem to get the bsods during regular use, and the stop code 0x100000d1 seems most common, as well, it's readable, and it references the file viamraid.sys as the problem. I've reinstalled the driver, a few minutes ago, but still, I'm wondering if anyone has any insight into this issue.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    This is the meaning of your stop code.


    The system attempted to access pageable memory using a kernel process IRQL that was too high. The most typical cause is a bad device driver (one that uses improper addresses). It can also be caused by caused by faulty or mismatched RAM, or a damaged pagefile.

    Try getting rid of the overclock and see if your system becomes stable.

    If it doesn`t, you may have a ram/page file/psu problem.

    Go HERE and follow the instructions.

    Regards Howard :)
  3. ryboto

    ryboto TS Rookie Topic Starter Posts: 34

    it's behaved normally since i reinstalled the driver, I'll clear the pagefile if it happens again. The PSU is an Enermax 485W Psu, a month old, thanks to RMA replacement.
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    That`s excellent news.

    Thanks for letting us know.

    Regards Howard :)
  5. ryboto

    ryboto TS Rookie Topic Starter Posts: 34

    i guess i spoke too soon. I got the same stop code, but it referenced atapi.sys as the issue. So, I'm going to clear the pagefile, and see if that makes a difference.
  6. ryboto

    ryboto TS Rookie Topic Starter Posts: 34

    so, i cleared the pagefile, reset it, and played bf2 yesterday. Stopped playing when the game so reliably crashed, and started cleaning up some files, as I was doing this, the system halted, and i was presented with a garbled blue screen. I could barely make out that it was in reference to atapi.sys again. I've also noticed that these issues only seem to happen on humid days. Could humidity be causing this? or would the errors be more random?
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    It is possible you have an overheating problem, you should monitor your system temps. Did you test your ram with Memtest86+? If not, I suggest you do so.

    Post more minidumps from any recent crashes and I`ll take a look and see if I can find a culprit.

    Regards Howard :)
  8. ryboto

    ryboto TS Rookie Topic Starter Posts: 34

    I have ran memtest many many times, these modules are rock solid. Last month I ran memtest for 15 hours, and had zero errors. As for savedumps, the problem is, is that every other blue screen is garbled, the garbled stops aren't logged with save dumps.
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I see your problem with the dump files.

    Please be aware, some ram can pass Memtest.

    Have you got rid of the overclock? If not, you should do so.

    Have you checked your system tempt?

    Regards Howard :)

    Edit: Try reinstalling the Viamraid.sys driver again.
  10. ryboto

    ryboto TS Rookie Topic Starter Posts: 34

    I have great faith in my ram. Not only did I run mentest 86, I ran HCI's memtest in windows, as well as prime95, all at the current settings, and all for a lengthly amount of time. I'm still running the overclock...sorta lazy about resetting it. My cpu idles around 30C, gets as high as 49C under heavy load. The chipset stays a few degrees below the cpu. Hard disks are between 35-40C.

    edit: and the first thing I did, outside of reset the pagefile, was reinstall the via driver.
  11. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Until you get rid of the overclock, there`s not a lot I can do.

    It may well be it`s the overclock that`s causing your problems.

    Regards Howard :)
  12. ryboto

    ryboto TS Rookie Topic Starter Posts: 34

    i've been doing some testing, as I keep getitng blue screens. They typically only occur during gameplay(BF2). And when they occur, they always appear garbled. I can barely make out that it is referring to atapi.sys as the file causing issues. It's always this file. I ran memtest86 again, after bumping voltages up just a tiny bit, and it was stable overnight. I've been running prime95 torture test since last night around 10:30, so it's been running for around 19 hours. Not sure if I am running the right test, or what. Prior to that I ran two instances of superpi32M. I haven't had a blue screen once during the testing, only during gameplay. The testing is stressing the cpu a lot more than gameplay does. The cpu sensor says 55C under Prime95 load, under gaming load, it rarely gets as high as 49C. So, I'm thinking it could be my video card, or, possibly something else that is stressed during gameplay, but not during stress testing.
  13. dan56965

    dan56965 TS Rookie


    Hi, just though I'd post this for reference, as it's taken me about a day to fix this frustrating issue...

    Background info:
    -Windows xp, SP3
    -SATA I drive, 250GB
    -old IDE drive 80GB

    Just decided to format pc, so backed up stuff to the 80GB drive. Plan was to install xp onto the SATA. Prior to the format, everything was working fine, and I was already using the same drivers as I would afterwards.
    After the format, I began to encounter problems:

    -After installing the SATA driver, and trying to transfer data across, I got whole system freezes for a second or so at a time. This was as the hard drive sounded like it was repeatedly spinning up.
    -Under heavy load, I got a blue screen of death, with the message "DRIVER_IRQL_NOT_LESS...viamraid.sys". This happened every time, without fail.

    For me, it turned out that windows had decided to write the master boot record and boot.ini to the old drive. Exactly why that caused the problem, I'm not sure, but presumably the viamraid.sys driver didn't have permission to access the data, and xp wrongly accused the SATA driver of accessing invalid memory addresses.

    A quick check to see if you share the same issue might be to go:
    Start>>Run, type "msconfig", and click 'ok'. If there's no mention of 'boot.ini' anywhere on the resulting window, then you may have the same problem.

    Anyway, the solution, was 'simply' to reinstall the whole OS, having disconnected the IDE drive for the duration. There's probably an easier way to do it, but I had no luck using the recovery console and 'fixmbr'.

    Hope this is some use!
  14. Stash00

    Stash00 TS Rookie

    Alternatives to format/reinstall (Testing by now)

    I've done this to avoid this process on my system. By now I'm on testing as BSOD appeared randomly so it may be not usefull as expected. I will report success/fail next week.

    Updating VIA drivers (viamraid.sys) did not make any difference on the problem. Formatting was the last option. Memcheck did not show any memory problem. Hardisks test were succesfull. Case an CPU temp were normal.

    In my case after analyzing several crash dumps (WinDBG with full memory dump) discovered that there were always a process attached involved in crash.
    Viamraid.sys is not guilty, IMHO.

    Even disabling it as service I found it loaded.
    This process is owned by adobe products (Photoshop, Acrobat, etc.). They load/launch the executable even when marked as disabled service.

    How to remove:
    I suggest to rename files instead deleting them for rollback purposes.
    Some file paths may be different on your computer

    1) In task manager
    1.- Close/kill any adobe program/process
    2.- Kill FNPLicensingService.exe

    2) Search for FNP_Act_Installer.dll. There will be several copies. Rename all to FNP_Act_Installer.dll_old

    3) Search for AcrobatInfo.exe. Usually on C:\[program files]\Adobe\Acrobat 8.0\Acrobat\AcrobatInfo.exe. Rename to AcrobatInfo.exe_old

    4) Find FNPLicensingService.exe on your PC and rename to FNPLicensingService.exe_old. Usually on C:\Program Files\Common files\Macrovision Shared\Flexnet Publisher.

    This will no load any flexnet FNPLicensing when any Adobe product loads. If you have any issue regarding licensing for registered Adobe Product, rollback changes made and contact Adobe support.

    Hope this help.
  15. Kerb

    Kerb TS Rookie

    Hi, i'm getting same issues, is there any available fix to these viamraid.sys driver? i couldn't find any stable for Win XP, tryied versions from 3.10 (5.1.2600.310) up to 5.80 (5.1.2600.580)
    but all of em doing BSOD, rev 3.10 up to 5.50 doing random 0x0A (IRQL_NOT_LESS_OR_EQUAL) BSOD, but even if bsod doesnt says viamraid.sys, analyze of memmory dump shows it, rev 5.60+ have also 0x0A , but it also got new one 0xD1 where it says that file.
    ive tryied to find any stable driver but i hadnt luck. ive founded only temp hack to load driver out of ntkrnlpa so system is stable now, but it have its cost (about 2/3 max speed and high cpu usage while read/move/copy/etc..)
    anyone finded some better solution to this for WIn XP 32-bit? on win98/me/vista/win7 or xp 64-bit, there arent any bsod, so its only xp-32bit related (for me)
    btw my device is VT6421
    thx for answers (if any) :)
  16. gow

    gow TS Rookie


    According to VIA's website, version 5.50b is the last stable driver you can use with the VT6421 Raid Controller. This controller is not supported from version 5.60 onwards.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...