Vista Drivers Not Working

By cfitzarl
Apr 10, 2007
  1. Hi! :D

    I had another post about some nvidia drivers not working, but that's a different story that plays into this one somewhat :( . Okay, when I installed Windows Vista Ultimate, I had two options.....(GeForce 7900GS)......and [GeForce 7900GS (Windows and a bunch of letters)]. both had the correct signing, but the second one (with the long name) reported that I was using turbocache (256Mb dedicated, 255Mb shared) with a total of 511Mb....and I know that's wrong, but my games and applications ran on it. The other one reported the correct amount of memory, but any intensive applications including games, and screensavers would cause a BSOD, and the computer would restart itself. I wanted to overclock with RivaTuner as I did in Xp, but the driver wouldn't allow it to happen, so I downloaded the latest nvidia drivers from the official website and in the middle of installation, the screen went blank, and lost it's range....I had to go in safe mode to disable it, and then use one of the working drivers. SNGX linked me another forceware version that worked, but wouldn't allow my resolution above 1024x768....which I don't use on my lcd screen, as the native is 1280x1024. I enabled the option to show resolutions not capable of the monitor, and even switched around the monitor drivers from Generic non-PhP Monitor to Generic PhP Monitor to Flat Panel (1280x1024), and none of them worked. I went into the nvidia control panel and had no luck either. I googled my problem and came up with a solution to another Vista Build and that was it. I'm becoming slightly frustrated, so any help would be much appreciated :wave: !


    Here's a pic of the available drivers in my system:


    The driver that did work, but showed too much memory was erased during an uninstall of nvidia drivers.
  2. cfitzarl

    cfitzarl TechSpot Chancellor Topic Starter Posts: 1,975   +9

    I have never done this before, and I hate to;


    Desperate times call for desperate measures ;)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...