WAN IP problem

By fpinkney ยท 7 replies
May 22, 2004
  1. I have a home network with 5 or 6 PCs on it (depends on notebook connected).

    Router is a wired SMC Barricade and all the PCs (except notebook) use Win 98SE. All the connectivity has been working well for some time (>1 year). However my daughter's computer lost connectivity with the lan and wan recently while I was out of town - she tried to correct this by stumbling through the internet and network settings in control panel. Because the disconnect was so complete I replaced her network card (d-link rev A) with a d-link rev C. This successfully brought back LAN connectivity but not WAN - at least not http. I can ping other LAN computers, the router and external URLs but I cannot get anywhere with IE explorer or Outlook (full or express).

    I've confirmed that all settings are consistent with the other computers on the LAN but feel I must be missing something. Her permissions and firewall settings are fine and the problem persists no matter how generous I am with permissions or firewall off. I've also tried specifying DNS, Gateway etc in all combinations. TCP/IP is the only protocol enabled (Netbios is checked).

    I dread re-installing windows but I feel I've run out of options.

    Any ideas obvious or not would be appreciated.

    Sorry for the length!
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Welcome to TechSpot

    How does she log on, using "Windows Logon" or "Client for Microsoft"? You need the Client installed to get on the network.
    Check that your Workgroup name is the same as all the other PCs and that her Username/PCname is unique.

    What are the exact settings you are using?
  3. fpinkney

    fpinkney TS Rookie Topic Starter

    Thanks for the response.

    I've tried all the "normal" tweaks etc including different combinations of settings and reinstalling NIC drivers. I've tried moving her connection on the switch, changing her name, resetting the switch/router and powering it off and on. She does show on the router's status menu and she can ping the switch (as well as internal and external addresses) but she can't access it's web interface.

    Here are the details you requested. It's relatively early here and she worked last night so this is from memory, nonetheless, I've been at this a long time and the only bits I'm lacking are a couple of settings for the NIC advanced features - but I have gone through all the settings and combinations.

    She uses Windows Logon and Client for Microsoft is installed.

    Other settings:

    Same Workgroup - and can access other PCs in LAN

    TCP/IP Settings:

    IP Address: Obtain Automatically
    WINS Config: use DHCP
    Gateway: Not specified
    DNS Config: DisableDNS
    Netbios: Greyed check
    Advanced: Binding to ATM: No
    Bindings: Client for Microsoft Network, File and Print share

    Client for Microsoft Networks Properties

    Logon Validation: Not selected
    Network Logon Option: Logon and Restore


    Driver Type: Enhance NDIS (only option)
    Bindings: TCP/IP


    Autonegotiate: On (also tried 10 full duplex)
    Network Address: Not present
    Rx Buffer: 64
    Tx Buffer: 64

    Thanks again

    frank p
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You should change the Logon to "Client for Microsoft Networks".
    In TCP/IP properties: set WINS = disabled
    Other than that, I can't see anything wrong.
    My home-network has 3x Win2K and 1x Win98, broadband via a Router.
    However, I use fixed IPs for all PCs in the range of - 110 and all on subnet mask
    Their default gateway and the first DNS-server are both the IP of my router (which is, the second DNS-server is blank, and my network-printer has
    The WAN-part has my Service-provider's IP and Subnet, as well as DNS-IPs.
    Try this if all else fails.
  5. fpinkney

    fpinkney TS Rookie Topic Starter

    Thanks rbs

    I don't think changing the Logon will impact much but it can't hurt to try.

    I'll give the DNS setting a shot and if that fails I'll try hard coding addresses like you suggested.

    I think it is probably something more subtle (I even tried implementing backup wsock files - to no avail). I'm sensing that a Windows re-install is in my future. Sigh...

    I'll post any results.

    Hope your weather is as nice as it is in Ottawa right now.


    frank p
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Your Winsock 2 maybe corrupted Give this a try http://support.earthlink.net/mu/1/psc/img/walkthroughs/windows_9x_nt/dialers/dun_1.3/5289.psc.html

    or download this and it will do it automatically
    Winsock2 Fix

    LSP-Fix is a free utility to repair a specific type of problem associated with certain Internet software. This type of software is known as a Layered Service Provider or LSP, a piece of software that can be inserted into the Windows TCP/IP handler like a link in a chain. However, due to bugs in the LSP software or deletion of the software, this chain can get broken, rendering the user unable to access the Internet.

    Unfortunately, this type of software is sometimes quietly installed by unrelated software such as file-sharing programs, sneaking onto a system unannounced. In fact, in many cases, the user does not know of its existance until something goes wrong, and he/she can no longer access Web sites. Common offenders include New.net* (NEWDOTNET) and WebHancer*, which are often bundled with file-sharing utilities, DVD player software, and other free downloads. LSP-Fix repairs the Winsock LSP chain by removing the entries left behind when LSP software is removed by hand (or when errors in the software itself break the LSP chain), and removing any gaps in the chain.

    LSP-Fix is not a malware removal utility and does not target specific products. LSP-Fix does not delete any files.

    Open Network Properties
    Delete all protocols and everything else except the Network card
    Click Apply
    Close the Properties wincow
    Click the Cancel button if it asks if you want to reboot

    Start > Run regedit
    backup registry first
    delete the following keys


    Open Network Properties
    Click ADD > PROTOCOL > Microsoft > TCPIP and this should Add Client for MS Networks

    Reboot and be ready to insert your OS installation CD

    or download this and it will do it automatically
    Winsock2 Fix
  7. fpinkney

    fpinkney TS Rookie Topic Starter


    Got it - thanks! Used the detailed brute force do-it-yourself way (w2fix didn't work - probably finger problems).

    I'm almost grateful enough to drink a Guinness - but as I've never acquired the taste (sorry) I'll by one for a couple of friends instead!


    thanks again.
  8. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I have bad luck with Winsock2 repair programs, but when I do it manually, it seems to always work.

    That's what I was thinking your probelm was too. Many spywares can cause this kind of Windows damage, so you may want to also scan her computer using some anti-spyware programs such as ad-aware or spybot.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...