Warcraft III Crash

By LaNdo · 21 replies
Sep 28, 2003
  1. When I'm playing Warcraft III, this message appears a lot:

    This application has encountered a critical error:


    Program: c:\program files\warcraf iii\war3.exe
    Exception: 0xC0000005 (ACCESS_VIOLATION) at 001B:6F08FDF8

    The instruction at '0x6F08FDF8'referenced memory at '0x6E6A755'.
    The memory could not be 'read'

    Press OK to terminate the application

    This happens at totally random, can anyone tell me what's wrong? Thx.
  2. PreservedSwine

    PreservedSwine TS Rookie Posts: 325

    Is your system overclocked at all?

    What are your system specs?
  3. LaNdo

    LaNdo TS Rookie Topic Starter

    No... not overclocked... GeForce 4 MX 420 64 MB,1.2 Ghz Amd Thunderbird, 1X 256 MB SDRAM 133 Mhz and 1X 512 MB SDRAM 133 Mhz,40 GB HD, but I'm not quite sure about the Motherboard...
  4. LaNdo

    LaNdo TS Rookie Topic Starter

    Plz help me...
  5. Steg

    Steg TS Rookie Posts: 269

    er - sounds like maybe one of ur ram sticks has gone - take one out and try again to c wot happens - if that doesnt work take the other one out
    does this happen in every game? or just War3? if its just War3? then the HHD sector its installed on might b bad

  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Does this happen with any other games or during normal operation?

    Access violations like these are usually caused by memory or poorly made software... And I can say that my Warcraft III never crashes. =P

    Of course, keep an open mind as this can be caused SO MANY different things.

    You can test your memory using this: www.memtest86.com
  7. LaNdo

    LaNdo TS Rookie Topic Starter

    Err... This only happens in war3...
  8. StormBringer

    StormBringer TS Maniac Posts: 2,244

    What version of WC3 do you have? I remember getting that a couple of times until I updated it, It wasn't as often as you are experiencing, but still....
  9. conradguerrero

    conradguerrero TS Rookie Posts: 310

    haha i also experience that error occasionally... happened two times last week, i belive its application specific as i run all these other games and never get any errors.
  10. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,978   +15

    I get that error alot too. im not ocing bla bla bla :D

    its a conflict in the maps with the latest patch.

    it happens to maps made before 1.10 i believe, they dont seem to like 1.11 and 1.12 :mad:
  11. Dantrag

    Dantrag TS Enthusiast Posts: 135

    yeah there are map probs but we had the same prob on the lan and that was before 1.10 i'm talking 1.06 and earlier we formatted it and havn't had any probs since
  12. LaNdo

    LaNdo TS Rookie Topic Starter

    Errrr... I don't think it's a map problem, 'coz I get this in campaign mode too...

    If it helps, I'm also in a little trouble with bluescreens... not only in War3...
  13. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,978   +15

    I cant think of how formatting could ever help.. i was playing online, this happened to me, and everyone else in the game (was in the game with a bunch of friends). I've reinstalled WC3 countless times, over nocd crack reasons, and its never gone away :( I wouldnt mind some 'help' either :p
  14. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Formatting doesn't solve anything, it may rid you of the problem, but it will likely return and then what.....
    You'll be in the same situation as before.

    Oh, I'll ask again what version this is you are having the problems with?

    Agissi, I also had issues when I was using the no cd patch, though mine were that I updated the game, got the patch for that version, but it didn't have one for the editor. I went back to using the CD to play. Playing without the CD was much faster but it left me unable to use the World Editor, or use any custom maps.
  15. LaNdo

    LaNdo TS Rookie Topic Starter

    I play it on Battle.net so I have the 1.12 version...
  16. LaNdo

    LaNdo TS Rookie Topic Starter

    Ok... here's the deal... When I bought the CPU it had one 256 MB SDRAM in it. Then, later, I bought an additional 512 MB. I removed the 256 MB and no crashes since then... And they lived happily ever after..:p ... Thx you guys..:grinthumb
  17. Aedak

    Aedak TS Rookie

    I had the same problem with mine until I manually set the Memory Timing for the ram in the Bios. Try to find out what the settings should be for your ram by going to the manufacturer's site.

    ie: mine were at 4-2-2-2 and warcraft crashed randomly with the same error...Then I changed them to 7-3-3-2.5 (they work on 6-3-3-2 also) and haven't had the problem since. Only now, I'm having a major video card issue which I'm going to address in another thread. -_-
  18. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,978   +15

    Just get a copy of World Editor (cracked) and it runs without the cd no problem.

    Also Ive always used the no-cd crack and all I play is custom maps.. Tower Defence, etc etc. You should be able to play Custom maps without a problem using the no-cd crack.

    Weird stuff about the RAM causing problems.. no way im messing with my timimgs or taking 256MBs out tho.
  19. Shorteef

    Shorteef TS Rookie


    Hello, I have fatal error 2 and don't know what to do..
    I read all the post but I don't understand anything.. >don't know if it's because I am a girl ;)
    I tried to update windows, war3.. almost everything but it doesn't work.
    I would like to try the ram thing by taking them out and putting them in again but could someone please tell me how to do so?
    And do you think that just copy your cd will make the fatal error go away?
    And what's up with the 6-2-4-3-2 something thing.. I don't understand anything of it, could someone please explain this to me?
    I had the fatel error for about 1 ½ year now.
    Since I had my new computer...
    A weird thing is when I remove my sound.. driver.. I don't get it so often as when its on..? how come?
    can any of you guys help me plz... :(
  20. Shorteef

    Shorteef TS Rookie


    and when you copy your game you can't play custom games or what????? :suspiciou
  21. SA-Headbanger

    SA-Headbanger TS Rookie

    ok this is an easy problem i got it too for a long time and it took me for ever to figure it out. If the game re-boots or re-boots your computer got to winupdate and make sure you have the latest update for your video card. it should fix it.
  22. DarkRedDevi1

    DarkRedDevi1 TS Rookie

    I have tried updating all of that, although its happening still... having these fatal errors every couple of games... running 1GB nvidia 8500gt i think.. 4gb ram, amd quadcore cpu.. ram is fine, tested it using cruicial scan (downloadable on the crucial website(decent ram sellers :p))

    uhmm havent overclocked this - although i could, its 20 degress cooler than what AMD Cpus can handle.. Any other suggestions? This error is just annoying me
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...