WARNING! Got a Worm From Registry Mechanic!, Now I can't open Windows (98SE)

By macx ยท 7 replies
Oct 18, 2005
  1. Saw the ad for Registry Mechanic on the main page of another large computer forum (is that what's being
    advertised on this Forum also!?), thought it should be a good idea to have that as it was advertised on the forum and therefore obviously approved, and highly rated
    by PCWorld.

    Downloaded it, paid for it, installed it and ran it.

    Then computer restarted and it required my product
    code to start Windows.

    Typed in product code, but says it's invalid.

    I called MS Support, they first gave me 2 different
    product codes to try to unlock Windows, neither worked.
    Then transferred to a Tech who said I had gotten a worm with Registry Mechanic which was the reason I was unable
    to access Windows.

    They worked with me for over 2 hours, including going
    back to and installing a backup registry created the day
    before this Registry Mechanic was installed, but I am still
    being blocked from starting Windows.

    They are going to work with me more tomorrow.

    Further, the Tech said emphatically that such tools
    should not be used on the registry, that it would
    only lead to problems, even without such a worm.

    A MOST unhappy experience from what should have
    been a trustworthy source!
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    hmmmm. when you say it required to to type the product code what code are you referring to? the product code for registry mechanic or windows?
  3. macx

    macx TS Evangelist Topic Starter Posts: 718

    Sorry, should have clarified.

    When the computer restarted after installation,
    it opened the Windows Setup Wizard where you
    type in the Windows product code.

    The code that came with the SE updates ~3 yrs
    ago and worked up till now was the one that the
    Wizard (or actually the worm per the MS Tech)
    says is invalid.

    MS Supt also gave me 2 other codes - must be
    "master" codes or something - to try to gain access
    to Windows but it said those were also invalid and
    it refused to open Windows. This was after they
    checked my product code and some little code on
    the inner lens of the 98SE Update CD (that I hadn't
    even realized was there) to verify it was valid
    and not a bootleg copy. It is a valid product code
    per their info.
  4. StormBringer

    StormBringer TS Maniac Posts: 2,244

    I've used Registry Mechanic quite a bit and never encountered anything like that. Sounds like you may have deleted some keys pertaining to product key info or something when you were fooling around with reg mechanic.

    Reg Mechanic, while more friendly than just using regedit, is still a powerful tool and can cause serious damage if you aren't careful.
  5. macx

    macx TS Evangelist Topic Starter Posts: 718

    All I did was download & install & run it.

    It came up with a number of I believe they were
    called serious and medium problems (wording?)
    which it recommended by "fixed" which I did.

    That's all I did - nothing more.

    I first ran the free version, "fixed" what it found,
    no problems. Of course, to "fix" everything it
    found, you have to buy the full version.

    It's after I ran the full, paid-for version that this
    problem surfaced.

    It certainly wouldn't call a needed part of the system/registry/whatever a serious or medium
    problem and recommend deleting it?
  6. meatologist

    meatologist TS Rookie Posts: 134

    System Restore !
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503


    read the post!
    Restore on a W98? Nah..
  8. meatologist

    meatologist TS Rookie Posts: 134

    oh ya. oops.

    soz :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...