Web "form" buttons don't work, no "all programs"

By Vigilante ยท 7 replies
Mar 5, 2005
  1. This one is interesting.

    When browsing the Internet with IE, all HTML "form" buttons do not work. Such as, for example, if you're on Google, you can't click to search. The buttons don't respond at all. This is the same for any button that is used with HTML form tags. Normal links and, say, images with a click function, still work. But not form buttons.

    Also, in start menu, the "All programs" link doesn't expand. The Start Menu shows up, with all icons and links, but click or hover on All Programs and it won't do anything.

    The system was clean as it relates to spyware/adware. However, using TrendMicros offline scanner, found over 250 copies of WORM_BAGLE.AZ. It cleaned them all. It just had a reload not long ago. He uses Netzero and Norton AV 2003.
    The virus may have caused it, not sure why NAV didn't find it except NAV sucks.

    So far I've tried using BHO captor, CWS, HJT, ad aware, spybot. Then I've re registered a handful of DLLs, checked the user folder settings in the registry.
    I mean, besides the virus, the system seems squeaky clean. And it's on XP.

    By the way, if I use Firefox, the form buttons work. So something in IE is jacked. And I've reloaded IE to no avail. But that doesn't explain why All Programs doesn't open.

    Any ideas? I did try a system restore, the only one usable, but it failed and couldn't use it.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    If your absolutely sure that the system is clean, no virii spyware etc then maybe a repair install might sort it out.

    Just a thought.

    Regards Howard :grinthumb
  3. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Well I always try to avoid the more drastic repair measures. I find that most problems can be fixed with nifty untilities, REG files, scripts, re-registering DLLs and that sort of thing.

    I feel like if I do a reload or something, then I'm giving up, plus that I'll never know how to fix it if it happens again.
    What sucks is that it just had a reload not long ago. And the system behaves perfectly well, no errors or anything. It's just that buttons don't work or the All Programs in the start menu.
    To me this sounds like a DLL problem or a registry key somewhere. Cause firefox works fine. And if you go into the profile directories, the startmenu folders work fine as well.

    The logic, to me anyway, is what part of IE could be messed up in such a way as it doesn't know how to handle clicking of a form button? While Firefox works fine. I've ran scripts that claim to reload IE off the original XP disk, but that didn't work. I then followed MS instruction to re-register ActiveX related DLLs. To no avail.

    Any other ideas?
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    sounds to me you still have a virsu, or a visrus you have since removed corrupted one of your XP dlls. System needs repair. The symtoms suggest IE has now got no rights to run VBscript and/or Javascript, either of which are commonly required to make buttons work.
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    The reason I suggested a repair is because it sounds to me that the virus trouble you had has screwed(corrupted) some files dll`s etc.

    Whilst it is quite possible that you could replace the faulty dll`s files etc. Finding exactly which ones are damaged could take a long time.

    Regards Howard :grinthumb
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  7. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Thanks for your replies.

    Last time I worked on it (yesterday), I went through some more MS procedures and some more online ideas from various forums and what not. Replacing files, reloading things, re-registering DLLs. With no luck.

    I reinstalled the Windows Scripting Host as well as Sun Java and those both work. I've gone through IE settings and reset everything to defaults all through it. Norton script blocking is OFF.

    Normally I might suspect a scripting problem but these are not vscript or jscript or flash buttons. They are just plain-jane HTML form buttons. Or I should say, "submit" buttons.
    I guess now I have to suspect something is wrong with cookies or sessions or security or some such thing. But IE is on 128bit encryption. And is the latest version.

    I'll be working on it again tomorrow. I'll post an HJT log if I can but I'd consider myself an expert on entry removal I've used the proggy for years. I'm just wondering what on earth could cause something like this? And have the rest of the system behave perfectly?

    He's just an old guy on dialup who only does E-mail and card games. It's not like he's a Kazaa file sharing, download crazy type of guy on high speed or something. So this was kind of a shock.

    My next step, if it still doesn't go away, is a repair install I suppose.

    I'll check your posts blackstuff and see if there's anything I missed. I'll write back here with my final solution when I figure it out. As my sig says!

    Thanks again.
  8. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Well after exhausting my resources, I broke down and did a repair install of XP SP2. And sure enough it cleared out the problem. But I just wish I could have found a fix for it.
    Oh well.

    This issue is closed!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...